Download it now!
Bug 32742 - Report builder not shows properties on report fields
Summary: Report builder not shows properties on report fields
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.3.0 RC2
Hardware: x86 (IA32) All
: medium normal
Assignee: Noel Power
URL:
Whiteboard:
Keywords:
: 32966 33363 (view as bug list)
Depends on:
Blocks: 32966
  Show dependency treegraph
 
Reported: 2010-12-30 07:29 UTC by Zoltán Reizinger
Modified: 2011-01-24 02:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zoltán Reizinger 2010-12-30 07:29:07 UTC
Open any existing database with report builder report with LibO 3.3RC2.
Open report for edit, select any data field, activate property browser.
Property browser not shows any content.

Click to label, only General Tab shows content, but extra tab in back-to the General tab.
 
Open report navigator select report, the General tab, and Data tab is shown, but extra tab in back-to the Data tab.

The report builder may be not updated after new version issued on extension site (1.2.1-rev2) on 14 December 2010 , which needs for 3.3 version. 

This is same on win7 and opensuse 11.3 32bit version in which I tested.
Comment 1 Yifan Jiang 2010-12-30 21:42:40 UTC
Reproduced on 3.3 RC2.

Hi Petr,

It is a regression problem introduced since beta3. LibO 3.3 Beta2 got this working well. I ran back over the history documents, and found we have brought a related fix in beta 3:

http://www.openoffice.org/issues/show_bug.cgi?id=114627

Can it be the culprit? The issue seems not good.
Comment 2 Petr Mladek 2011-01-10 05:31:33 UTC
Noel, could you please have a look at it?

I am sorry. I am somehow overloaded. I think that you solved similar problem in the past.
Comment 3 Alex Thurgood 2011-01-11 06:05:59 UTC
*** Bug 32966 has been marked as a duplicate of this bug. ***
Comment 4 Noel Power 2011-01-12 03:12:42 UTC
fixed on master
Comment 5 Noel Power 2011-01-24 02:58:21 UTC
*** Bug 33363 has been marked as a duplicate of this bug. ***