Bug 32754 - cannot enter symbol in visual editor
Summary: cannot enter symbol in visual editor
Status: CLOSED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
3.3.0 RC2
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-31 05:27 UTC by Regina Henschel
Modified: 2012-08-23 06:43 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2010-12-31 05:27:44 UTC
I have defined a symbol "prime" for character U+2032. No I will enter it using the new visual formula editor.

(1)
Entering
    f%prime(x)
does not resolve the symbol

(2)
Entering f and then clicking the symbol in the symbol catalog results in visual
    f prime
although the command window shows
    f %prime
That would resolve correctly after saving and reloading, but the visual formula should be correct immediately.

(3)
Entering f then blank then %prime still does not resolve the symbol but adds an additional unwanted ~ in the command window.

I can use f%prime(x) without problems in the command window, but not in the new visual mode.
Comment 1 Björn Michaelsen 2011-12-23 11:34:34 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 Florian Reisinger 2012-08-14 13:59:53 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 3 Florian Reisinger 2012-08-14 14:01:03 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 4 Florian Reisinger 2012-08-14 14:05:47 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 5 Florian Reisinger 2012-08-14 14:07:48 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 6 sasha.libreoffice 2012-08-22 09:30:20 UTC
nobody verified it. Changing to Unconfirmed
Comment 7 Rainer Bielefeld Retired 2012-08-22 12:07:58 UTC
Hi Regina, I already looked at this bug some time ago, but I did not want to admit that I did not understand how to reproduce it ;-)

I added a phone symbol to the Greek symbols and was able to add it directly to the formula in "Visual Editor" from catalog.

Your (1) IMHO can not work, ""alpha" in visual formula editor also will not show the Greek Letter

Your (2) means that you see a text "f prime" and not text "f " + your prime symbol? That works perfect for me with "LibreOffice 3.6.1.1  German UI/Locale [Build-ID:  4db6344] on German WIN7 Home Premium (64bit) and my phone symbol.

Can you please contribute some hints how I should try to reproduce your problem? A sample document containing your formula and may be some screenshots might help
Comment 8 Regina Henschel 2012-08-22 15:09:25 UTC
(In reply to comment #7)

> I added a phone symbol to the Greek symbols and was able to add it directly to
> the formula in "Visual Editor" from catalog.

"from catalog", that is it. You can only insert it, if you open the symbol catalog, select it there and click 'Insert'-button.

I have expected, that it would be possible to use the form with the % sign. But for those who want collecting the formula parts by clicking with the mouse it is OK with the catalog.

When the feature gets its help texts, it should be mentioned, that you must use the symbol catalog.

I'll close the issue.
Comment 9 sasha.libreoffice 2012-08-23 06:43:19 UTC
We should not forget that
Tools->Catalog->Edit->Help  has empty page (no Help). It is because this button added only in 3.6 version