Bug 32886 - recent documents list always blank with libreoffice
Summary: recent documents list always blank with libreoffice
Status: RESOLVED DUPLICATE of bug 46074
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.3.0 RC2
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2011-01-06 15:14 UTC by Mark
Modified: 2012-05-07 10:37 UTC (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark 2011-01-06 15:14:46 UTC
After reboot LibreOffice does not have list of recent documents. The list only exists if there are documents restored. It does not appear when I close LibreOffice, the shutdown and start again.
Comment 1 Yifan Jiang 2011-01-07 00:26:39 UTC
I can not reproduce the problem on 3.3 rc2 SLED 11 sp1. Both Recent Document menu items and the Open drop list in the home screen contain the recently opened items as expected.
Comment 2 ismalun 2011-02-01 07:50:04 UTC
Ich have the same Problem with LO 3,3.0 on Ubuntu 10.04: No list of recent documents.
Comment 3 LeMoyne Castle 2011-05-30 22:33:00 UTC
Works in current release 3.3.2 and master as of 28 May 2011.  Found this while looking for previous report of issue in Bug 37775.  
If working in 3.4 then would say its resolved.
Comment 4 LeMoyne Castle 2011-06-15 10:57:46 UTC
May be a special case report of the problem in Bug 37775 or 
may be a symptom of crash on exit. 
Marked as needinfo
@ Mark, ismalun 
Thanks for your report.  If this problem persists for you (whatever the version) please let us know the steps taken in opening, saving and closing the files.  
There are cases where the Recent Documents list may not get updated (thru Save As incl. initial Save, or when LibreOffice crashes on exit).  It would be great if you could take a look at Bug 37775 and see if that describes your problem.  
Is it that a full list of Recent Documents disappears for you or 
is it that documents don't get added to Recent list?  
Do restored documents appear and then disappear from Recent list?
Comment 5 Björn Michaelsen 2011-12-23 11:33:43 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 6 Björn Michaelsen 2011-12-23 16:59:56 UTC
needinfo keyword redundant by needinfo status.
Comment 7 Lance Haverkamp 2012-03-08 10:30:11 UTC
Still a problem with 3.5 final, at least in Linux (Xubuntu 11.10)
Comment 8 Mark 2012-03-08 13:35:06 UTC
I believe this may be related to migration of settings from one version to another. I had this problem too. Then I removed all settings of libreoffice, which turned out to be duplicated at more than one place so I actually could not determine which one Libreoffice was actually using. So I removed all of them and then the problem was gone.
Comment 9 Carlo Strata 2012-03-10 09:40:23 UTC
I also confirm that I had the same problem with:

- LibreOffice 3.5.1 both RC1 and RC2, linux, x86-64, RPM packages;
- on OpenSuSE 12.1, linux, x86-64, kernel-desktop 3.1.10-8;
- using kernel built-in nouveau nvidia driver;
- Intel Centrino EM64T dual core;
- nVidia GeForce 9500M GS with 512 kbyte dedicated video memory.

As Mark already said, I solve the trouble renaming my profile directory that I carry me on since OpenOffice.org... ;-)

So the problem disappear renaming / deleting the LibreOffice profile directory:
~/.config/libreoffice/3

simply in
~/.config/libreoffice/3.old

and letting LibreOffice creating a new clean one!

Carlo
Comment 10 Stephan Bergmann 2012-03-12 01:53:36 UTC

*** This bug has been marked as a duplicate of bug 46074 ***
Comment 11 Roman Eisele 2012-05-07 10:37:30 UTC
This is (at least at the surface) a UI issue, just like bug 46074, therefore changed the 'Component' field accordingly.