Bug 32894 - [Task] LibreOffice 3.3.1 release blockers / stoppers
Summary: [Task] LibreOffice 3.3.1 release blockers / stoppers
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 33249 33258 33355 33744 33785 34226
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-07 03:06 UTC by Michael Meeks
Modified: 2011-05-10 05:16 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Meeks 2011-01-07 03:06:51 UTC
This is the Meta issue to track the potential stoppers for the release of LibO
3.3.1.

If anyone wants to raise an Bug for the release, please add the Bug ID as
dependent Bug here to the Meta Bug in field "Depends on". Additionally please
leave a comment here why you want to declare that issue as a blocker for a.m.
release.
Comment 1 Michael Meeks 2011-01-07 03:12:41 UTC
the tracker bug for 3.3.0 is bug #31865
Comment 2 Volker Merschmann 2011-01-07 10:07:04 UTC
.
Comment 3 manj_k 2011-01-08 11:39:03 UTC
CC
Comment 4 Rainer Bielefeld Retired 2011-01-09 05:19:27 UTC
Nominate Bug 32329 - [MAILMEGE] E-Mail server connection fails
Comment 5 Michael Meeks 2011-01-13 03:59:13 UTC
Add 32930
Comment 6 Rainer Bielefeld Retired 2011-01-13 09:07:50 UTC
Nominating: Bug 31792 Mail Merge Wizard hangs
For me LibO can't replace OOo with this bug.
Comment 7 Michael Meeks 2011-01-17 03:58:54 UTC
Should consider fixing impress hang bug#32861
Comment 8 Andras Timar 2011-01-18 12:29:24 UTC
Nominating bug 33249: LibreOffice redirect contributors to OpenOffice.org
It has an l10n impact, too.
Comment 9 Andras Timar 2011-01-25 22:32:08 UTC
Nominating bug 33258
regardless of UI language always en wikihelp is launched
Comment 10 clio 2011-01-26 09:01:36 UTC
Please, consider bug 32575 (specific LibO bug) and http://qa.openoffice.org/issues/show_bug.cgi?id=108689 (and the bugs referenced there) - the Standard panel in the Basic IDE is broken - buttons Cut, Copy, Undo, Redo, Save not working properly.
Comment 11 Noel Power 2011-01-26 09:22:30 UTC
(In reply to comment #10)
> Please, consider bug 32575 (specific LibO bug) and
> http://qa.openoffice.org/issues/show_bug.cgi?id=108689 (and the bugs referenced
> there) - the Standard panel in the Basic IDE is broken - buttons Cut, Copy,
> Undo, Redo, Save not working properly.

I don't think something that has probably ( never ) been working at least according to the oracle bug ( since 2.2 ) could ever be considered a blocker?
Comment 12 clio 2011-01-26 13:47:48 UTC
I just filed the bug 33552 - Standard panel is broken in Basic IDE. IMHO, a fix wouldn't be risky, because the same commands work properly in the menu. Undo/Redo worked fine in 3.1.1, Cut/Copy seem to be older. The Save button not disabled on Windows after first save - not sure how old is this.
Comment 13 Michael Meeks 2011-01-28 07:48:28 UTC
perhaps 33655 too for Olivier.
Comment 14 Petr Mladek 2011-02-01 09:22:58 UTC
Added bug 33744. The BrOffice branding does always work on Linux.
Comment 15 Jesus Corrius 2011-02-02 06:34:01 UTC
I'd like to nominate bug 33785 as a blocker.
Comment 16 Don't use this account, use tml@iki.fi 2011-02-08 06:12:07 UTC
Nominating bug #31023. And when I say "nominate", I mean "suggest".
Comment 17 Cor Nouws 2011-02-08 15:58:50 UTC
Suggesting bug 33970 . Crash with roaming profiles of course is a no-go for our business users.
Comment 18 LucTur 2011-02-09 00:08:47 UTC
There are other severe crash or freezing bugs with .doc and .odt documents that are sure show stoppers for several professional users. Here is a suggestion (with test document):

https://bugs.freedesktop.org/show_bug.cgi?id=33894
Comment 19 Michael Meeks 2011-02-10 12:57:40 UTC
bug #32930 is specific to LangTool which we no longer bundle, and is thus dropped as a blocker.
Comment 20 vitriol 2011-02-13 09:59:56 UTC
Nominating Bug 34226. Regression from 3.3.0 final to 3.3.1 RC1
Comment 21 tester8 2011-02-13 12:08:29 UTC
to vitriol
You need not only wrote that you nominate some bug but also add it to the "Depends on".
Comment 22 vitriol 2011-02-13 12:12:09 UTC
Added bug 34226
Comment 23 Petr Mladek 2011-02-17 09:03:18 UTC
Created bug 34404 for LO-3.3.2 blockers.
Comment 24 Petr Mladek 2011-02-17 09:11:03 UTC
We fixed many bugs for LO-3.3.1 but did not manage to fix the bug 31792, bug 32861, and bug 32895. Neither of them is serious enough to block the 3.3.1 release. Let's move them for the LO-3.3.2 release.
Comment 25 Gökçen Eraslan 2011-02-20 23:58:45 UTC
(In reply to comment #24)
> We fixed many bugs for LO-3.3.1 but did not manage to fix the bug 31792, bug
> 32861, and bug 32895. Neither of them is serious enough to block the 3.3.1
> release. Let's move them for the LO-3.3.2 release.

What about bug 33189 ? In many languages, print dialog in Calc has missing parts like printing range.
Comment 26 Alex Thurgood 2011-02-21 02:51:47 UTC
I would like to nominate 33904, which while platform specific, makes opening reports with separator lines (i.e. the most common scenario) in Base on Mac impossible.

Alex
Comment 27 Volker Merschmann 2011-05-10 05:16:28 UTC
LibreOffice 3.3.1 has been released Feb 23rd, 2011

Fixed...
Comment 28 Volker Merschmann 2011-05-10 05:16:47 UTC
... and closed