Bug 33022 - Change motion path of custom effect, old path displays on screen until the presentation is reloaded
Summary: Change motion path of custom effect, old path displays on screen until the pr...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.0 RC2
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0
Keywords:
: 107551 116209 118067 (view as bug list)
Depends on:
Blocks: Custom-Animations
  Show dependency treegraph
 
Reported: 2011-01-12 02:46 UTC by Gregor
Modified: 2018-07-18 14:13 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gregor 2011-01-12 02:46:35 UTC
I have an object that I give a custom animation path, it shows as expected as alight grey dotted arrow. I use the Change Effect option to change the path to another path shape. The object follows the new path shape but the custom path displayed on screen (light grey dotted arrow) remains the original shape and does not reflect the present state of the slide.
Comment 1 Gregor 2011-01-12 03:23:55 UTC
When the presentation is closed and reopened, the correct path shows.
Comment 2 Kohei Yoshida 2011-01-12 07:10:34 UTC
Could you give me exact steps to change the path?  I'm not very familiar with Impress...
Comment 3 Rainer Bielefeld Retired 2011-01-12 08:53:55 UTC
[Reproducible] with "LibreOffice 3.3.0 RC2 - WIN7  Home Premium (64bit) English UI  [OOO330m18 (build 3.3.0.2)]". 

Steps to reproduce :

0. create new Presentation document with 1 blank slide
1. Insert small symbol shape "smiley"
3. click smiley (so that control points appear), right click -> 
   'Costom Animation - Modify Effect -> <add> - Motion paths -> Freeform line ->
   <ENTER>
   Freeform Draw Cursor appears
4. Draw some sinus line all over the slide
5. <f9> to start Presentation, <space> to start animation
   Smiley will fly over sheet following your freeform line
6. Stop presentation
7. click smiley (so that control points appear), right click -> 
   'Costom Animation - Modify Effect -> <change> - Motion paths -> Basic/Heart
    ->  <ENTER>
   unexpectedly the old freeform line remains visible when heart has appeared
8. <f9> to start Presentation, <space> to start animation
   Smiley will fly over sheet following your HART line, thats ok, but 
   when you terminate Presentation, old freeform motion path still will be 
   visible additional to heart motion line
9. Save, Close and reopen
   now only heart motion line will be shown

The problem is the remaining motion path freeform line in step 7

Also an OOo bug:
<http://www.openoffice.org/issues/show_bug.cgi?id=107674>

Added tbehrens to CC.

@Gregor:
Please add information concerning you LibO version!
What't the difference here to your Bug 33026?
May I ask you to read <> and to file Bug reports with status UNCONFIRMED? 
Thank you!
Comment 4 Rainer Bielefeld Retired 2011-01-12 08:57:15 UTC
@Gregor:
Please excuse me, forgot contents:
<http://wiki.documentfoundation.org/BugReport>
Comment 5 Björn Michaelsen 2011-12-23 11:49:17 UTC Comment hidden (obsolete)
Comment 6 Björn Michaelsen 2011-12-23 17:01:13 UTC Comment hidden (obsolete)
Comment 7 sasha.libreoffice 2012-03-22 02:39:53 UTC
Reproducible in 3.5.1 on Fedora 64 bit
IMHO it is not a bug but uncompleted feature. It intended for reuse path for different objects or animations. So, path not deleted automatically.
Comment 8 Florian Reisinger 2012-08-14 14:01:51 UTC Comment hidden (obsolete)
Comment 9 Florian Reisinger 2012-08-14 14:02:54 UTC Comment hidden (obsolete)
Comment 10 Florian Reisinger 2012-08-14 14:07:28 UTC Comment hidden (obsolete)
Comment 11 Florian Reisinger 2012-08-14 14:09:34 UTC Comment hidden (obsolete)
Comment 12 sasha.libreoffice 2012-08-23 07:33:47 UTC
reproduced in 3.6.0rc on Fedora 64 bit
Comment 13 Rob Snelders 2013-10-20 14:38:06 UTC
Still exists in 4.1.1.2 with Ubuntu 13.04 x86_64
Comment 14 Joel Madero 2014-11-03 03:26:21 UTC
Setting to NEW as that's the appropriate status for bugs that are not assigned to anyone nor have they ever been set to FIXED. Thanks
Comment 15 QA Administrators 2015-12-20 16:08:57 UTC Comment hidden (obsolete)
Comment 16 QA Administrators 2017-01-03 19:47:00 UTC Comment hidden (obsolete)
Comment 17 Gregor 2017-01-12 01:14:49 UTC
Present in 5.2.4.2
Windows 10
Comment 18 Regina Henschel 2017-02-11 15:00:04 UTC
Workaroun: Move the entire motion path.
Comment 19 Regina Henschel 2017-05-01 22:51:05 UTC
*** Bug 107551 has been marked as a duplicate of this bug. ***
Comment 20 Katarina Behrens (CIB) 2017-05-02 07:47:52 UTC
Odd, I haven't found this one although I searched *sigh*
Comment 21 ak 2017-07-23 12:12:47 UTC
It's 2017 and the same bug's still out there.
My conf:
LibreOffice Version: 5.3.4.2
Build ID: 1:5.3.4-0ubuntu0.16.04.1~lo0.1
CPU Threads: 4; OS Version: Linux 4.4; UI Render: GL; VCL: gtk2; Layout Engine: new; Locale: en-US (en_US.UTF-8); Calc: group
Kernel: 4.4.0-53-generic x86_64 (64 bit)  Desktop: Cinnamon 3.2.7  Distro: Linux Mint 18.1 Serena
Comment 22 Buovjaga 2018-03-11 14:10:59 UTC
*** Bug 116209 has been marked as a duplicate of this bug. ***
Comment 23 Commit Notification 2018-06-24 01:54:32 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7414e07f52af87094240f5c3d9a0eb764e8642f5

tdf#33022 Dispose the deprecated motion path.

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 24 Mark Hung 2018-07-18 14:13:51 UTC
*** Bug 118067 has been marked as a duplicate of this bug. ***