Bug Hunting Session
Bug 33167 - Please show spaces at the end of the line
Summary: Please show spaces at the end of the line
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 RC3
Hardware: All All
: medium enhancement
Assignee: Bartosz
URL:
Whiteboard:
Keywords:
: 44009 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-01-15 13:42 UTC by Todd
Modified: 2014-06-15 11:16 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Patch to display non printable characters (5.62 KB, patch)
2011-04-20 16:39 UTC, Bartosz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Todd 2011-01-15 13:42:05 UTC
Hi All,

This is an EIGHT year old bug that got carried over from Open Office:

http://www.openoffice.org/issues/show_bug.cgi?id=20878
Opened: Wed Oct 8 11:23:00 +0000 2003

Basically, Writer does not show/allow spaces at the end of a line on text.  It does not wrap spaces either.

Please fix this!

Many thanks,
-T
Comment 1 Rainer Bielefeld Retired 2011-01-16 11:02:30 UTC
Platform / OS due to OOo report.
Comment 2 sasha.libreoffice 2011-02-23 06:25:39 UTC
It problem is on windows and linux, 32 and 64. Last tested on Libreoffice 3.3.0.
Comment 3 sasha.libreoffice 2011-02-24 06:49:33 UTC
on LibreOffice 3.3.1 still exist
Comment 4 Bartosz 2011-04-20 16:39:38 UTC
Created attachment 45888 [details]
Patch to display non printable characters

blank5.patch is implement the display of the the non printable characters till
the end of right margin. 
It works only with left align (the rest aligns was unchanged)

One of the most big benefits of blank5.patch, is possible to edit non printable
character at the end of line (for example inserting new characters).
Comment 5 Kohei Yoshida 2011-04-20 20:59:33 UTC
(In reply to comment #4)
> Created an attachment (id=45888) [details]
> Patch to display non printable characters

Please drop a note on the developer mailing list of this patch.  Otherwise it won't reach the right developer.  Thanks!
Comment 6 Cédric Bosdonnat 2011-05-02 06:12:58 UTC
Pushed in master (target 3.5):
http://cgit.freedesktop.org/libreoffice/writer/commit/?id=4ee4892968d3e42efc03c1158bebfcdd7bb3249e
Comment 7 Simo Kaupinmäki 2014-06-15 11:16:39 UTC
*** Bug 44009 has been marked as a duplicate of this bug. ***