Bug Hunting Session
Bug 33593 - FindBar use breaks the normal 'Find and replace' by columns
Summary: FindBar use breaks the normal 'Find and replace' by columns
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other All
: medium normal
Assignee: Jan Holesovsky
URL:
Whiteboard: target:3.4.3
Keywords:
: 33379 37499 38158 (view as bug list)
Depends on:
Blocks: mab3.4
  Show dependency treegraph
 
Reported: 2011-01-27 07:10 UTC by vitriol
Modified: 2011-08-21 07:37 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Test doc (7.78 KB, application/force-download)
2011-01-27 07:10 UTC, vitriol
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vitriol 2011-01-27 07:10:56 UTC
Created attachment 42595 [details]
Test doc

If you use the FindBar before the normal search, the search by columns doesn't work. If you close and reopen the application it works again.
Steps ti reproduce:

1) Open the attached TestDoc.ods
2) Open Find & Replace > More Options > Search direction:Columns, and search the word "test". It works OK.
2) Close dialog and use the FindBar to search the word "test" or everything else.
3) Reopen Find & Replace and redo point 2). The search by columns doesn't work anymore, an the search is performed by row

Thanks
Comment 1 vitriol 2011-02-07 06:19:28 UTC
Fixed in OOo:

http://www.openoffice.org/issues/show_bug.cgi?id=116250
Comment 2 Dietmar 2011-02-11 14:49:35 UTC
The bug is still in LO 3.3.1 RC1 in Calc.
Do a search with the search bar on a non-existing term.
Open the search dialog, tick-mark search in all tables, use a term that is NOT present in the current table but in a different one.
It's not found.

It IS found, if you made the search directly with the dialog, without using the search bar first.
Comment 3 Rainer Bielefeld Retired 2011-05-05 22:22:54 UTC
Still [Reproducible] with "LibreOffice 3.4Beta3  – WIN7  Home Premium  (64bit) German UI [DEV300m103 (Build:3)]".

@Kohei:
can you please check?
Comment 4 Cor Nouws 2011-05-13 06:54:48 UTC
I would say: related to bug #33379
Comment 5 vitriol 2011-06-10 08:37:58 UTC
*** Bug 38158 has been marked as a duplicate of this bug. ***
Comment 6 Rainer Bielefeld Retired 2011-07-15 06:36:51 UTC
I believe Kendy should also have look, seems to be  Findbar related
Comment 7 Jan Holesovsky 2011-07-26 15:15:17 UTC
*** Bug 37499 has been marked as a duplicate of this bug. ***
Comment 8 Jan Holesovsky 2011-07-26 15:16:32 UTC
*** Bug 33379 has been marked as a duplicate of this bug. ***
Comment 9 Jan Holesovsky 2011-07-26 15:32:13 UTC
Fixed in master, awaiting cherry-pick to libreoffice-3-4.
Comment 10 Jan Holesovsky 2011-07-26 15:33:49 UTC
vitriol: BTW, thank you a lot for pointing out the OOo fix, that helped!
Comment 11 vitriol 2011-08-21 07:37:25 UTC
Verified on 3.4.3 RC1 and seems OK. Thanks and close.