Bug 33600 - better default gradient set
Summary: better default gradient set
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Jean-François Fortin Tam
QA Contact:
URL:
Whiteboard: target:4.2.0
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-27 08:59 UTC by Jean-François Fortin Tam
Modified: 2013-11-28 20:16 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Examples of proposed gradients usage (151.29 KB, image/png)
2012-08-28 17:48 UTC, Lekow
Details
Updated gradients palette provided as a git-formatted patch (14.62 KB, patch)
2013-06-10 21:15 UTC, Jean-François Fortin Tam
Details
old gradients after the patch (220.91 KB, image/png)
2013-11-19 05:37 UTC, Emir Sarı (away)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-François Fortin Tam 2011-01-27 08:59:11 UTC
As a designer/UI reviewer, I find the default set of gradients in OOo/LibreOffice to be lacking in elegance. They have that '95 look, as if they were meant as a benchmark for colors (squared radial pink to green!?). They generally lack subtlety and a more "professional" look, and, as such, discourage the user from using them at all. 

They are really not suitable for charts or flowchart boxes.

I made a new set of gradients in Tango style, which you can preview here: http://jeff.ecchi.ca/blog/2009/01/05/nicer-openofficeorg-gradients/

You can grab the gradients file here: http://jeff.ecchi.ca/public/standard.sog

I would love for this to replace the existing set of default gradients.
Comment 1 Björn Michaelsen 2011-12-23 11:52:51 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 Andreas B. 2012-05-06 06:02:05 UTC
Confirmed, I think it's important to provide good looking default gradients!
Comment 3 Roman Eisele 2012-08-19 08:54:01 UTC
@Kendy, @Astron:

I just stumbled over this old enhancement request which still is valid. And, what is really important: The reporter has already provided an improved set of default gradients (see link in comment #0) which is IMHO at least much better than the present one and also harmonizes well with the UI changes in LibreOffice 3.6.

So please have a look at this report and at the reporter’s suggested new default gradients. Couldn’t we integrate them (maybe with some minor changes) into LibO 3.7?

Thank you very much!
Comment 4 Lekow 2012-08-28 17:48:15 UTC
Created attachment 66236 [details]
Examples of proposed gradients usage

I want to support the idea of bug reporter. The current default gradients are ugly and old-fashioned. It would be great to replace them and the set by Jean-François is really awesome. Maybe some colors can be added or slightly changed, but it is applicable right now. Look at the attached example of usage.
Comment 5 Roman Eisele 2012-08-29 06:04:05 UTC
(In reply to comment #4)
> Created attachment 66236 [details]
> Examples of proposed gradients usage

@Lekow:
Thank you very much for the nice examples!

IMHO Lekow’s examples confirm my impression that Jean-François’ gradients set harmonizes very well with our UI changes in LibreOffice 3.6; both go into the directon of an up-to-date, clean and simple, but lucid and vivid design.
Comment 6 Jean-François Fortin Tam 2013-06-10 21:15:22 UTC
Created attachment 80643 [details]
Updated gradients palette provided as a git-formatted patch

There, someone test and commit this please.
Comment 7 Michael Stahl 2013-11-08 22:46:52 UTC
hello design mailing list, ... you don't have a bugzilla account :(

hello ux-advise mailing list,

there is a patch for gradients attached here.  can somebody please review it?
Comment 8 Adolfo Jayme 2013-11-09 01:37:04 UTC
Comment on attachment 80643 [details]
Updated gradients palette provided as a git-formatted patch

Review of attachment 80643 [details]:
-----------------------------------------------------------------

Please commit it already, it has been waiting too much time.
Comment 9 Michael Stahl 2013-11-14 23:30:20 UTC
alright pushed the patch to master now in time for 4.2 feature freeze.

Jean-François, thanks for the patch; can you please send a license mail
to  libreoffice@lists.freedesktop.org  as described on this page:

https://wiki.documentfoundation.org/Development/Developers#Example_Statement

feel free to add an entry for yourself on the page too.

also now that i've actually looked what those gradient things
looked like before (ewww) - please add some before/after
image to the release notes :)
https://wiki.documentfoundation.org/ReleaseNotes/4.2
Comment 10 Commit Notification 2013-11-14 23:45:52 UTC
Jean-François Fortin Tam committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=868103846b9b32bfecd77c08055fdca69d0265c2

fdo#33600 - Better default gradient set



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Emir Sarı (away) 2013-11-19 05:34:54 UTC
This new gradient set is not available for use in background gradients, e.g. when setting a background for a frame or a shape. 

Can we reopen this bug?
Comment 12 Emir Sarı (away) 2013-11-19 05:37:57 UTC
Created attachment 89445 [details]
old gradients after the patch
Comment 13 Michael Stahl 2013-11-28 20:16:20 UTC
Emir, in a current master build i can not find the old gradients

E.g. insert a Frame in Writer, background: new gradients
Insert Drawing Shape in Writer, Area: new gradients
Insert Drawing Shape in Impress, Area: new gradients

please verify if you can still reproduce the old gradients.

oh wait, now i remeber: perhaps the gradients are stored in the user profile?

ah indeed that seems to be the case ...
.config/libreoffice/4/user/config/standard.sog

hmm... no idea what to do about that...