Download it now!
Bug 33807 - [EDITING]Multiple selection with shift key doesn't work if there is a picture in the document
Summary: [EDITING]Multiple selection with shift key doesn't work if there is a picture...
Status: CLOSED DUPLICATE of bug 37960
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: x86 (IA32) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-01 05:20 UTC by matteli
Modified: 2017-04-19 21:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description matteli 2011-02-01 05:20:37 UTC
If you have a picture in a document and you select a second line with the key shift pressed (after selected a first line), your selection is cancelled and the picture is selected.

To reproduced :

In a document, paste a picture. Create 2 lines. Select a line. Select a second line with the shift key pressed.

Result : the picture is selected
Expected Result : the 2 lines are selected
Comment 1 Björn Michaelsen 2011-12-23 11:43:25 UTC Comment hidden (obsolete)
Comment 2 bugzilla.1.destroyer77 2012-07-16 13:01:23 UTC
The problem still exists in the latest release (LibreOffice 3.5.4.2) on Windows 7.
Comment 3 fitz321 2013-01-24 08:25:13 UTC
Problem still exists in LibreOffice 3.6.4.3 (Build 2ef5aff) for Windows.
OS: Windows XP Professional x86 (32 bit)

It is not only not possible to select multiple lines when a picture is in the document (haven't tested this), but selection of multiple text boxes and other drawing objects is also not possible.

My special case: Pictures (png) in header of document; text, text boxes and lines in the body of document. It is not possible to select multiple text boxes and lines with shift + mouseclick, unless you delete the pictures in the header.

If you try to select muliple elements without deleting the pictures first, then the cursour jumps into the header and the first picture from left to right is selected.
Comment 4 ntrrgc 2013-11-18 19:08:47 UTC

*** This bug has been marked as a duplicate of bug 37960 ***
Comment 5 Regina Henschel 2017-04-19 21:25:27 UTC
Fixed