Bug Hunting Session
Bug 33831 - Media wiki export pictures as files
Summary: Media wiki export pictures as files
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:6.0.0 target:5.4.0.1
Keywords: difficultyBeginner, easyHack, skillJava, skillScript
Depends on:
Blocks: MediaWiki
  Show dependency treegraph
 
Reported: 2011-02-02 03:43 UTC by Christian
Modified: 2017-06-19 14:35 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian 2011-02-02 03:43:48 UTC
I love the possibility to edit offline wikipedia articles with Libre Office. But what I really miss is, that LO does not export embedded Pictures. It sould be no big deal exporting pictures as jpg file with some unique random file name and add the corresponding tag. It would also be coll if you could direct export to a wiki url. Its also not very difficult I think because its just a simple "post".

Wish you all the Best! Cheers
Christian
Comment 1 Muthu 2011-02-03 03:39:20 UTC
Adding EasyHack: tag.
Comment 2 Björn Michaelsen 2011-12-23 11:50:00 UTC Comment hidden (obsolete)
Comment 3 Björn Michaelsen 2011-12-23 12:57:28 UTC
An EasyHack should have been checked by developers and thus is confirmed regardless of age. Moving back to NEW from NEEDINFO again. Sorry for the hassle.
Comment 4 Florian Reisinger 2012-05-18 09:39:11 UTC
Deleted "Easyhack" from summary.
Comment 5 Björn Michaelsen 2013-10-04 18:47:42 UTC
adding LibreOffice developer list as CC to unresolved EasyHacks for better visibility.

see e.g. http://nabble.documentfoundation.org/minutes-of-ESC-call-td4076214.html for details
Comment 6 Björn Michaelsen 2014-12-02 10:53:14 UTC
adding LibreOffice developer list as CC to unresolved Writer EasyHacks for better visibility.

see e.g. http://nabble.documentfoundation.org/minutes-of-ESC-call-td4076214.html for details
Comment 7 Robinson Tryon (qubit) 2015-12-10 11:50:47 UTC Comment hidden (obsolete)
Comment 8 Michael Stahl (CIB) 2016-01-26 15:53:00 UTC
the Wiki Publisher is implemented in Java and XSLT, in swext/mediawiki
Comment 9 Tomas Novotny 2016-03-10 23:17:41 UTC
I retested issue on branch libreoffice-5-1 commit version b3a28e359a527a307edf843e8590c2a73591cfe31. The issue persist, I'll try to fix it.
Comment 10 jani 2016-04-12 13:45:13 UTC
Tomas@ are you still working on this bug (otherwise please unassign it) ?
Comment 11 Tomas Novotny 2016-05-14 21:03:35 UTC
@Jan Still working on it but unfortunately haven't much time lately.
Comment 12 jani 2016-06-14 05:55:26 UTC
Unassigning due to lack of work, if you want to continue working, please assign yourself again.
Comment 13 Niknok 2016-07-25 09:35:24 UTC
Hi I am going to work on this bug.
Comment 14 jani 2016-08-25 06:13:05 UTC Comment hidden (obsolete)
Comment 15 jani 2016-09-25 09:52:28 UTC
Unassigning.
Comment 16 Owen Anderson 2016-11-26 02:26:20 UTC
I am going to start working on this bug.
Comment 17 Owen Anderson 2016-11-26 02:27:08 UTC
I'm going to start working on this easy hack.
Comment 18 jani 2016-11-26 08:02:18 UTC
Hi looking forward to see your patch.

Please do not forget to submit your license statement as I wrote to you.
https://wiki.documentfoundation.org/Development/Developers#Example_Code_Contributor_Statement

Without a license statement your patch are not likely to be merged.
Comment 19 Owen Anderson 2016-11-26 21:04:49 UTC
(In reply to jan iversen from comment #18)
> Hi looking forward to see your patch.
> 
> Please do not forget to submit your license statement as I wrote to you.
> https://wiki.documentfoundation.org/Development/
> Developers#Example_Code_Contributor_Statement
> 
> Without a license statement your patch are not likely to be merged.

Thanks I must have missed this. I've submitted my license statement as of now.
Comment 20 Owen Anderson 2016-12-03 20:40:52 UTC
So I'm still working on this bug. But it's going slow to say the least. Very little of the code has any documentation so I'm having to figure out how this extension works. I'm will be adding some documentation as I go through this plug in hopefully making it easier for future additions. In addition to this I have determined that the request to add the feature to export directly to a wiki URL is already implemented under File > Send > To MediaWiki... So I will just be implementing the exporting of embedded images for this fix. On top of this it something to consider is adding some more help in using this extension on the LibreOffice wiki to allow people to more easily use this extension.
Comment 21 jani 2016-12-05 08:16:25 UTC
(In reply to Owen Anderson from comment #20)
> So I'm still working on this bug. But it's going slow to say the least. Very
> little of the code has any documentation so I'm having to figure out how
> this extension works. I'm will be adding some documentation as I go through
> this plug in hopefully making it easier for future additions. In addition to
> this I have determined that the request to add the feature to export
> directly to a wiki URL is already implemented under File > Send > To
> MediaWiki... So I will just be implementing the exporting of embedded images
> for this fix. On top of this it something to consider is adding some more
> help in using this extension on the LibreOffice wiki to allow people to more
> easily use this extension.

A good hint, submit several smaller patches as you work towards the final version...that way you get feedback earlier.
Comment 22 jani 2017-01-09 08:25:07 UTC
A polite ping, still working on this issue ?
Comment 23 jani 2017-02-09 06:50:20 UTC
UNassigning, if you want to continue work on this bug please reassign yourself
Comment 24 Shoaib Noor 2017-03-08 15:49:48 UTC
(In reply to Muthu from comment #1)
> Adding EasyHack: tag.
Comment 25 Shoaib Noor 2017-03-08 15:52:17 UTC
How to get the source code of that particular session for fixing this bugs
Comment 26 Commit Notification 2017-05-29 21:41:38 UTC
Arianna Masciolini committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a8124c2eaf401741e2235939a20cef2617ad8bd1

tdf#33831 swext: mention images by name in the mediawiki export

It will be available in 5.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 27 Commit Notification 2017-06-19 14:10:24 UTC
Arianna Masciolini committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6ef9fca590622d3269c0ba11e3782910ac573261&h=libreoffice-5-4

tdf#33831 swext: mention images by name in the mediawiki export

It will be available in 5.4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 28 Julien Nabet 2017-06-19 14:35:23 UTC
Let's put this one to FIXED since the patch is now in 5.4 branch and am not sure it worths it to backport it in 5.3 branch.