Download it now!
Bug 33894 - Scrolling a Writer document may cause LibreOffice to crash or freeze
Summary: Scrolling a Writer document may cause LibreOffice to crash or freeze
Status: RESOLVED DUPLICATE of bug 33785
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-04 01:32 UTC by LucTur
Modified: 2011-02-10 09:02 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Test document for crash and freeze while scrolling (291.41 KB, application/vnd.oasis.opendocument.text)
2011-02-04 01:32 UTC, LucTur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description LucTur 2011-02-04 01:32:02 UTC
Created attachment 42918 [details]
Test document for crash and freeze while scrolling

Scrolling up to page number 5 of the attached offending document may cause:

a) the crash of LibreOffice application when scrolling by using the lateral scroll bars or buttons;

b) the freeze of LibreOffice application when positioning the cursor at the last line of page 4 and moving into page 5 by pressing the down arrow key on your keyboard.

This issue can be reproduced on Windows XP, Vista and 7, both in .doc format (original format of this document) and .odt format.
Comment 1 LucTur 2011-02-04 03:01:35 UTC
Some more tests.

I've tried to delete all images, footers and heading through the Navigator from the test document, but it still crashes and freezes LibreOffice.

Instead, OpenOffice.org 3.3 opens this file just fine. No problem at all.
Comment 2 Cor Nouws 2011-02-09 02:44:54 UTC
Thanks for reporting.
I cannot reproduce the bug on Ubuntu.
Did you try it on Ubuntu too, or do you know of people that did?
Comment 3 vitriol 2011-02-09 02:51:24 UTC
Based on other reports by several Italian users, only the Windows version seems affected. 100% reproducible under Windows.
Comment 4 LucTur 2011-02-09 02:56:41 UTC
Other users have tested the document on different Linux distros and Mac, and this test document works as expected or with a brief freezing. In fact, it seems it's a Windows specific bug.

So far, it affects Windows XP, Vista and 7.

There has been a long discussion on this topic (only in Italian language, sorry), here:

https://groups.google.com/group/it-alt.comp.software.openoffice/browse_thread/thread/1aedaf7d99668a8e?hl=it
Comment 5 vitriol 2011-02-09 03:29:37 UTC
Additional information: this bug is LibO specific. OOo 3.3 under Windows works fine with the same document.
Comment 6 Michael Meeks 2011-02-10 09:02:24 UTC
I reproduced in the debugger; it is a duplicate.

*** This bug has been marked as a duplicate of bug 33785 ***