Bug 33942 - Export Selection as PDF does not export selected slides
Summary: Export Selection as PDF does not export selected slides
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-05 13:06 UTC by mike.hall
Modified: 2011-02-06 00:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mike.hall 2011-02-05 13:06:46 UTC
To show bug:
Create a 3 slide new presentation
Select slide 1 and 3 in normal view
do file > export as pdf with 'selection' checked

Expected behaviour:
PDF created with slides 1 & 3

Actual behaviour:
PDF created with all three slides.


Presumably this is a regression from OOo 3.2.1, but I haven't tested that.

Note that from the slide sorter, attempting PDF export with 'selection' checked gives an error message (file cannot be saved).

In both normal and slide sorted view, export as PDF with 'pages' selected and 1 3 in the dialogue box correctly creates PDFs with only slides 1 & 3.
Comment 1 Rainer Bielefeld Retired 2011-02-06 00:46:23 UTC
This is an user error because of incomplete instruction in UI and / or Help. "Selection" does not mean "selected slides" (for that you have selection "Slides" under "Range and Copies" in print dialog or "Pages" under "Range" in "Export to PDF" dialog), but "selected area on slide"

@mike.hall@onepoyle.net
I doubt that that works for you when printing ...
Please feel free to file Enhancement bug reports for more unambiguous Help and UI!