Download it now!
Bug 34404 - LibreOffice 3.3.2 release blockers / stoppers
Summary: LibreOffice 3.3.2 release blockers / stoppers
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 33701 34533 34718
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-17 08:53 UTC by Petr Mladek
Modified: 2019-12-18 11:08 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Mladek 2011-02-17 08:53:29 UTC
This is the Meta issue to track the potential stoppers for the release of LibO
3.3.2.

If anyone wants to raise an Bug for the release, please add the Bug ID as
dependent Bug here to the Meta Bug in field "Depends on". Additionally please
leave a comment here why you want to declare that issue as a blocker for a.m.
release.

See http://wiki.documentfoundation.org/ReleasePlan#3.3.2_release
Comment 1 Petr Mladek 2011-02-17 09:08:20 UTC
Moved 31792 32861 32895 from LO-3.3.1 nominated bugs.
Comment 2 sasha.libreoffice 2011-02-26 01:56:27 UTC
bug 34718 it is so obvious for user of Impress and I hope it is easy to fix
bug 34749 undo corrupts text on slides and users will fear to use Impress
Comment 3 sasha.libreoffice 2011-02-28 05:54:42 UTC
bug 33361, bug 34821, bug 34757 with this bugs Impress becomes useless for students
Comment 4 Cédric Bosdonnat 2011-02-28 06:08:03 UTC
You shouldn't add blocker bugs without having them correctly qualified first. This one simply doesn't make sense for anyone!
Comment 5 Cédric Bosdonnat 2011-02-28 06:25:59 UTC
A bug but not a blocker. Please ask for advises on the developers mailing list before nominating a bug as a release blocker!

Imagine what mess it would be here if anyone added his pet bug as a blocker for the next release!
Comment 6 sasha.libreoffice 2011-02-28 07:29:40 UTC
I am sorry about incorrect previous bug. bug 34834 instead
Comment 7 Andras Timar 2011-02-28 22:15:29 UTC
fdo#330701 - Extension Manager: "Check for Updates" – LibO crashes - frequently reported, patch exists, see https://bugs.freedesktop.org/show_bug.cgi?id=33701#c21
Comment 8 Cédric Bosdonnat 2011-03-01 02:00:57 UTC
Removed bug 34749 from blockers. Loosing formatting on undo can't be a blocker bug.
Comment 9 Petr Mladek 2011-03-01 08:10:44 UTC
bug #32861 is not a real blocker. It does not happen with the default setting (HW acceleration on). It happens only with a particular presentation. We will fix it ASAP but I do not want to block 3.3.x releases because of this.
Comment 10 Petr Mladek 2011-03-01 08:15:19 UTC
bug #32895 is not a real blocker; The presentation template names are not that helpful. I think that most of people select it by the preview rather than by name.
We should not block the 3.3.2 release by this.
Comment 11 Petr Mladek 2011-03-01 08:33:11 UTC
bug #33361 is not a blocker; I see the same behavior also with OOo-3.2.1. Note that we steadily improve the OOXML import/export but it is a work in progress. Only serious regressions might be considered as blockers. The rest are normal bugs that will be solved in furher versions by the severity and priority.
Comment 12 Petr Mladek 2011-03-01 08:44:59 UTC
Hmm, I remove the bug #31792 from the blockers. It seems to be random. It was found when debugging another bug and not in a real life usage. It does not have duplicates. It is hard to debug. It will be either solved when time permits or we will get duplicates and will be forced to fix it. The duplicates might happen in some other circumstances, might bring new ideas...
Comment 13 Rainer Bielefeld Retired 2011-03-10 23:22:40 UTC
Nominate Bug 34093 - Partial PDFEXPORT of particular Master Documents breaks hyperlinks.
Comment 14 Rainer Bielefeld Retired 2011-03-11 00:07:25 UTC
To be honest, I use LibO because of my idealism, but it's still not an office suite that can fulfill my needs. For that I still need OOo 3.1.1, for example because of unfixed
Bug 34093
Bug 34187 - MAILMEGE E-Mail does not send mails  
  Bug 34184 - [Task]: Make E-mail MAILMEGE usable
Comment 15 Andreas Mantke 2011-03-13 08:31:35 UTC
I want to propose https://bugs.freedesktop.org/show_bug.cgi?id=35273 as blocker for LibO 3.3.2 because it causes a crash in the use of the outline view of Impress. I hope it is easy to fix.
Comment 16 Zack 2011-03-13 19:51:10 UTC
(In reply to comment #15)
> I want to propose https://bugs.freedesktop.org/show_bug.cgi?id=35273 as blocker
> for LibO 3.3.2 because it causes a crash in the use of the outline view of
> Impress. I hope it is easy to fix.

Not reproducible in 3.3.2 RC1 with the information provided.  Running Vista SP2 x86.  I recommend this not be considered as a blocker for the 3.3.2 release.
Comment 17 Michael Meeks 2011-03-21 10:16:25 UTC
filed bug #35509 for 3.3.3 release blockers.
Comment 18 Rainer Bielefeld Retired 2011-03-21 23:32:21 UTC
Bug 34184 - [Task]: Make E-mail MAILMEGE usable:
3.3.3 blocker now
Comment 19 Michael Meeks 2011-03-22 03:48:05 UTC
dropping 34093 - moved to 3.3.3 - since 3.3.2 just released.

Thanks guys; this bug is now closed.