Bug 34704 - Customization of MOD3 missing on macOS
Summary: Customization of MOD3 missing on macOS
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Mac OS X (All)
: medium enhancement
Assignee: Heiko Tietze
URL:
Whiteboard:
Keywords:
: 116774 (view as bug list)
Depends on:
Blocks: Customize-Dialog-Keyboard Shortcuts-Mac 78777
  Show dependency treegraph
 
Reported: 2011-02-25 02:21 UTC by herrdeh
Modified: 2018-05-11 08:38 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (232.99 KB, image/jpeg)
2011-02-25 02:25 UTC, herrdeh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description herrdeh 2011-02-25 02:21:49 UTC
Apart from the problem that LibO tends to sometimes forget newly assigned keyboard shortcuts (see bug 34703), in LibO some of the OOO probs are persisting.

The major issue: Shift, ctrl, alt and cmd are not assigned properly, which IMHO has to do with the mod1 and mod2 concept. 
On non-Macs, AFAIK Mod1 is ctrl, and Mod2 is alt. On the Mac, Mod1 was assigned to cmd, so there is not proper way to assign keyboard shortcuts to the ctrl key.

So, if I do assign a funktion to ctrl-cmd, it will work with alt-cmd.

Attached you find a view to the editor (Bild 4) - this way it has to be assigned.
And a shot (Bild 6) which shows how shortcuts actually work.

Is it possible to introduce a Mod3 on the Mac to make the ctrl key useable again?
Comment 1 herrdeh 2011-02-25 02:25:09 UTC
Created attachment 43787 [details]
Screenshot
Comment 2 herrdeh 2011-02-25 02:25:46 UTC
NB.: Screenshot contains both views.
Comment 3 Cédric Bosdonnat 2011-02-25 02:33:37 UTC
Thorsten another macos bug for you?
Comment 4 Thorsten Behrens (CIB) 2013-02-20 08:57:45 UTC
Adjusting bug category, freeing bug for other takers - I cannot currently commit time to this one unfortunately.
Comment 5 Yousuf Philips (jay) (retired) 2017-05-25 03:03:05 UTC
@Steve, @Alex, @Telesto: Can you guys check this and give your input on it? Thanks.
Comment 6 Heiko Tietze 2018-04-16 09:24:11 UTC
I read this ticket as the need to add MOD3 to the customization dialog (working on a patch). And bug 117033 as ticket regarding the visualization.
Comment 7 Heiko Tietze 2018-04-16 11:33:04 UTC
Patch at https://gerrit.libreoffice.org/#/c/52964/
Comment 8 Heiko Tietze 2018-04-16 18:15:15 UTC
macOS ctrl key aka ^ aka MOD3 can now be configured as MOD1 (cmd). Not all combinations make sense, and I think we shouldnt add all combinations with alt and cmd.
Comment 9 Heiko Tietze 2018-05-11 08:38:33 UTC
*** Bug 116774 has been marked as a duplicate of this bug. ***