Bug 34772 - Word count / statistics in the status bar
Summary: Word count / statistics in the status bar
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: All All
: medium enhancement
Assignee: Muhammad Haggag
QA Contact:
URL:
Whiteboard: target:3.6.0
Keywords:
: 46126 49984 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-02-26 10:03 UTC by Jean-François Fortin Tam
Modified: 2012-07-06 23:50 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Proposed patch. (11.00 KB, patch)
2012-05-22 08:14 UTC, Muhammad Haggag
Details
First stab at updating help content. Incomplete. (1.99 KB, patch)
2012-05-22 08:25 UTC, Muhammad Haggag
Details
Followup patch. (3.04 KB, patch)
2012-05-24 10:55 UTC, Muhammad Haggag
Details
Patch to add help content. (6.79 KB, patch)
2012-05-25 15:17 UTC, Muhammad Haggag
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-François Fortin Tam 2011-02-26 10:03:59 UTC
Students (a significant portion of LibreOffice users, I would expect) are often expected to write papers based on either a maximum amount of pages or a minimum/maximum word count. It is also possible that other users (journalists? writers?) write based on word count.

Thus, it would be very beneficial for many users to be able to see the word count at all times in Writer's status bar, alongside the (already present) pages count. The status bar seems to have plenty of space left for this feature.
Comment 1 Matteo Rapone 2011-04-05 05:29:28 UTC
It's a duplicate of this bug in OpenOffice.org's bugzilla: http://openoffice.org/bugzilla/show_bug.cgi?id=41454

I hope this will be fixed in the next major release, it's a fundamental functionality IMHO.
Comment 2 Ben McGinnes 2011-04-21 10:02:41 UTC
I'd like to add my support for the inclusion of this feature which is required by writers of all persuasions.  Including, but by no means limited to, authors, journalists, students, technical writers, speech writers, policy writers and, well, just about any kind of word smith you can think of.

We've been waiting for it for more than six years in OpenOffice.org, with no end in sight, surely LibreOffice can succeed where OpenOffice.org and StarOffice have clearly failed.
Comment 3 Shawn T. 2011-06-19 11:56:08 UTC
I also support this. It's hard to write a thousand word essay when you don't know if you've reached a thousand words yet.
Comment 4 Björn Michaelsen 2011-12-23 11:43:20 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 5 sasha.libreoffice 2012-01-20 05:03:37 UTC
At this time requested functionality exist in Tools->Word count. Appears standalone (unmodal) window which indicates word count in real time.
What about status bar: it my be placed in left corned after page number/count. But then appears some problem:
1) if screen is small (pocket comp), then it can not fit there
2) if document is big, it my take much time to re-count words each time
3) users my confuse  page number/count with word count
Comment 6 Jean-François Fortin Tam 2012-01-20 05:27:17 UTC
> 1) if screen is small (pocket comp), then it can not fit there
There already is a status bar, which is mostly empty. It's not going to take any more space because it's just filling horizontal space. And I don't expect a desktop gui to fit in something like 200 pixels without having a dedicated "mobile" UI, that's being unreasonable.

> 2) if document is big, it my take much time to re-count words each time
It takes a fraction of the second to do it currently. It might already store that statistic in the file, I don't know. And at runtime, it's just a counter to increment/decrement. No performance hit at all if you do it in a smart way.

> 3) users my confuse  page number/count with word count
What exactly is confusing with "Page 7/32     3948 words" in the statusbar?
Seriously?
Comment 7 Muhammad Haggag 2012-05-04 10:40:24 UTC
I'm working on a patch to add word count to the status bar.
Comment 8 Muhammad Haggag 2012-05-04 10:41:44 UTC
*** Bug 46126 has been marked as a duplicate of this bug. ***
Comment 9 Rainer Bielefeld Retired 2012-05-15 22:08:36 UTC
*** Bug 49984 has been marked as a duplicate of this bug. ***
Comment 10 gauravjuvekar 2012-05-16 07:54:39 UTC
It should also display the number of words in selected text(eg. 25/100 words if selection contains 25 words)
Comment 11 Muhammad Haggag 2012-05-22 08:14:32 UTC
Created attachment 61962 [details]
Proposed patch.

I'll post a link to the patch review thread on the developers mailing list shortly. I'm also pursuing guidance on how to properly update help with content for the new control, but that probably won't block this patch from getting in first once approved.
Comment 12 Muhammad Haggag 2012-05-22 08:25:49 UTC
Created attachment 61963 [details]
First stab at updating help content. Incomplete.
Comment 13 Muhammad Haggag 2012-05-22 08:40:02 UTC
Developer review thread for those interested: http://nabble.documentfoundation.org/PATCH-fdo-34772-Word-count-statistics-in-the-status-bar-td3985352.html
Comment 14 Muhammad Haggag 2012-05-24 10:55:41 UTC
Created attachment 62063 [details]
Followup patch.

Followup patch that extracts the status bar word-count strings and puts them as string resources, so that they can be localized.
Comment 15 Not Assigned 2012-05-25 00:02:31 UTC
Muhammad Haggag committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ce14342c4292628a641a72d4f63d9c048e030c6a

fdo#34772 Add word count to the status bar in writer
Comment 16 Not Assigned 2012-05-25 00:02:59 UTC
Muhammad Haggag committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8ed3a427245a07bb787c521a178cfb421fa46854

Followup to fdo#34772: Add resource strings for word-count messages
Comment 17 sasha.libreoffice 2012-05-25 05:15:26 UTC
Thanks for adding this functionality
Comment 18 Muhammad Haggag 2012-05-25 15:17:20 UTC
Created attachment 62112 [details]
Patch to add help content.
Comment 19 Not Assigned 2012-06-01 07:40:40 UTC
Muhammad Haggag committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=732978e854aaf0b85e013b8c438983f6ab7804de

Added help content for fdo#34772: Word count in the status bar
Comment 20 Zeki Bildirici 2012-07-06 06:15:19 UTC
Hi,

Thank you for bringing this feature, which we have been waiting for sooo long.

I would like to ask that, is there a special/technical* reason to show the word numbers a 10730(without thousand seperator) i/o 10.730?
http://wiki.documentfoundation.org/File:Libreoffice-3.6-mac.png

If it is possible, i think it will be nice to see and understand.

(*Of course it will cause some confusing due to local Decimal mark usage: http://en.wikipedia.org/wiki/Decimal_mark#Hindu-Arabic_numeral_system )

Regards and many thanks.
Comment 21 Muhammad Haggag 2012-07-06 23:27:30 UTC
(In reply to comment #20)
> I would like to ask that, is there a special/technical* reason to show the word
> numbers a 10730(without thousand seperator) i/o 10.730?
> http://wiki.documentfoundation.org/File:Libreoffice-3.6-mac.png

IIRC, during development, the word count string when you had text selection was something like "Words: 100, 5 selected". So using a separator resulted in strings like "Words: 1,000, 5 selected" which were confusing, so I stopped using separators. 

Now the string is actually: "Words: 1000 Selected: 5" so it shouldn't be a problem to add separators back.

> If it is possible, i think it will be nice to see and understand.
I agree. I'll look into it.
Comment 22 Rainer Bielefeld Retired 2012-07-06 23:43:19 UTC
<https://wiki.documentfoundation.org/BugReport_Details#How_to_reopen_Bugs>

ASSIGNED due to facts.

In future please submit new reports for feature requests, bugs in this feature, ...
Comment 23 Muhammad Haggag 2012-07-06 23:50:46 UTC
(In reply to comment #22)
> <https://wiki.documentfoundation.org/BugReport_Details#How_to_reopen_Bugs>
> 
> ASSIGNED due to facts.
> 
> In future please submit new reports for feature requests, bugs in this feature,
> ...

My apologies. I'll revert this back to fixed. I've opened 51818 to track the formatting issue: https://bugs.freedesktop.org/show_bug.cgi?id=51818