Bug 34828 - Navigator item "Draw objects" in Calc does not show Draw objects without name (Writer fixed in the mean time..)
Summary: Navigator item "Draw objects" in Calc does not show Draw objects without name...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: target:7.2.0
Keywords:
: 90277 124989 134344 134378 137837 (view as bug list)
Depends on:
Blocks: Navigator
  Show dependency treegraph
 
Reported: 2011-02-28 04:46 UTC by sasha.libreoffice
Modified: 2021-04-01 22:28 UTC (History)
21 users (show)

See Also:
Crash report or crash signature:


Attachments
explanation and screenshots of navigator problem (35.35 KB, application/vnd.oasis.opendocument.text)
2011-02-28 04:46 UTC, sasha.libreoffice
Details
How it would look like with all shapes appearing (190.82 KB, image/png)
2016-03-15 11:10 UTC, Samuel Mehrbrodt (allotropia)
Details
unique drawing object names demo 1 (468.23 KB, video/x-matroska)
2020-11-16 08:53 UTC, Jim Raykowski
Details
unique drawing object names demo 2 (440.67 KB, video/x-matroska)
2020-11-16 08:56 UTC, Jim Raykowski
Details
unique drawing object names demo 3 (495.63 KB, video/x-matroska)
2020-11-16 09:01 UTC, Jim Raykowski
Details
unique drawing object names demo 4 (861.08 KB, video/x-matroska)
2020-11-23 04:01 UTC, Jim Raykowski
Details
unique drawing object names demo 5 (411.46 KB, video/x-matroska)
2020-11-23 04:02 UTC, Jim Raykowski
Details
unique drawing object names demo 6 (474.11 KB, video/x-matroska)
2020-11-24 07:16 UTC, Jim Raykowski
Details
patch set 7 Draw/Impress demo (325.00 KB, video/x-matroska)
2020-11-29 19:58 UTC, Jim Raykowski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sasha.libreoffice 2011-02-28 04:46:28 UTC
Created attachment 43923 [details]
explanation and screenshots of navigator problem

In navigator never appears "Drawing objects".
Used LibreOffice 3.3.1.2 Mandriva 64 bit Kde 4.4 and windows xp 32 bit
In attachment explanation and screenshots of navigator problem.
Comment 1 GerardF 2011-02-28 06:10:06 UTC
(In reply to comment #0)
> In navigator never appears "Drawing objects".

If you want to see "Drawing objects" in the navigator, you may name these objects. Right-clic > Name.

Don't remember, but i think it is the same in OpenOffice.
Comment 2 Cédric Bosdonnat 2011-02-28 07:15:06 UTC
(In reply to comment #1)
> (In reply to comment #0)
> > In navigator never appears "Drawing objects".
> 
> If you want to see "Drawing objects" in the navigator, you may name these
> objects. Right-clic > Name.
> 
> Don't remember, but i think it is the same in OpenOffice.

Indeed you need to name the draw objects to make them appear here. This would be an enhancement to have them shown here.
Comment 3 sasha.libreoffice 2011-02-28 07:44:22 UTC
Thanks about Name. I do not know about this.
Comment 4 Björn Michaelsen 2011-12-23 11:45:28 UTC Comment hidden (obsolete)
Comment 5 sasha.libreoffice 2012-01-02 02:41:26 UTC
reproduced in LibO 3.5.0 beta 1
Comment 6 Roman Eisele 2012-05-04 07:40:56 UTC
This is a general UI issue, right? Therefore changed 'Component' field accordingly.
Comment 7 Rainer Bielefeld Retired 2013-03-28 09:49:59 UTC
In Draw Navigator shows all draw objects, even any simple line, if you enable 'Show Shapes -> All Shapes'. This problem does not exist there.

Bu I can confirm the problem for Writer and Calc, there always exists an item "Draw Objects", where I even can select a 'Drag Mode', but that's useful for nothing if there are no shapes listed. 

So I consider this one a bug.

That never worked in LibO or OOo, see "AOOo#17444 - unnamed objects in navigator"

May be we simply need in heading of Navigator the icon 'Show Shapes -> All Shapes' as we have it in Draw / Impress?

@Thorsten:
Can you please rate the easyhack proposal? I had to learn that many issues related to inherited Draw code are not as simple as they might look.
Comment 8 Jean-Francois Nifenecker 2014-02-22 17:27:44 UTC
This problem seems to come from the fact that drawing objects added in Writer are not named by default. Naming them as "Drawing 1", "Drawing 2", etc. by default could probably help.
Comment 9 Joel Madero 2014-02-27 23:22:27 UTC
In order to limit the confusion between ProposedEasyHack and EasyHack and to make queries much easier we are changing ProposedEasyHack to NeedsDevEval.

Thank you and apologies for the noise
Comment 10 Harald Koester 2015-10-08 12:49:05 UTC
(In reply to Jean-Francois Nifenecker from comment #8)
> This problem seems to come from the fact that drawing objects added in
> Writer are not named by default. Naming them as "Drawing 1", "Drawing 2",
> etc. by default could probably help.

I would appreciate a default naming of drawing objects. All other objects (tables, comments,..) are named by default, only drawing objects are not named. Also particularly if an object is covered by another object this is only way to select the covered object without modifying the covering object. Furthermore I propose that the default name also indicates the kind of an object. E.g. Rectangle1, Rectangle2, Circle1, Square1, ...
Comment 11 Robinson Tryon (qubit) 2015-12-14 06:12:39 UTC Comment hidden (obsolete)
Comment 12 Samuel Mehrbrodt (allotropia) 2016-03-15 11:10:47 UTC
Created attachment 123588 [details]
How it would look like with all shapes appearing
Comment 13 Samuel Mehrbrodt (allotropia) 2016-03-15 11:40:27 UTC
Have a patch for this here: https://gerrit.libreoffice.org/#/c/23265/ which enables show unnamed shapes.

However, I am not sure this is the right approach. Maybe we should rather go with default names for shapes as we do with images?
Comment 14 Regina Henschel 2016-03-15 17:29:04 UTC
I use a Version: 5.2.0.0.alpha0+
Build ID: 129d199d27f6961ea0c850686f76c83e2fc1953d
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-03-11_06:16:01
Locale: de-DE (de_DE)

If I insert a Draw object into a Writer document, it is named automatically and therefore it is listed in the Navigator. So for Writer nothing is to do.
Comment 15 Samuel Mehrbrodt (allotropia) 2016-03-15 17:35:26 UTC
(In reply to Regina Henschel from comment #14)
> If I insert a Draw object into a Writer document, it is named automatically
> and therefore it is listed in the Navigator. So for Writer nothing is to do.

Oh this seems to have changed in 5.2 - thanks for testing. So I guess this can be closed then :)
Comment 16 Regina Henschel 2016-03-15 17:43:27 UTC
It is only solved in Writer, in Calc they are not named automatically.

And for Calc the discussion remains whether to use the solution of Writer to name them automatically or use the solution of Draw/Impress to have a special mode (with icon in Navigator) to show or hide unnamed objects.
Comment 17 Harald Koester 2016-08-30 10:00:34 UTC
Current situation:

Beginning with version 5.1.0 drawing objects are named automatically with Shape1, Shape2, ... in Writer. A differentiation between kinds of objects (line, rectangle, Circle, ...) is not performed like proposed in comment 10 and comment 12.

In Calc neither in version 5.1.0 nor in version 5.2.0 an automatic naming of drawing objects is performed. Hence this bug is not completely fixed. Set back to NEW.
Comment 18 Thomas Lendo 2017-09-16 01:38:56 UTC Comment hidden (obsolete)
Comment 19 QA Administrators 2018-09-17 02:46:33 UTC Comment hidden (obsolete)
Comment 20 Thomas Lendo 2018-09-17 05:32:13 UTC
Still reproducible.

Version: 6.2.0.0.alpha0+ (x64)
Build ID: 18c5089df091bddeb8c2dc339776671964389040
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-09-12_23:24:12
Locale: de-AT (de_AT); Calc: CL
Comment 21 Cor Nouws 2018-09-18 11:27:27 UTC
(In reply to Thomas Lendo from comment #20)
> Still reproducible.


When opening the first attached file (attachment 43923 [details]) I do not see them in the Navigator.
But
 - starting a new Writer document;
 - using Drawing toolbar;
 - clicking a shape and drawing it in the document
  >> F5 shows "shape 1", "shape 2" etc

Version: 6.2.0.0.alpha0+
Build ID: 8c20d5d4ad6f3e8c672337e3ba67be45a1ccb7c2
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-09-14_02:29:28
Locale: nl-NL (nl_NL.UTF-8); Calc: threaded

So..
Comment 22 Thomas Lendo 2018-09-20 11:10:42 UTC
(In reply to Cor Nouws from comment #21)
> When opening the first attached file (attachment 43923 [details]) I do not
> see them in the Navigator.
> But
>  - starting a new Writer document;
>  - using Drawing toolbar;
>  - clicking a shape and drawing it in the document
>   >> F5 shows "shape 1", "shape 2" etc
Right, but not in Calc.
Comment 23 Cor Nouws 2018-09-23 07:56:23 UTC
(In reply to Thomas Lendo from comment #22)

> Right, but not in Calc.

Ah.. better make a separate issue for that?
Comment 24 Thomas Lendo 2018-09-23 17:48:35 UTC
(In reply to Cor Nouws from comment #23)
> Ah.. better make a separate issue for that?
I'd go with the existing bug. All necessary information is here for future commits.
Comment 25 Aron Budea 2019-04-24 06:46:20 UTC
(In reply to Harald Koester from comment #17)
> Beginning with version 5.1.0 drawing objects are named automatically with
> Shape1, Shape2, ... in Writer. A differentiation between kinds of objects
> (line, rectangle, Circle, ...) is not performed like proposed in comment 10
> and comment 12.
For reference, this was done by the following commit:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=3647626309ef89bf90d8b6a6539d41d8deb6b482
author		Caolán McNamara <caolanm@redhat.com>	2015-09-17 13:55:28 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2015-09-17 14:12:08 +0100

Give drawing objects unique names by default
Comment 26 Heiko Tietze 2019-04-30 13:18:44 UTC
*** Bug 124989 has been marked as a duplicate of this bug. ***
Comment 27 Xisco Faulí 2020-03-09 13:27:41 UTC
Please add keyword 'needsUXEval' and CC 'libreoffice-ux-advise@lists.freedesktop.org' if input from UX is needed.
Comment 28 Buovjaga 2020-06-29 09:45:35 UTC
*** Bug 134344 has been marked as a duplicate of this bug. ***
Comment 29 Jim Raykowski 2020-07-16 17:42:35 UTC
*** Bug 134378 has been marked as a duplicate of this bug. ***
Comment 30 Heiko Tietze 2020-10-29 10:45:19 UTC
*** Bug 137837 has been marked as a duplicate of this bug. ***
Comment 31 Heiko Tietze 2020-10-29 10:46:37 UTC Comment hidden (obsolete)
Comment 32 Heiko Tietze 2020-10-29 10:47:11 UTC Comment hidden (obsolete)
Comment 33 Telesto 2020-10-29 11:26:17 UTC
(In reply to Heiko Tietze from comment #32)
> Shall we switch the default of the Show Shapes selection from "Named Shapes"
> to "All Shapes"?

From my perspective +1
Comment 34 Heiko Tietze 2020-11-12 09:09:48 UTC
We discussed the topic in the design meeting and recommend to change the default from "Only named shapes" to "All shapes" but keep both for the rare workflows where unnamed objects should be hidden. This applies also to other modules.

Jim, one for you or make it an easyhack?
Comment 35 Jim Raykowski 2020-11-12 22:45:55 UTC
I'll take this as it is something that is able to utilize effort made to ensure object name uniqueness when cloning draw objects. If this patch proves correct, current code specific for draw objects name uniqueness in Writer should be able to be removed. It works the same across all modules.

https://gerrit.libreoffice.org/c/core/+/105774
Comment 36 Heiko Tietze 2020-11-13 07:15:10 UTC
(In reply to Jim Raykowski from comment #35)
> I'll take this as it is something that is able to utilize effort made to
> ensure object name uniqueness when cloning draw objects.

Uniqueness is one reason but the other is the ability to hide items in the Navigator. Removing the option might feel like a regression for many.
Comment 37 Jim Raykowski 2020-11-13 08:30:43 UTC
(In reply to Heiko Tietze from comment #36)

> Uniqueness is one reason but the other is the ability to hide items in the
> Navigator. Removing the option might feel like a regression for many.

An object can be hidden by editing the name and setting it empty. Better might be a setting somewhere in the Options dialog to enable or disable automatic object names.
Comment 38 Jim Raykowski 2020-11-16 08:51:57 UTC
Additional effort to provide unique names based on object type has been done in  patch set 3. The patch seems to also fix crash reported in Bug 130629.
Comment 39 Jim Raykowski 2020-11-16 08:53:22 UTC
Created attachment 167325 [details]
unique drawing object names demo 1
Comment 40 andreas_k 2020-11-16 08:54:42 UTC
(In reply to Jim Raykowski from comment #39)
> Created attachment 167325 [details]
> unique drawing object names demo 1

yes please this is the way to go. thanks a lot
Comment 41 andreas_k 2020-11-16 08:56:00 UTC
In addition to the command label name the command icon should be used. 

If you need new icons for something, let me know.
Comment 42 Jim Raykowski 2020-11-16 08:56:34 UTC
Created attachment 167326 [details]
unique drawing object names demo 2
Comment 43 andreas_k 2020-11-16 09:00:51 UTC
That's great that text boxes (Fontwork) use the text as label name. This is well known from Gimp or PS. how would it work with Text boxes where you have a lot text? show only the first 2 names,.. ?
Comment 44 Jim Raykowski 2020-11-16 09:01:20 UTC
Created attachment 167327 [details]
unique drawing object names demo 3
Comment 45 Jim Raykowski 2020-11-16 09:18:44 UTC
(In reply to andreas_k from comment #43)
> That's great that text boxes (Fontwork) use the text as label name. This is
> well known from Gimp or PS. how would it work with Text boxes where you have
> a lot text? show only the first 2 names,.. ?

I don't think Fontworks with a lot of text will affect the label name. They are created from the STR_ObjNameSingul defines in include/svx/strings.hrc
Comment 46 Jim Raykowski 2020-11-16 09:22:36 UTC
(In reply to andreas_k from comment #41)
> In addition to the command label name the command icon should be used. 
> 
I'll look into it.

> If you need new icons for something, let me know.

Thanks!
Comment 47 Heiko Tietze 2020-11-16 09:25:58 UTC
Wouldn't 

Shape 1
Shape 2
Shape n

be better than

Shape
Shape_0
Shape_1
Shape_n

(Start with 1, add a number to every item; and double-check what happens when "Shape X" is deleted- replace the number or keep empty)
Comment 48 andreas_k 2020-11-16 09:28:34 UTC
(In reply to Jim Raykowski from comment #45)
> I don't think Fontworks with a lot of text will affect the label name. They
> are created from the STR_ObjNameSingul defines in include/svx/strings.hrc

True.

When you add an a Text Box in writer it was listed as >>Shape 1<<. If possible I suggest for Text Boxe to use the label first x names of the Text Box.
Comment 49 Telesto 2020-11-16 11:04:27 UTC
(In reply to Heiko Tietze from comment #47)
> Wouldn't 
> 
> Shape 1
> Shape 2
> Shape n
> 

FWIW: This reminds me about a image/shape naming issue in Writer. I did argue about different naming style (especially in case of copy's of names items) and order they are presented in. In Writer Shape 100 can be first shape on page etc. While number suggesting a hierarchical order.

Will search for the relevant bug report/comment soon
Comment 50 Telesto 2020-11-16 11:48:31 UTC
(In reply to Telesto from comment #49)
> Will search for the relevant bug report/comment soon

Bug 134960 [mostly containing my own opinion, without magic bullet]. However not big fan of numbering items. 

And if this would be numbering, don't start with 0. But with say 0001 to get a nice list. Or align with what with digital camera's use. Say: IMGP3606 

IMG (Image) + P (Picture) + Number (And everything BOLD and without space to make it it easy to read. Smallcap/Caption bit restless to look at, IMHO

Of course not knowing what the format would be for say shape? SHPP? Shape (SHP) + P (Picture?) + number?
Comment 51 Telesto 2020-11-16 11:57:26 UTC
Forgot:
Maybe name everything internally: IMGP0001 and up (ideally in order with document structure). While next to that is a naming attribute/column with the user defined name.  

As long as empty they User Defined name will be the internal name.

Additional option would be to make unique IMG dynamic. So if image IMGP0200 is pasted before IMGP0001, IMGP0001 will change in IMGP0002 and IMGP0200 becoming IMGP0001.

But that's my fantasizing around. Not sure how useful (and CPU expensive) that would become; or how hard to follow code-wise.

Only some thoughts :-)
Comment 52 Jim Raykowski 2020-11-23 04:01:19 UTC
Created attachment 167490 [details]
unique drawing object names demo 4
Comment 53 Jim Raykowski 2020-11-23 04:02:02 UTC
Created attachment 167491 [details]
unique drawing object names demo 5
Comment 54 Jim Raykowski 2020-11-23 04:03:04 UTC
(In reply to Heiko Tietze from comment #47)
> Wouldn't 
> 
> Shape 1
> Shape 2
> Shape n
> 
> be better than
> 
> Shape
> Shape_0
> Shape_1
> Shape_n
> 
> (Start with 1, add a number to every item; and double-check what happens
> when "Shape X" is deleted- replace the number or keep empty)

I agree. Please see demo 4 and 5 which show patch set 5 effort to do this.
Comment 55 Telesto 2020-11-23 07:49:06 UTC
They demo is about they initial insertion phase. Or is this they scope as such?
Else i would like to know what happens on open foreign formats. Or if someone opens a file with say multiple objects without name?

Anyhow thanks for looking at this
Comment 56 Jim Raykowski 2020-11-23 08:07:22 UTC
(In reply to Telesto from comment #55)

> Else i would like to know what happens on open foreign formats. Or if
> someone opens a file with say multiple objects without name?
> 

When a file is opened objects without names remain without names. As far a I can tell foreign file formats are unaffected on opening.
Comment 57 Heiko Tietze 2020-11-23 08:57:02 UTC
(In reply to Jim Raykowski from comment #54)
> I agree. Please see demo 4 and 5 which show patch set 5 effort to do this.

Awesome! I wonder what happens when you delete "Shape 2" and three have been added. And it's also important to allow both show and hide the "unnamed" objects (now with inverted logic where all are shown by default).
Comment 58 Jim Raykowski 2020-11-24 07:16:29 UTC
Created attachment 167525 [details]
unique drawing object names demo 6

(In reply to Heiko Tietze from comment #57)

> Awesome! I wonder what happens when you delete "Shape 2" and three have been
> added.

The next shape added will receive the name "Shape 2". Demo 6 shows this and a self surprise finding that inserted controls fall under drawing objects.

> And it's also important to allow both show and hide the "unnamed"
> objects (now with inverted logic where all are shown by default).

Is this only for Draw/Impress? With this patch, the only way to make an "unnamed" object is to rename the object with no name.
Comment 59 Heiko Tietze 2020-11-24 08:46:00 UTC
(In reply to Jim Raykowski from comment #58)
> > And it's also important to allow both show and hide the "unnamed"
> > objects (now with inverted logic where all are shown by default).
> 
> Is this only for Draw/Impress? With this patch, the only way to make an
> "unnamed" object is to rename the object with no name.

It's relevant for all modules, see also bug 137837. Most users struggle with not visible objects but some may use it to hide a number of objects by not naming them. And the idea was to keep the function but switch its default. I would expect to not see any "<Shape|PolyLine|etc> 1..n" object when the option is off.
Comment 60 Jim Raykowski 2020-11-29 19:58:33 UTC
Created attachment 167656 [details]
patch set 7 Draw/Impress demo

Patchset 7 makes selection of an unnamed or named object in the Draw/Impress Navigator tree select the object in the document. For Draw/Impress, order plus object type is used for unnamed shape object identification in the Navigator tree. These names are not assigned to the shape object. Calc and Writer Navigators do not have the unnamed/named object feature. For these, unique object names are assigned to the shape object. Demo7 shows Draw/Impress Navigator unnamed/named object selection and that object name assignment does not happen automatically.
Comment 61 Heiko Tietze 2020-11-30 10:10:55 UTC
(In reply to Jim Raykowski from comment #60)
> Patchset 7 makes selection of an unnamed or named object...

Awesome! I assume renaming "Shape 1 (Circle)" not to shape1 but again "Shape 1 (Circle)" makes it also a user-named object. Does it? Not a big deal if not, the type in addition to the actual name makes it very unlikely that users use this exact string.
Comment 62 Jim Raykowski 2020-12-01 01:02:25 UTC
(In reply to Heiko Tietze from comment #61)

> Awesome! I assume renaming "Shape 1 (Circle)" not to shape1 but again "Shape
> 1 (Circle)" makes it also a user-named object. Does it?

I didn't test this case until you mentioned it. Indeed it does make it a user-named object. Automatic unnamed object naming appears to work as expected after doing so.

Patchset 8 makes the Draw/Impress Navigator list all shapes by default.

Possibly this patch should be split into four parts,
1) Writer and Calc drawing object automatic naming.
2) Draw/Impress unnamed shape name (shape type) is appended.
3) Draw/Impress Navigator unnamed shape object selection selects shape object in the document.
4) Draw/Impress Navigator list all shapes by default.
or just keep these all together in one patch as is already done?
Comment 63 Heiko Tietze 2020-12-01 06:22:18 UTC
(In reply to Jim Raykowski from comment #62)
> or just keep these all together in one patch as is already done?

No preference from my side here.
Comment 64 Telesto 2020-12-01 07:30:45 UTC
(In reply to Heiko Tietze from comment #63)
> (In reply to Jim Raykowski from comment #62)
> > or just keep these all together in one patch as is already done?
> 
> No preference from my side here.

Splitting maybe useful for debugging/bibisecting. Delivering  more specific results. And would make it possible to selectively revert something in worse case.

But the unwritten rules on this can be found in the irc dev channel; long term experts on the matter. No idea which kind of side-effects should be expected, if there is something....
Comment 65 Jim Raykowski 2020-12-01 10:35:09 UTC
Splitting the patch up seems like the best thing to do. 

Here are links to each:

sd navigator: make 'All shapes' the default
https://gerrit.libreoffice.org/c/core/+/106955

sd navigator: enhance automatic shape name
https://gerrit.libreoffice.org/c/core/+/106957

sd navigator: make unnamed shape select, select shape object
https://gerrit.libreoffice.org/c/core/+/106958

Give draw object a name when made
https://gerrit.libreoffice.org/c/core/+/105774
Comment 66 Commit Notification 2020-12-03 20:37:34 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/70fd160ea0c2a2afeee520f450f1ed4f81fa88f3

tdf#34828 sd navigator: make 'All shapes' the default

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 67 Commit Notification 2020-12-03 20:38:48 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/cbc43bef143f3109bdf3bf981317ae74b73cde5a

tdf#34828 sd navigator: enhance automatic shape name

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 68 Commit Notification 2020-12-03 20:40:02 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/f0878173e1963cf8db5f60ced6d19da24e18bc41

tdf#34828 sd navigator: make unnamed shape select select shape object

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 69 Commit Notification 2020-12-04 07:10:02 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/986952dd52861563006d0ba178e8bdd44247af81

tdf#34828 sd navigator: fix crash when page item entry is selected

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 70 Buovjaga 2020-12-07 18:07:58 UTC
*** Bug 90277 has been marked as a duplicate of this bug. ***
Comment 71 Commit Notification 2021-03-25 19:29:35 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/50b731c84cb17d7f05a690d90588e90ee267d1c2

tdf#34828 Give draw object a name when made

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.