Bug Hunting Session
Bug 34871 - OS locale overwrites user chosen language
Summary: OS locale overwrites user chosen language
Status: RESOLVED DUPLICATE of bug 36324
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86 (IA32) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-01 07:27 UTC by Nick White
Modified: 2012-12-10 16:24 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nick White 2011-03-01 07:27:41 UTC
Currently, libreoffice writer kindly changes the language it spellchecks etc in, according to the locale of the OS. The most obvious place for users to change the language for a document is by changing the spellchecking language (by selecting a different language from the bottom toolbar). The problem with this is that very soon thereafter (after inserting a few characters into the document) libreoffice changes the language back to the OS locale setting, making the language selection nearly useless.

Ideally, if the language is changed for a document, through libreoffice's interface, it should remain that language, even if the locale of the OS is different.

I've tested this behaviour on Windows XP.
Comment 1 Cédric Bosdonnat 2011-03-02 08:32:19 UTC
As per http://wiki.documentfoundation.org/BugReport

could you give more precise steps to reproduce? Mixing UI language and default lang for documents isn't a good idea IMHO.
Comment 2 Don't use this account, use tml@iki.fi 2011-03-07 23:50:56 UTC
Nick, please do as Cédric asked if you want your bug report to be taken seriously.
Comment 3 Nick White 2011-03-08 03:41:11 UTC
Sorry for taking so long to reply.

LibreOffice is version 3.3.1, OOO330m19 (Build:8), tag libreoffice-3.3.1.2

Steps to reproduce:

1. Open Windows "Text Services and Input Languages": Start -> Control Panel -> Regional and Language Options -> Languages -> Details
2. Click Add... -> select a different language & KB layout -> OK -> OK -> OK
3. Open a new document in LibreOffice writer, and write a few lines of text
4. Select all, then click on the 3rd section from left on the status bar to bring up languages. Select a language different to the language you added in 2
5. Switch the locale / keyboard to the new language in 2: Click on the 2 letter country code on the XP language bar, then click the new language
6. Type new text into the document, and find that it is now marked as in the new language.

Perhaps the issue is that the UI should make it easy to say "this whole document is in french, and is likely to stay that way", which disables changing OS locale changing the language text is inserted into. This is what I expected the option in 4 to do.
Comment 4 Don't use this account, use tml@iki.fi 2011-03-08 03:55:58 UTC
Ah. Firstly, I think you are confusing the concepts "OS locale" (the term "locale" isn't used as such much on Windows) and "keyboard layout".

When you add a new keyboard layout in "select a different language & KB layout" you are just adding a new keyboard layout. Despipte the (in my opinion) unfortunate wording in that dialog, I think one is not supposed to draw any conclusions as to what *language* keyboard input represents based on the keyboard *layout*. (Sure, to write for instance Greek, one would most naturally use a Greek keyboard layout. But in many cases, there is no such clear correspondence.)

You don't change the OS locale even if you change keyboard layout.

But anyway, what you are saying is that LibreOffice sets the language of entered text based on the keyboard layout? That would indeed be wrong in my opinion too. I will need to investigate.

Maybe that could/should be done for a few clear-cut cases where a keyboard layout can be used well just for a single language (like (just guessing here) Greek, Hebrew, and the IMEs for CJK languages).

But for instance in my personal case, the Swedish and Finnish keyboard layouts are in fact identical (the hardware keyboards certainly are identical to the best of my knowledge; the keys for "Caps Lock", "Insert" etc have the English abbreviations on them (!)), and can be used equally well to write either language, or to write English, and many other languages that use Latin script, for that matter...
Comment 5 Nick White 2011-03-08 04:17:59 UTC
(In reply to comment #4)
> But anyway, what you are saying is that LibreOffice sets the language of
> entered text based on the keyboard layout? That would indeed be wrong in my
> opinion too. I will need to investigate.

That is what I thought was the case. But actually, I was wrong. The wording of Windows' language vs kb layout stuff isn't the clearest. Glad you made me write out the reproduction stuff so I had to methodically think through it ;)
 
Still, the fact that a document's locale is changed according to that of the operating system seems bad to me (it's only for newly inserted text, mind). If I'm sent a French document to make a few changes to, it shouldn't matter that Windows considers me as working in English.

So to be specific, I am talking about changing the language from that dialog, not the keyboard.
Comment 6 Christian Dywan 2011-04-14 06:04:25 UTC
Typing in an English document with an Arabic keyboard layout changes the document language to Hindi, tested git master on Ubuntu Maverick.
No change happens if I type with a Greek, French or German layout.

It's worth noting that the keyboard layout affects localised shortcuts  in menus (KeysymNameReplacement) unlike GTK+ and Qt which only regard the locale, not the layout.
Comment 7 Björn Michaelsen 2011-12-23 11:47:44 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 8 Björn Michaelsen 2011-12-23 17:02:41 UTC
needinfo keyword redundant by needinfo status.
Comment 9 sasha.libreoffice 2012-01-20 05:55:22 UTC
my be this bugreport is functionality request: Add option to disable language sensitivity on Windows.
This my be useful if both document and keyboard languages are latin characterset.
But unuseful if one language is with different characterset, for example English and Greek.
Comment 10 Florian Reisinger 2012-08-14 14:00:47 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 11 Florian Reisinger 2012-08-14 14:01:55 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 12 Florian Reisinger 2012-08-14 14:06:36 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 13 Florian Reisinger 2012-08-14 14:08:38 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 14 manj_k 2012-12-10 16:24:45 UTC

*** This bug has been marked as a duplicate of bug 36324 ***