Bug 34892 - Unable to play AVI videos in Impress
Summary: Unable to play AVI videos in Impress
Status: CLOSED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: All Linux (All)
: medium normal
Assignee: Radek Doulik
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-01 17:37 UTC by Jean-François Fortin Tam
Modified: 2013-02-10 08:34 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
screencast (847.84 KB, video/ogg)
2011-03-01 17:37 UTC, Jean-François Fortin Tam
Details
screencast (alternate method with drag and drop) (929.75 KB, video/ogg)
2011-03-01 17:37 UTC, Jean-François Fortin Tam
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-François Fortin Tam 2011-03-01 17:37:13 UTC
Created attachment 43995 [details]
screencast

No matter what video file type I try to insert (ogg theora, mp4 h.264, etc.), I am unable to see and play video in Impress.

This is with Ubuntu 10.10 and the 3.3.1 release from the libreoffice PPA. Gstreamer apps can play all my videos fine.
Comment 1 Jean-François Fortin Tam 2011-03-01 17:37:53 UTC
Created attachment 43996 [details]
screencast (alternate method with drag and drop)
Comment 2 Jean-François Fortin Tam 2011-03-01 17:39:04 UTC
I almost forgot: this doesn't work in slideshow (F5) mode either.
Comment 3 Rainer Bielefeld Retired 2011-03-01 22:47:12 UTC
More or less [reproducible] with "LibreOffice 3.3.1  – WIN7  Home Premium  (64bit) German UI [OOO330m19 (build 8 / tag 3.3.1.2)]"
I tried 
<http://medien.wdr.de/m/1296842400/angeklickt/wdr_fernsehen_angeklickt_20110204.mp4>
and got Message "The format of the selected file is not supported"
But some win7_scenic-demoshort_raw.wtv or Wildlife.wmv worked fine.

It's a general LibO Problem. And of course, Winamp and VLC play those videos without problems.

Additional strange: Media player only plays files that will not appear in the file open dialog with selection "Media files", only with "All files".

I sometimes hear advice "take DirectShow" - what ever that might be?

This one might be related to or DUP of 
Bug 34757 - Can not insert .ogg sound files
Comment 4 Cédric Bosdonnat 2011-03-02 01:02:16 UTC
Could you check whether this is actually a duplicate of bug 34757?
Comment 5 Rainer Bielefeld Retired 2011-03-02 01:29:43 UTC
> Could you check whether this is actually a duplicate of bug 34757?

That's hard to say, currently I do not understand all details of bug 34757, but I will keep at it.
Comment 6 sasha.libreoffice 2011-03-02 04:47:34 UTC
In case of Media Player it is more simply to reproduce the bug: if it not plays, then it is surely a bug.
In case of presentaton we should set proberly many other params in slide to play.
Comment 7 Jean-François Fortin Tam 2011-03-02 05:46:35 UTC
FWIW, compared to bug 34757, I am not running Windows, but Linux. As far as I know, GStreamer is the standard here. Besides, bug 34757 is about audio, this one is about videos.
Comment 8 Rainer Bielefeld Retired 2011-03-02 06:05:24 UTC
Also saw that problem with LibO on XP and OOo3.1.1 on 2 other PC.

Currently, because several media file types are conceerned, I believe it's a common problem and activities should be concentrated in

Bug 34757 - Contemporary sound/video media file types like ogg-vorbis not supported

under that very general heading. If necessary (may be that video problems have different roots), other Bug reports like this one can be splitted for particular file types.

*** This bug has been marked as a duplicate of bug 34757 ***
Comment 9 Roman Eisele 2012-05-04 05:28:29 UTC
This report, as it stands, is about an Impress issue, therefore changed 'Component' field accordingly.

Of course, comment #3 tells us "It's a general LibO Problem", but for the general problem we have bug 34757, so I propose to use "Impress" for the Component here to make it easier to find this report when someone searches for Impress problems, and to use the general "Libreoffice" for the Component field in bug 34757. (The other possible solution was to remove 'Impress' from the Summary field here.)
Comment 10 sasha.libreoffice 2012-06-29 04:36:12 UTC
Changing to Unconfirmed because bug 34757 now closed.
Problem with ogg audio on Linux solved

But roblem with mp3 audio on Linux remains.
And problem with video on Linux also remains.
Comment 11 Valek Filippov 2012-07-07 12:49:43 UTC
Works for me in LO 3.6beta2.

Jean-François, could you check on your system with 3.6beta2 or beta3?
Comment 12 sasha.libreoffice 2012-08-17 09:48:32 UTC
in 3.5.5 and 3.6.0 on Alt6 64 bit, for installing used rpm files from libreoffice.org:
When I press Insert->Movie and sound and insert mpeg file about 30 Mb size, it works. But when I insert mpeg file about 200 Mb, dialog "Insert movie and sound" itself hangs. I should kill soffice process in this case.
But may be it is an another bug
Comment 14 sasha.libreoffice 2012-08-20 08:29:11 UTC
Thanks for links. They are very useful for testing.
First link not working, but I used my own avi file.
All mentioned file types working correctly in 3.5.5 and 3.6.0rc on Alt6 64 bit
But with ogv file happens problem, mentioned in comment 12.
How I produced problem: inserted another video file, then inserted this file. Dialog hangs. Resembles memory corruption. It is unknown if problem is in office or in Alt6 distro. After restarting office ogv works correctly.
But all about (or connected with) gstreamer is working correctly.
Comment 15 Alex Thurgood 2012-11-19 09:26:40 UTC
I can't get any media (sound or video) to insert into an Impress slide with my Linux 32bit build from master, yet I can read the files the OP posted up as samples, either in my browser or separately with VLC.

I get the error message "The format of the file is unsupported"


Alex
Comment 16 sasha.libreoffice 2012-11-19 12:07:48 UTC
Works correctly in:
3.5.7 (installed from Fedora repo)
3.6.3 (installed from rpm from libreoffice.org)
on RFR 17 64 bit "Beefy miracle"
used for testing all mentioned above files except of avi and my own avi file.
In all cases LO installed from rpm (in comment 12 and 14 too)
IMHO problem may be or in deb package or in Linux distro or 32 bit specific
Comment 17 sasha.libreoffice 2013-02-08 07:53:17 UTC
Works correctly in 3.6.2.2 on Ubuntu 12.10 64bit updated until now
(tested 5 mentioned in comment 13 formats)
For testing I placed video into first slide using Insert->Video and then pressed F5
Comment 18 Alex Thurgood 2013-02-08 12:50:39 UTC
Confirming for AVI files on Linux 32bit master build
 
Version 4.1.0.0.alpha0+ (Build ID: 7e2f34a3172a756a0fd70cae1294250206945a6)

What works (tested with files provided by reporter):

MOV file
WEMB file
OGV file
FLV file

What _doesn't_ work :
AVI files, e.g :
http://www.engr.colostate.edu/me/facil/dynamics/avis.htm

Changing title to reflect updated information.

Alex
Comment 19 Alex Thurgood 2013-02-08 12:55:08 UTC
Addin Michael Meeks to CC, I believe he did the new gstreamer integration.
@Michael : is there some reason why AVI's don't play ?


Alex
Comment 20 sasha.libreoffice 2013-02-08 13:11:47 UTC
reproduced problem without LO.
when I open file drop.avi from link in previous comment in Totem, it tells:
Installing resources for GStreamer
Decoder Intel Indeo 4
And can not install something.

But SMPlayer works, because not uses GStreamer
Comment 21 Michael Meeks 2013-02-08 13:49:47 UTC
> Addin Michael Meeks to CC, I believe he did the new gstreamer integration.
> @Michael : is there some reason why AVI's don't play ?

If gstreamer hasn't got the codecs for your movie - then we simply cannot play it. We rely on the platform infrastructure to -actually-work- and if it does not - then there is nothing we can do.

If the video plays in 'totem' then it should work in LibreOffice. The fact it works in VLC / whatever-else-that-doesn't-use-gstreamer is not at all interesting. We are obliged to depend on the platform infrastructure here.

So - can -anyone- give me a sample file and codec set for which gstreamer/totem plays the movie fine [ and that is proved via eg. a screencast ], and for which a re-started (ie. first pkill -9 -f soffice.bin) libreoffice fails to embed the video ?

If not - there is no bug here :-)
Comment 22 Alex Thurgood 2013-02-08 14:44:03 UTC
Some console output while I was playing around, don't know whether this is significant :

(libreoffice:376): GStreamer-CRITICAL **: Failed to deactivate pad avidemux5:sink, very bad

(libreoffice:376): GStreamer-CRITICAL **: Failed to deactivate pad typefind:src, very bad

(libreoffice:376): GStreamer-CRITICAL **: 
Trying to dispose element typefind, but it is in PAUSED instead of the NULL state.
You need to explicitly set elements to the NULL state before
dropping the final reference, to allow them to clean up.
This problem may also be caused by a refcounting bug in the
application or some element.


(libreoffice:376): GStreamer-CRITICAL **: 
Trying to dispose element decodebin64, but it is in PAUSED instead of the NULL state.
You need to explicitly set elements to the NULL state before
dropping the final reference, to allow them to clean up.
This problem may also be caused by a refcounting bug in the
application or some element.

** Message: don't know how to handle video/x-indeo, indeoversion=(int)4, framerate=(fraction)30/1, width=(int)256, height=(int)240

(libreoffice:376): GStreamer-CRITICAL **: Failed to deactivate pad avidemux3:sink, very bad

(libreoffice:376): GStreamer-CRITICAL **: Failed to deactivate pad typefind:src, very bad

(libreoffice:376): GStreamer-CRITICAL **: 
Trying to dispose element typefind, but it is in PAUSED instead of the NULL state.
You need to explicitly set elements to the NULL state before
dropping the final reference, to allow them to clean up.
This problem may also be caused by a refcounting bug in the
application or some element.


(libreoffice:376): GStreamer-CRITICAL **: 
Trying to dispose element decodebin62, but it is in PAUSED instead of the NULL state.
You need to explicitly set elements to the NULL state before
dropping the final reference, to allow them to clean up.
This problem may also be caused by a refcounting bug in the
application or some element.

** Message: don't know how to handle video/x-indeo, indeoversion=(int)4, framerate=(fraction)30/1, width=(int)256, height=(int)240
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x0296fa6c, pid=376, tid=3064248448
#
# JRE version: 6.0_24-b24
# Java VM: OpenJDK Client VM (20.0-b12 mixed mode, sharing linux-x86 )
# Derivative: IcedTea6 1.11.5
# Distribution: Ubuntu 12.04 LTS, package 6b24-1.11.5-0ubuntu1~12.04.1
# Problematic frame:
# C  [libsvxcorelo.so+0x29aa6c]  SdrObject::SendUserCall(SdrUserCallType, Rectangle const&) const+0x3e
#
# An error report file with more information is saved as:
# /home/Development/libo/core/hs_err_pid376.log
Comment 23 Alex Thurgood 2013-02-08 15:08:43 UTC
Yep, this one works :

http://archive.org/download/EricZimmermanMyTestAVIfile.../test.avi


so will close this as WFM.

Apparently, gstreamer doesn't support all AVI codecs, but that is not LO's problem as such.


Alex
Comment 24 Michael Meeks 2013-02-08 16:00:49 UTC
rather odd those warnings, were they vs 4.0 ? we ~invariably do:

            gst_element_set_state( mpPlaybin, GST_STATE_NULL );
            g_object_unref( G_OBJECT( mpPlaybin ) );

in pairs which is what is seems to be complaining about us not doing (but we do). The JRE SEGV looks nasty any way to reproduce that ?
Comment 25 Jean-François Fortin Tam 2013-02-10 05:53:38 UTC
For the record, this didn't work at all back in the 3.3.x days, be it ogg theora or webm or mkv.

With 3.5 and 3.6, it works fine now.
Comment 26 Alex Thurgood 2013-02-10 08:34:42 UTC
(In reply to comment #24)
> rather odd those warnings, were they vs 4.0 ? we ~invariably do:
> 
>             gst_element_set_state( mpPlaybin, GST_STATE_NULL );
>             g_object_unref( G_OBJECT( mpPlaybin ) );
> 
> in pairs which is what is seems to be complaining about us not doing (but we
> do). The JRE SEGV looks nasty any way to reproduce that ?

They were from my master build of 2 days ago. Will have à look and see if I can reproduce it then open separate report.

Alex