Download it now!
Bug 34990 - Draw file exported to PDF have erroneous pixel-sized dots in Acroread, not in Evince
Summary: Draw file exported to PDF have erroneous pixel-sized dots in Acroread, not in...
Status: RESOLVED DUPLICATE of bug 37559
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: All All
: lowest trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-03 15:35 UTC by Christopher M. Penalver
Modified: 2011-06-22 11:08 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
classnetwork.odg (14.35 KB, application/vnd.oasis.opendocument.graphics)
2011-03-03 15:35 UTC, Christopher M. Penalver
Details
classnetwork.pdf (14.26 KB, application/pdf)
2011-03-04 06:40 UTC, Christopher M. Penalver
Details
Screenshot.png (58.20 KB, image/png)
2011-03-04 06:47 UTC, Christopher M. Penalver
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher M. Penalver 2011-03-03 15:35:11 UTC
Created attachment 44096 [details]
classnetwork.odg

Downstream bug may be found at:
https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/689349

1) lsb_release -rd
Description: Ubuntu 10.10
Release: 10.10

2) apt-cache policy libreoffice-draw
libreoffice-draw:
  Installed: 1:3.3.1-1ubuntu3~maverick1
  Candidate: 1:3.3.1-1ubuntu3~maverick1
  Version table:
 *** 1:3.3.1-1ubuntu3~maverick1 0
        500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

apt-cache policy acroread
acroread:
  Installed: 9.4.2-0maverick1
  Candidate: 9.4.2-0maverick1
  Version table:
 *** 9.4.2-0maverick1 0
        500 http://archive.canonical.com/ubuntu/ maverick/partner i386 Packages
        100 /var/lib/dpkg/status

apt-cache policy evince
evince:
  Installed: 2.32.0-0ubuntu1.1
  Candidate: 2.32.0-0ubuntu1.1
  Version table:
 *** 2.32.0-0ubuntu1.1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick-updates/main i386 Packages
        500 http://security.ubuntu.com/ubuntu/ maverick-security/main i386 Packages
        100 /var/lib/dpkg/status
     2.32.0-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages

3) What is expected to happen is when one performs at the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/689349/+attachment/1763870/+files/classnetwork.odg && lodraw -nologo classnetwork.odg

File -> Export as PDF -> Save button

Then perform at the Terminal:

acroread classnetwork.pdf
evince classnetwork.pdf

it looks the same in both evince and acroread.

4) What happens instead is acroread displays erroneous red dots, while evince does not.
Comment 1 Don't use this account, use tml@iki.fi 2011-03-04 04:17:12 UTC
Where are the red dots? Could you provide screenshots *and* the exported PDF file please.
Comment 2 Christopher M. Penalver 2011-03-04 06:40:16 UTC
Created attachment 44122 [details]
classnetwork.pdf
Comment 3 Christopher M. Penalver 2011-03-04 06:47:48 UTC
Created attachment 44124 [details]
Screenshot.png
Comment 4 Christopher M. Penalver 2011-03-04 06:52:09 UTC
Tor Lillqvist, thank you addressing this. Attached are the PDF and screenshots (with pixel-sized dots highlighted) as requested. For myself, the pixel-sized dots are actually black (original reporter noted red), but may be different based on platform/version of acroread one is using, IDK.
Comment 5 Don't use this account, use tml@iki.fi 2011-03-04 08:18:25 UTC
Thanks for showing where the dots are, I wouldn't have noticed otherwise.

I can see the dots also in a PDF exported from LO on Windows.
Comment 6 Christopher M. Penalver 2011-06-22 09:36:43 UTC
*** Bug 37559 has been marked as a duplicate of this bug. ***
Comment 7 Rainer Bielefeld Retired 2011-06-22 11:08:00 UTC
I do not think that it's useful to duplicate a Bug report containing all required information to one without pointing the method of resolution.

So I reverse the DUP definition, because the reason for the problem is very well described in Bug 37559. 

The problem has nothing to do with the PDF Viewer, but with really existing extra dots in the drawing, what will be shown sometimes in some Viewers under particular circumstances, and sometimes not.

*** This bug has been marked as a duplicate of bug 37559 ***