Bug 35030 - Customize Keyboard Reset button doesn't work
Summary: Customize Keyboard Reset button doesn't work
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Heiko Tietze
URL:
Whiteboard: target:7.4.0 target:7.5.0
Keywords:
: 82248 87181 (view as bug list)
Depends on:
Blocks: Customize-Dialog-Keyboard
  Show dependency treegraph
 
Reported: 2011-03-05 02:05 UTC by Rainer Bielefeld Retired
Modified: 2022-09-23 14:17 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Two reset buttons (78.23 KB, image/png)
2016-11-19 18:19 UTC, Muhammet Kara
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-03-05 02:05:43 UTC
I found that problem with "LibreOffice 3.3.1  – WIN7  Home Premium  (64bit) English UI [OOO330m19 (build 8 / tag 3.3.1.2)]" i found during my tests for Bug 35017 - Shortcuts that can not be modified permanently should be marked

After Comment 1 Step 10 you will have "Style Numbering" on <f4>

Now continue:
20. 'Tools > Customize > Keyboard - F4'
21. <Reset>
   expected: Writer shortcut "Numbering" will be deleted, so that LibO function
             "Data source" will be proceeded in future
   actual: nothing, shortcut "Numbering" remains

I tested with OOo 1.1.4, there RESET works as expected.
Comment 1 sasha.libreoffice 2011-04-06 06:46:26 UTC
In window Customize in tab Keyboard:
if something changed, but not pressed OK, then button Reset work
if OK pressed, then button Reset does nothing

produced on Mandriva 64 bit with LibreOffice 3.3.2
Comment 2 Rainer Bielefeld Retired 2011-08-02 09:46:56 UTC
CONFIRMED due to comment 1

That might have been some misunderstanding of me, from <https://bugs.freedesktop.org/show_bug.cgi?id=39452#c3> I know better how such buttons should work.

But I still do not understand what a RESET button should do there.

I read in OOo 3.2 Help: "Resets modified values back to the default values."
So IMHO a DEFAULT button would be required here.

What I see with "LibreOffice 3.4.2  – WIN7  Home Premium  (64bit) English UI [OOO340m1 (Build:203)]":

1. Menu 'Tools -> Customize -> Keyboard'
2. Go to <F7>
3. Press Delete: Function behind <f7> will be deleted
4. press <Reset>
   Function "Spell Check" reappears for  <f7>, so this is a BACK button
5. Redo 3., 4.
6. <ok>
7. Redo 1., 2.
   As expected <f7> without function
8. Press 'Reset'
   Nothing happens, <f7> still without function, so <f7>, is a BACK button

So HELP is wrong here, because it describes a DEFAULT button.

I believe such a dialog needs a BACK and additionally a DEFAULT button.

@Christoph:
Is there any general style guide what buttons where should be?

@David
Can you please adapt HELP and Documentation to final solution
Comment 3 André Schnabel 2011-08-02 09:57:03 UTC
I think, this should be split in two seperate issues, as the current behaviour is consistent with Tools - Options - Back button.

What is currently wrong is the label (should be Back as suggested) and the help for the button.

If we want to change the behaviour that should go to a differten bug (enhancement)
Comment 4 Christoph 2011-08-22 14:26:32 UTC
Hi all, some additional thoughts:
* there are two buttons "Back" that seem to be equal according the descriptions in the earlier comments, so the button at the top isn't required (or had a different functionality in the past)
* if we add "Default" functionality (reset to LibO default values), then we have to consider "change the currently selected item" vs. "reset all items" vs. "reset all items for application XYZ"
* an alternative / simple solution might be to ship the default values in a configuration file (via Load...)

Easy solution: remove the upper "Back" button and any trace in the documentation

Real solution:
* mark all items that have been changed (being non-defaults)
* turn the "Back" button into "Default" functionality (for both selected and all items)

@ Rainer: "Back" to you ...

@ André: Heading "Zurücksetzen" is missing in the German help --> separate issue?
@ Rainer: Using the upper "Back" doesn't update the list "Keys" --> separate issue?
Comment 5 David Nelson 2011-08-22 23:59:49 UTC
I've bookmarked this in my mail to follow the conversation and take any appropriate action in the documentation and online help when a final resolution is decided and implemented.
Comment 6 Rainer Bielefeld Retired 2011-08-23 00:23:15 UTC
> @ Rainer: Using the upper "Back" doesn't update the list "Keys" --> separate
> issue?

I think THIS report is for that issue, it seems that the button is completely dead with "LibreOffice 3.4.3 RC1 - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:301)]" 

Steps to reproduce:
1. Menu 'Tools -> Customize -> Keyboard
2. select <f7>
3. press button <Delete>
   Function in "Shortcut keys" pane disappears
4. <ok>
5. Menu 'Tools -> Customize -> Keyboard
6. Click <Reset> button (you can try both)
   Expected: the one right from Help (what IMHO should have name "Default")
             should restore the default "Spell Check" function for <f7>
   Actual: Nothing

BTW: the other "Reset" button IMHO  should have name "Back". The button naming (not only here) is completely messed up, with German UI The "Back" button has name "Zurücksetzen", the "Default" Button has name "Zurück". But that's a different issue.
Comment 7 Björn Michaelsen 2011-12-23 13:25:05 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.
Comment 8 Kytrix 2014-04-26 10:26:31 UTC
This bug is still present in version Version: 4.2.3.3

On linux x64


When changing a keyboard shortcut, saving by OK,
then re-open the keyboard shortcut window, Reset button doesn't reset to default value !
Comment 9 sasha.libreoffice 2014-04-28 05:21:32 UTC
Thanks for interesting in this bug
Sorry, but "version" is version where bug appears. Not a current version. Changing settings back.
Comment 10 QA Administrators 2015-06-08 14:42:13 UTC Comment hidden (obsolete)
Comment 11 Maxim Monastirsky 2016-01-21 21:14:50 UTC
*** Bug 87181 has been marked as a duplicate of this bug. ***
Comment 12 Muhammet Kara 2016-11-19 18:19:35 UTC
Created attachment 128877 [details]
Two reset buttons

Issue still persists as of

Version: 5.3.0.0.alpha1+
Build ID: f533b3f39956fe8028c1f7f7cc3c37b0feed8b57

Currently there are two "Reset" buttons on the same tab:
 * One of them (the upper one) works as "reset my current/not yet applied changes",
 * The other one (at the bottom) does "nothing at all" when pressed.
Comment 13 Yousuf Philips (jay) (retired) 2016-11-22 13:19:16 UTC
(In reply to Muhammet Kara from comment #12)
> Currently there are two "Reset" buttons on the same tab:
>  * One of them (the upper one) works as "reset my current/not yet applied
> changes",

I would expect that this button be below the 'delete' button and when pressed, it would reset the currently selected item to its default value.

>  * The other one (at the bottom) does "nothing at all" when pressed.

Similar to other tabs of the dialog, i would expect this button to reset all shortcuts their default values.
Comment 14 QA Administrators 2019-03-17 03:51:29 UTC Comment hidden (obsolete)
Comment 15 QA Administrators 2021-03-17 04:20:44 UTC Comment hidden (obsolete)
Comment 16 sdc.blanco 2022-03-07 16:44:38 UTC
repro comment 12 

Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 7ac19fbce8a35f559eebb879cd0f232bfc95e703
CPU threads: 8; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: da-DK (da_DK); UI: pt-BR
Calc: CL

adding UX-Eval to consider:

1.  possible hiding of the Reset button (on bottom, that does nothing) for the Keyboard tab
2.  improvement of extended tool tip for the other Reset button to indicate that reset works only for current session (also, on Help page [1}).


[1] https://help.libreoffice.org/7.4/en-US/text/shared/01/06140200.html
Comment 17 sdc.blanco 2022-03-07 16:47:29 UTC
*** Bug 82248 has been marked as a duplicate of this bug. ***
Comment 18 Heiko Tietze 2022-03-14 12:14:11 UTC
Removing the button makes the UI jump and I'd prefer to just disable. However, this leads to other confusion. So hiding sounds good enough.
Comment 19 sdc.blanco 2022-03-14 13:02:11 UTC
For the "remaining" reset button (on the left side), I would propose to change the extended tooltip to:

Revert any changes made to keyboard shortcuts to the assignments that were present when this dialog was opened.


And there is no tooltip at present for the Reset key, but maybe the following would be useful:

Unsaved modifications to shortcut keys are reverted.
Comment 20 Heiko Tietze 2022-03-14 13:15:53 UTC
(In reply to sdc.blanco from comment #19)
> For the "remaining" reset button (on the left side), I would propose to
> change the extended tooltip to:
> 
> Revert any changes made to keyboard shortcuts to the assignments that were
> present when this dialog was opened.

Please submit your patch independently. Not sure I manage to hide the button at all.
Comment 21 sdc.blanco 2022-03-15 06:31:05 UTC
proposal for tooltips for "reset" button

https://gerrit.libreoffice.org/c/core/+/131480
Comment 22 Commit Notification 2022-03-15 16:09:32 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/89614f20e0b04b8415178244066090bbcf115af7

Related: tdf#35030 improve description of Reset button
Comment 23 Commit Notification 2022-03-15 16:23:47 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4108348161b1f1f1693b722a828e7c9584c33cd6

Related: tdf#35030 - add tooltip and improve extended tooltip for reset

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 24 Commit Notification 2022-03-16 06:04:21 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2e8cbf38b760d2d5d76048542f15962b94acc03a

Resolves tdf#35030 - Hide Reset button for keyboard customization

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 25 Commit Notification 2022-09-23 14:17:56 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/abe8d06682c68c85f750d05409322a5eabc84158

Related: tdf#35030 hide the "reset" button more reliably

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.