Bug Hunting Session
Bug 35132 - PRINTING: Landscape print portrait and vise versa
Summary: PRINTING: Landscape print portrait and vise versa
Status: RESOLVED DUPLICATE of bug 44664
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 46102
  Show dependency treegraph
 
Reported: 2011-03-09 00:45 UTC by Bruce Carroll
Modified: 2012-03-19 03:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bruce Carroll 2011-03-09 00:45:46 UTC
When printing a one page spreadsheet that is set under Format Page to be landscape it prints portrait.  When selecting portrait as a print option it prints landscape.

Printing to a Epson B1100.
Comment 1 Pierre Baraduc 2011-06-24 05:37:14 UTC
This is not restricted to spreadsheets. The same bug happens in WRITER for .doc documents (at least). 

Strangely, the text appears portrait-mode on screen, and every .doc-reading application will display it as portrait (Apple Pages, Microsoft Word 2003), but if you look at the document properties it'll show 'landscape' (although switching it to 'portrait' will display the document incorrectly as landscape on screen in LibreOffice). All seems consistent as long as you don't want to get an output. I only printed as PDF but this generated a landscape-oriented page, with portrait-oriented lines, thus cropping text at the top & bottom. The only way to solve the problem was to switch it to portrait in Microsoft Office, which did not change the on-screen display but cured the printing (to PDF) problem.
Comment 2 Björn Michaelsen 2011-12-23 11:44:54 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 Bruce Carroll 2012-01-04 01:44:03 UTC
The new Beta version appears to be working correctly now.

Many thanks.

Bruce

On 23/12/2011 19:44, bugzilla-daemon@freedesktop.org wrote:
> https://bugs.freedesktop.org/show_bug.cgi?id=35132
>
> Björn Michaelsen<bjoern.michaelsen@canonical.com>  changed:
>
>             What    |Removed                     |Added
> ----------------------------------------------------------------------------
>               Status|NEW                         |NEEDINFO
>
> --- Comment #2 from Björn Michaelsen<bjoern.michaelsen@canonical.com>  2011-12-23 11:44:54 PST ---
> [This is an automated message.]
> This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
> started right out as NEW without ever being explicitly confirmed. The bug is
> changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
> to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2
> prereleases.
> Details on how to test the 3.5.0 beta1 can be found at:
> http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1
>
> more detail on this bulk operation:
> http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
>
Comment 4 sasha.libreoffice 2012-02-21 05:42:53 UTC
In 3.5.0 release still works correctly?
Comment 5 markusN 2012-03-17 00:23:43 UTC
Printing an A4 landscape document on a HP laser results in a portrait print
(with the respective losses). Using LibreOffice 3.4.5 OOO340m1 (Build:502).
Comment 6 markusN 2012-03-17 00:27:10 UTC
I would add that the printer preview window shows the preview correctly 
in landscape. "Just" on paper it comes out in portrait.
Comment 7 sasha.libreoffice 2012-03-17 01:05:35 UTC

*** This bug has been marked as a duplicate of bug 44664 ***