Bug Hunting Session
Bug 35139 - Java macros killed or not shown in LO, regression?
Summary: Java macros killed or not shown in LO, regression?
Status: RESOLVED DUPLICATE of bug 37015
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: x86 (IA32) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-09 03:42 UTC by Heiko
Modified: 2011-05-11 10:38 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
patch to fix (1.12 KB, patch)
2011-05-11 10:38 UTC, Noel Power
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Heiko 2011-03-09 03:42:45 UTC
I tried to embed a macro whithin a document as described on http://wiki.services.openoffice.org/wiki/Documentation/DevGuide/Scripting/Writing_Macros : (odt-ZIP-Container under Scripts/java).

When opening the document, LO 3.3.1 says, the document was defect and offers a repair. Doing so deletes the embedded macro.

Then I tried to place the macro under (ooo-profile-path)/user/Scripts/java, LO still does not show the macro when trying to execute it.

In OOo 3.3.0 both works. Is this a so wanted new limitation to LO or is it just a bug?
Comment 1 Alex Thurgood 2011-05-09 06:54:24 UTC
Probably a bug in registration of the scripting framework. Was resolved in 3.3.2, but appears to have come back again in 3.4 betas. Even though I haven't tried with a java programs, the problem also appears for python, beanshell and JS.

Alex
Comment 2 Noel Power 2011-05-10 06:33:28 UTC

*** This bug has been marked as a duplicate of bug 37015 ***
Comment 3 Noel Power 2011-05-11 10:38:11 UTC
Created attachment 46611 [details]
patch to fix

beanshell is broken because it needs the bsh.jar in the directory the extension is installed in

javascript ( when installing the extension manaully ) has an extra entry for the js.jar and the extension manager tries to register it.