Bug Hunting Session
Bug 35329 - EDITING: =núm,caract(B1) broken in [Pt]
Summary: EDITING: =núm,caract(B1) broken in [Pt]
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-15 05:40 UTC by paulo.antunespiorla
Modified: 2015-02-22 05:08 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Sample Document, see Comment 2 (83.14 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-03-18 11:51 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description paulo.antunespiorla 2011-03-15 05:40:12 UTC
We work with the language/user interface/ in Português (PORTUGAL)

In Calc, the functio LEN() works OK in language English.
In Calc, the same function LEN() is NÚM,CARACT() and works OK in language Português (Brasil)

If we change the language/user interface to Português (Portugal), the same function LEN() is NÚM,CARACT() do not work, send the error message: Err:501
Comment 1 Yifan Jiang 2011-03-15 23:09:00 UTC
Reproduced in 3.3.1, thanks for reporting!

Would Kohei have a look?
Comment 2 Rainer Bielefeld Retired 2011-03-18 11:50:15 UTC
[Reproducible] with "LibreOffice 3.3.2RC2  – WIN7  Home Premium  (64bit) [OOO330m19 (Build:202 / tag 3.3.2.2)]".

I found some additional details.

In Pt, I only can get "=núm,caract(B1)" in lower case what will not work. Pt-Br inserts a formula in uppercase, what will work.

Additionally I see a problem in the UI, when I use the function assistant, in Pt the input pane for the cell selection is missing. 

I will attach a sample document with my results and screenshots.

It seems that that function is totally broken in Pt. Might be a localization problem?
Comment 3 Rainer Bielefeld Retired 2011-03-18 11:51:04 UTC
Created attachment 44591 [details]
Sample Document, see Comment 2
Comment 4 QA Administrators 2015-02-19 15:47:55 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.0.3 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-02-19
Comment 5 Urmas 2015-02-22 05:08:57 UTC
The function assistent inserts the proper function, 'núm.caract' for me.