Bug 35332 - DOC and DOCX look different in Writer because of text position after the image
Summary: DOC and DOCX look different in Writer because of text position after the image
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc, filter:docx
Depends on:
Blocks: DOC
  Show dependency treegraph
 
Reported: 2011-03-15 06:59 UTC by sasha.libreoffice
Modified: 2020-09-15 12:18 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
document from MSWord with picture looks different in Writer (78.00 KB, application/msword)
2011-03-15 06:59 UTC, sasha.libreoffice
Details
document with indents after image (25.97 KB, application/vnd.oasis.opendocument.text)
2015-06-19 16:57 UTC, Gordo
Details
DOC and DOCX compared in MSO and LO (119.90 KB, image/png)
2020-05-29 22:01 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sasha.libreoffice 2011-03-15 06:59:30 UTC
Created attachment 44476 [details]
document from MSWord with picture looks different in Writer

In attachment is document in format .doc that looks different in Word and in Writer. Also there is screenshot of document itself. Text on right of picture is placed different.

Source of problem: Writer count begining of paragraph exactly from right edge of picture. And MSword from left edge of page, but slightly moves paragraph to right. The same behaves Word 2003 and Word 2007.

produced on Mandriva 64 bit and windows XP 32bit
LibreOffice 3.3.1.2 and 3.3.2.1rc1
Comment 1 Yifan Jiang 2011-03-15 23:55:12 UTC
Confirmed in Libreoffice 3.3.1 SLED 11 sp1. Looking forward to a fix :)
Comment 2 Björn Michaelsen 2011-12-23 11:49:38 UTC Comment hidden (obsolete)
Comment 3 sasha.libreoffice 2011-12-30 00:44:20 UTC Comment hidden (obsolete)
Comment 4 A (Andy) 2013-01-20 13:35:43 UTC
reproducible with LO 3.6.4.3. (Win7 Home, 64bit)

The file looks different in LO and Word 2007:
The tabs are different and the image has a frame as shown in the attachment.
Comment 5 bfoman (inactive) 2013-08-15 16:11:30 UTC
Confirmed with:
Version: 4.2.0.0.alpha0+
Build ID: 087a610fcd5c0c354a9ed6bfccd3451b667d62a3
TinderBox: Win-x86@6-debug, Branch:master, Time: 2013-08-04_21:41:24
Windows 8.1 Enterprise Preview 64 bit

Same results.
Comment 6 Cédric Bosdonnat 2014-01-20 08:57:13 UTC
Restricted my LibreOffice hacking area
Comment 7 Joel Madero 2015-05-02 15:41:55 UTC Comment hidden (obsolete)
Comment 8 Gordo 2015-06-19 16:57:21 UTC
Created attachment 116661 [details]
document with indents after image

The paragraphs starting with the numbers have indents of 3.75 cm before text and 1.27 cm first line.  Writer applies both after the image.  In MS Word Viewer, the first line indent is applied after the image but not the before text indent.  Maybe it is a bug in Word with it either failing to apply the before text indent or applying first line indent when it should not.

In the attachment, which is odt, if you move the image with the right arrow key, there is a point where the text (starts with “10”) no longer indents after the image because the left side of the image is now past the before text indent.  If you move the image some more then the second line of text will wrap to the left side of the image and the first line will not be indented even though the image is 4.85 cm from the left and the total for the first line indent is 5.00 cm but that could be because it is already applying the indent on the left side of the image and the 1.25 cm first line indent is occupied by the image.

I do not know whether or not Writer should ignore indents if an object occupies the space on the page before the text that is greater than the indent.

Windows Vista 64
Version: 4.4.4.2
Build ID: f784c932ccfd756d01b70b6bb5e09ff62e1b3285
Comment 9 QA Administrators 2016-09-20 10:11:07 UTC Comment hidden (obsolete)
Comment 10 Telesto 2016-12-03 20:19:51 UTC
Confirming with:
Version: 5.4.0.0.alpha0+
Build ID: 33f5bc54aaa7fe7aa9335726e30f9c349155e04d
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-12-01_23:21:05
Locale: nl-NL (nl_NL); Calc: CL
Comment 11 QA Administrators 2017-12-10 16:39:20 UTC Comment hidden (obsolete)
Comment 12 QA Administrators 2019-12-11 03:37:29 UTC Comment hidden (obsolete)
Comment 13 Timur 2020-05-29 22:01:35 UTC
Created attachment 161409 [details]
DOC and DOCX compared in MSO and LO

DOC left and DOCX right show the same issue in LO 7.1+.