Bug 35412 - Slow Opening and Saving of Large Files in Impress (incl. autosave) FILEOPEN FILESAVE
Summary: Slow Opening and Saving of Large Files in Impress (incl. autosave) FILEOPEN F...
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86 (IA32) All
: medium enhancement
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-18 02:53 UTC by D
Modified: 2012-08-31 10:05 UTC (History)
0 users

See Also:


Attachments
This is an old test file. (98.13 KB, application/vnd.oasis.opendocument.presentation)
2011-03-18 04:38 UTC, D
Details

Note You need to log in before you can comment on or make changes to this bug.
Description D 2011-03-18 02:53:08 UTC
Impress does not seem to be made for large card sets.

Opening a 530 cards file takes 18 seconds, saving it with just an additional space inserted takes 10 seconds. Since the program is blocked and unusable during the operations, this makes autosave very annoying.

It would be great if the load and save time could be decreased and (auto)save be moved into a seperate thread in order not to interfere with ongoing work.
Comment 1 D 2011-03-18 04:38:35 UTC
Created attachment 44575 [details]
This is an old test file.

This file has just over 1000 slides and takes just over 20 seconds to save on my computer. It looks like the time scales with the number of slides.

Also, editing itself slows down the more cards there are. This seems to happen in steps of roughly 50-100 cards.
Comment 2 Björn Michaelsen 2011-12-23 11:47:33 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 Volker Merschmann 2012-06-06 13:55:21 UTC
Fixed typo in Summary
Comment 4 Florian Reisinger 2012-08-14 14:00:37 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 5 Florian Reisinger 2012-08-14 14:01:44 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 6 Florian Reisinger 2012-08-14 14:06:26 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 7 Florian Reisinger 2012-08-14 14:08:28 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian