Bug 35546 - EDITING: Inserting multiple images, one per slide
Summary: EDITING: Inserting multiple images, one per slide
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Gergő Mocsi
QA Contact: Florian Reisinger
URL:
Whiteboard: target:4.1.0
Keywords:
: 38617 51067 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-03-22 08:10 UTC by Jeff P
Modified: 2015-03-22 05:13 UTC (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff P 2011-03-22 08:10:51 UTC
Starting with Microsoft Office 2003, PowerPoint has included a feature called "Insert Photo Album" which allows the user to create a presentation/slideshow from a group of images. Basically, the user selects a group of images, either individually or from a folder, then PowerPoint inserts each image on to a slide, one image per slide. You can read more about it here:

http://office.microsoft.com/en-us/powerpoint-help/create-a-photo-album-HP003088324.aspx

Back in 2006, someone with the OpenOffice community developed a macro which accomplished this task; however, it no longer works in newer versions of OpenOffice or LibreOffice.

We are a prosecutor's office and we present images to juries several times per week. When we get a case with hundreds of images, it's really time consuming to go to Insert > Picture and insert 100+ images. Thank you for your consideration.
Comment 1 Brad 2011-07-23 16:17:35 UTC
This is basic functionality for creating presentations.  IMO, it should be higher priority.

When I have time, I'll be doing a 'git clone git://anongit.freedesktop.org/libreoffice/bootstrap' and looking for the right place to get started, but if someone could point me towards the repo directory for the gui menu of impress and file importer, that would be great.  

I have experience with Java and would love to help out as I see this project as one of the cornerstones of the full open source suite and with the greatest need for more developers.
Comment 2 Björn Michaelsen 2011-12-23 11:47:32 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 sasha.libreoffice 2012-03-28 03:38:11 UTC
Thanks for new idea
I guess that it is not implemented yet and changing to New

@ Jeff P
Please, search among OpenOffice and LibreOffie extensions. May be already implemented. If not, please, attach mentioned in Description extension that not works now. May be it may fixed.
Comment 4 Florian Reisinger 2012-08-14 14:00:36 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 5 Florian Reisinger 2012-08-14 14:01:43 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 6 Florian Reisinger 2012-08-14 14:06:25 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 7 Florian Reisinger 2012-08-14 14:08:27 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 8 sasha.libreoffice 2012-08-15 08:49:10 UTC
still not implemented. Reopening
Comment 9 Florian Reisinger 2012-08-15 12:53:59 UTC
Why was this still needinfo??
Comment 10 Samuel Mehrbrodt (CIB) 2013-02-14 08:45:31 UTC
I support this Issue via FreedomSponsors: http://www.freedomsponsors.org/core/issue/181/editing-inserting-multiple-images-one-per-slide

The person who fixes that, gets some bounty.
If you want to get this fixed, consider increasing the bounty (You pay only when it actually _is_ fixed).
Comment 11 Commit Notification 2013-03-20 11:50:10 UTC
GergÅ Mocsi committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7ef3b46fd5bdfb3a87e9b0a840287fdb6ff4734b

fdo#35546, implementing 'Create Photo Album' function



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 sasha.libreoffice 2013-03-20 11:53:50 UTC
Thanks for implementing this feature
Comment 13 Samuel Mehrbrodt (CIB) 2013-03-24 22:05:17 UTC
Hi Gergő, thanks for working on this. I tested this and there are a few things that should be fixed:

– The Menu entry should be a submenu of Insert->Image and should be called "Photo Album", not "Create Photo Album"
– When I called the function once, I cannot open the Dialog again.
– In the File Chooser I cannot select a folder.
– The Up/Down/Remove buttons should be disabled, if there is no Image selected, or if there is nothing to move (only one Image)
– File Chooser should remember the last opened directory
– There should be a Checkbox "Keep Aspect Ratio" that is enabled by default, so that Images are not stretched.

Glad you are working on this :) Please claim that you are working on this at Freedomsponsors.
Comment 14 Samuel Mehrbrodt (CIB) 2013-04-10 20:00:15 UTC
*** Bug 51067 has been marked as a duplicate of this bug. ***
Comment 15 Samuel Mehrbrodt (CIB) 2013-04-11 10:19:10 UTC
Thanks for further improving this, I just tested the patch that was committed yesterday.
I like the 2/4 slide layout and that it has some space between the pictures. Also the "Keep aspect ratio" function works fine.

There are still some things to be improved:

- As written before, I cannot select a folder from the File chooser. You might add two buttons, one to import a whole folder and one to import files.
- When I add a lot of images and then create the photo album, the program takes some while and is unresponsive. It would be nice to have a progressbar for that.
- When I select the layout "1 Image with title", the image is very small. I think it should fill the whole area below the title
- To me it was unclear what the "New Text Box" button does. It creates an empty slide and so I think a better name would be "Insert Empty Slide" or "Insert Text Slide"
- The "Create" button should be called "Insert Slides". That's what it does.
- A suggestion: Instead of automatically creating the first Slide with the title "Photo Album" and the Subtitle with the Author’s name, you could add two entries where the user could enter a title and a subtitle. The default values can be the same as they are now.

You are doing a good job! Hope you have still fun hacking on this :)
Comment 16 Adolfo Jayme 2013-04-19 20:17:39 UTC
I think this bug should be marked RESOLVED FIXED, and new individual bugs be filed for every desired enhancement.
Comment 17 Florian Reisinger 2013-04-21 08:39:42 UTC
Hi,

I have not tested this feature personally, so I am very neural :)
What should be done till fixed:
If not done yet (assaid above) it into a submenu of insert
It should be possible to open the dialog more thn once
Rename New Textbox to e.g. Empty title page

Again, I have not tested it myself, so it is possible to be fixed in the meantime.

PS: if it is called CREATE photo album not INSERT photo album, the album should be a new presentation....

Thanks for the work... (PS: i will change status as soon as I know, that these things are fixed :))
Comment 18 Samuel Mehrbrodt (CIB) 2013-04-27 22:27:34 UTC
*** Bug 38617 has been marked as a duplicate of this bug. ***
Comment 19 Commit Notification 2013-05-09 10:08:00 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=aa0bc15b42e8d432def185089ea8fca17f3fd8c8

Related fdo#35546 Improve Layout of "Insert Photo Album" Dialog



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 20 Commit Notification 2013-05-09 19:41:07 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=97a055dfa7c85c8795dc9b55fb39a5b3448b29f2

Related fdo#35546: Cosmetic fixes for Photo Album Dialog



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 21 Commit Notification 2013-05-13 14:36:57 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1c7af341d068e4474774077524ccc15721ea3df3

Related fdo#35546: Simplyfy Code in Photo Album Dialog



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 22 Commit Notification 2013-05-13 14:37:15 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ba489418be7b67fd1e0e6a136ace9667a49a1013

Related fdo#35546: Further improve Layout of Photo Album Dialog



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 23 Commit Notification 2013-05-13 14:37:33 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3c480196dd66df48f8ab637a2ac26ffbca328063

Related fdo#35546: Remove the "Text box" function from Photo Album Dialog



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 24 Commit Notification 2013-05-13 15:00:08 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cd1034f87ae0c03d8107e2e1fd8f968c3f7075b3

Related fdo#35546: Remove "1 Image with Title" Layout for Photo Album Dialog



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.