Download it now!
Bug 35845 - Breaking Up a Master Document into SubDocuments Feature Fail
Summary: Breaking Up a Master Document into SubDocuments Feature Fail
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86 (IA32) Windows (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Master-Doc
  Show dependency treegraph
 
Reported: 2011-03-31 11:57 UTC by dlphan
Modified: 2020-01-12 16:35 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
The master file and the subfiles generated in OpenOffice 3.3.1 (76.91 KB, application/x-rar-compressed)
2011-03-31 11:57 UTC, dlphan
Details
zip file of the reporter (77.99 KB, application/x-compressed)
2012-08-19 16:39 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dlphan 2011-03-31 11:57:43 UTC
Created attachment 45099 [details]
The master file and the subfiles generated in OpenOffice 3.3.1

In earlier version of OpenOffice upto 3.3.1, it is possible to break up a master document into a set of smaller file each contains a chapter in the master document file, provided that each chapter had use the Heading style appropriately.
(i.e Heading 1 for the Chapter Title, Heading 2 for Subtitle,... body text for the text in the body of the chapter).

When the master file has been set up like this.  To break it up in OpenOffice,
one would choose File->Send->Create Master Document.  Upon saving the master file, OpenOffice would generate a master file and a set of files each contain a chapter.

Please see attachment for the files generated when MasterFileToBeBrokenUp.odt
is broken into test.odm (the master file) and test1.odt, test2.odt, test3.odt....

LibreOffice generate neither the master test.odm file, nor the test1.odt, test2.odt, test3.odt...  It generated nothing.

In short, the Feature that break the master document into a set of subdocument files no longer work
Comment 1 Yifan Jiang 2011-05-26 03:45:38 UTC
Not reproduced. The create master document works for me on 3.4 rc1.
Comment 2 Yifan Jiang 2011-05-26 22:00:07 UTC
(In reply to comment #1)
> Not reproduced. The create master document works for me on 3.4 rc1.

My platform is SLED 11 sp1 i586.

Since the original problem was reported in Windows, would some one else confirm the issue on Windows xp/ Windows 7 ? Thank you!
Comment 3 Björn Michaelsen 2011-12-23 11:49:22 UTC Comment hidden (obsolete)
Comment 4 Florian Reisinger 2012-08-14 14:01:54 UTC Comment hidden (obsolete)
Comment 5 Florian Reisinger 2012-08-14 14:02:56 UTC Comment hidden (obsolete)
Comment 6 Florian Reisinger 2012-08-14 14:07:30 UTC Comment hidden (obsolete)
Comment 7 Florian Reisinger 2012-08-14 14:09:36 UTC Comment hidden (obsolete)
Comment 8 dlphan 2012-08-14 15:53:55 UTC
I have verified this bug on all LibreOffice Version 3.4.4 and 3.5.  The bug is still there.  Breaking Up Master Document into subdocuments failed exactly as describe previously.  Please used the attached master file to try breaking up if you can not reproduce the failure.  Thanks.
Comment 9 Michael Meeks 2012-08-15 10:54:49 UTC
thanks for re-testing ! we rely on users to re-check their bugs vs. the latest versions :-) I imagine the problem persists for 3.6 but perhaps worth a check. So re-opening.

Thanks.
Comment 10 Julien Nabet 2012-08-18 18:05:23 UTC
dlphan: could you use an open format to compress the files like .zip, .gzip, ... and attach the new file? (I can't unrar it with Debian)
Comment 11 Julien Nabet 2012-08-19 16:39:57 UTC
Created attachment 65786 [details]
zip file of the reporter

The reporter sent me the zip so I attach it.
Comment 12 Julien Nabet 2012-08-19 18:43:30 UTC
On pc Debian x86-64 with Debian package 3.5.4.2, I reproduce the problem.
With 3.5 sources updated 2 days ago, I don't reproduce the problem.
Did you try with 3.5.5? If you reproduce the problem with it, you must wait 3.5.6 or test one of its pre-release
Comment 13 Joel Madero 2014-11-04 03:11:44 UTC
This bug is incorrectly in REOPENED status - moving to NEW. If it's been resolved in the past 2 years - please set to RESOLVED -> WORKSFORME. Thanks
Comment 14 Oliver Specht (CIB) 2015-11-10 10:19:57 UTC
The reason for not breaking up the file is that the used styles Heading 1/Heading 2 have an outline level "body text" (see 'Outline & Numbering' page in dialog "Edit paragraph style") 

OTOH there are the styles "Dau Chuong" and "Tieu Mac" that are children of Heading1/2 and they have an appropriate outline level.
Comment 15 QA Administrators 2018-05-13 02:30:36 UTC Comment hidden (obsolete)
Comment 16 Thomas Lendo 2019-09-18 20:38:08 UTC
According to comment 14, this bug should be closed if it contains false formatted content. Can someone verify this?
Comment 17 Julien Nabet 2020-01-12 16:35:16 UTC
No feedback since 2012.
Moreover, I tried with LO 6.3.4 on pc Debian x86-64, it generated an odm file.

dlphan:
1) Could you give a try to a recent LO version?
2) Also so can you give a look at https://bugs.documentfoundation.org/show_bug.cgi?id=35845#c14

Let's put this one to WFM meanwhile.
Of course, don't hesitate to reopen this tracker if needed.