Bug 36377 - Avoid using Ctrl-Alt (AltGr) combinations for keyboard shortcuts
Summary: Avoid using Ctrl-Alt (AltGr) combinations for keyboard shortcuts
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Shortcuts-AltGR
  Show dependency treegraph
 
Reported: 2011-04-18 23:20 UTC by Kim Bastin
Modified: 2017-04-18 15:01 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kim Bastin 2011-04-18 23:20:28 UTC
I suggest that combinations of Ctrl-Alt (= AltGr) with alphanumeric keys should not be used for default keyboard shortcuts on Windows platforms, because many national keyboard layouts use such combinations to return characters or as dead keys.

The use of such combinations is a particular annoyance due to bug 35017, which currently makes it impossible to permanently delete/change keyboard shortcuts.
Comment 1 Björn Michaelsen 2011-12-23 12:05:42 UTC Comment hidden (obsolete)
Comment 2 Florian Reisinger 2012-08-14 13:59:32 UTC Comment hidden (obsolete)
Comment 3 Florian Reisinger 2012-08-14 14:00:43 UTC Comment hidden (obsolete)
Comment 4 Florian Reisinger 2012-08-14 14:05:26 UTC Comment hidden (obsolete)
Comment 5 Florian Reisinger 2012-08-14 14:07:28 UTC Comment hidden (obsolete)