Bug Hunting Session
Bug 36426 - Fonts are not rendered correctly
Summary: Fonts are not rendered correctly
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-20 08:45 UTC by Adam Thompson
Modified: 2015-04-19 14:24 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Writer vs gedit (137.50 KB, image/png)
2012-01-21 07:14 UTC, vastevaste
Details
Writer vs Adobe Reader (export as pdf) (106.56 KB, image/png)
2012-01-21 07:17 UTC, vastevaste
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Thompson 2011-04-20 08:45:01 UTC
Fonts are not rendered correctly. They look very jagged. This is severe enough to make LibreOffice pretty much unusable. All other applications on my system render fonts correctly. I am using Ubuntu 10.04 and have an LCD monitor.
Comment 1 Björn Michaelsen 2011-12-23 12:01:21 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 Adam Thompson 2012-01-04 14:08:16 UTC
This bug still persists in LODev 3.5.0beta2
Comment 3 Adam Thompson 2012-01-04 14:38:54 UTC
Status changed to NEW.

On 12/23/11 12:01, bugzilla-daemon@freedesktop.org wrote:
> https://bugs.freedesktop.org/show_bug.cgi?id=36426
>
> Björn Michaelsen<bjoern.michaelsen@canonical.com>  changed:
>
>             What    |Removed                     |Added
> ----------------------------------------------------------------------------
>               Status|NEW                         |NEEDINFO
>
> --- Comment #1 from Björn Michaelsen<bjoern.michaelsen@canonical.com>  2011-12-23 12:01:21 PST ---
> [This is an automated message.]
> This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
> started right out as NEW without ever being explicitly confirmed. The bug is
> changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
> to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2
> prereleases.
> Details on how to test the 3.5.0 beta1 can be found at:
> http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1
>
> more detail on this bulk operation:
> http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
>
Comment 4 vastevaste 2012-01-21 07:11:33 UTC
I have (possibly) the same problem, linux mint (ubuntu based) x64, both in Libreoffice 3.3.2 and Libreoffice 3.4.3.

It looks like a problem with font spacing. The distant between letters is quite uneven. It kinda looks like mini-spaces are inserted in the middle of words. See attached screenshot comparing with gedit.

It looks okay if export to PDF is used and then viewed in Adobe Reader. See screenshot.

"Use printer metrics for document formatting" does seem to help a bit. Still, it's not quite right even with it enabled.
Comment 5 vastevaste 2012-01-21 07:14:57 UTC
Created attachment 55914 [details]
Writer vs gedit

screenshot comparing font rendering in Writer and gedit with the same font and text
Comment 6 vastevaste 2012-01-21 07:17:14 UTC
Created attachment 55915 [details]
Writer vs Adobe Reader (export as pdf)

Screenshot comparing font rendering in Writer and Adobe Reader after exporting to PDF.
Comment 7 Jon Grossart 2013-07-18 02:35:59 UTC
I can confirm that this happens in Windows as well (has been for some time). It's especially bad with Times New Roman and anything involving "r".

Exporting the same document to PDF has correct spacing for the characters.
Comment 8 ign_christian 2013-07-18 03:21:49 UTC
I haven't did thorough investigation, but seems like specific problem with Ubuntu based system. Perhaps it's been reported on upstream or https://launchpad.net/ubuntu ?
Comment 9 Jon Grossart 2013-07-18 18:18:38 UTC
(In reply to comment #8)
> I haven't did thorough investigation, but seems like specific problem with
> Ubuntu based system. Perhaps it's been reported on upstream or
> https://launchpad.net/ubuntu ?

As I said, I see this on Windows as well.
Comment 10 ign_christian 2013-07-19 02:31:00 UTC
@Jon, I think this bug reported against Linux (Ubuntu based) only.

Should be different problem on Windows, which I didn't see so far. Perhaps you should open new bug report for problem against Windows.

I can confirm that I can see any files by LO much better with Windows & PCLinuxOS, than with Ubuntu.
Comment 11 QA Administrators 2015-04-01 14:40:02 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-01
Comment 12 Buovjaga 2015-04-19 14:24:18 UTC
(In reply to vastevaste from comment #4)
> I have (possibly) the same problem, linux mint (ubuntu based) x64, both in
> Libreoffice 3.3.2 and Libreoffice 3.4.3.
> 
> It looks like a problem with font spacing. The distant between letters is
> quite uneven. It kinda looks like mini-spaces are inserted in the middle of
> words. See attached screenshot comparing with gedit.
> 
> It looks okay if export to PDF is used and then viewed in Adobe Reader. See
> screenshot.
> 
> "Use printer metrics for document formatting" does seem to help a bit.
> Still, it's not quite right even with it enabled.

The original report was never confirmed, I'll close as WFM. Original reporter is free to change back to UNCONFIRMED, if they still experience the problem.

The problem in comment 4 is dealt with in bug 88991.