Bug 37141 - BUGTRACKER: Please enable "Voting" in the LibreOffice Bugtracker
Summary: BUGTRACKER: Please enable "Voting" in the LibreOffice Bugtracker
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: WWW (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: VOTE
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-12 07:24 UTC by gleppert
Modified: 2015-03-22 19:15 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gleppert 2011-05-12 07:24:40 UTC
Voting for bugs and enhancements can be a great feature to prioritize related bugs/enhancements according to the users' votes. 

There has been an action to simulate the missing voting-feature in the Documentfoundation wiki: http://wiki.documentfoundation.org/Vote_for_Enhancement I think that this approach is misleading and causes double work. It would be really better to have a real voting feature in the Bugtracker.

According to the bugzilla administrator's manual, this feature just needs to be enabled: https://bugs.freedesktop.org/docs/html/voting.html

I propose to allow users to give 50 votes in total and at maximum 2 votes for each bug/enhancement.

This feature exists in the OOo bugtracker and was used by many members. Although the OOo team has not really been focusing on high voted bugs, they use the votes as orientiation of users' needs.
Comment 1 Don't use this account, use tml@iki.fi 2011-05-12 07:37:41 UTC
Please don't.
Comment 2 gleppert 2011-05-12 07:47:20 UTC
@Tor: "Don't" for what reason? Do you mean that it would put pressure on (employed and) voluntary developers and that such pressure would be counter-productive?

A "positive" alternative could be a "pledge for it" feature like Codeweavers does with their products. There, the users "offer" money and in case they improve support of particular application in Crossover Linux (= which means in LO closing particular bug or developing a particular enhancement), users have to pay the stated amount.
For example, I would definitively "pay" for an improved "track changes" feature.
Comment 3 Don't use this account, use tml@iki.fi 2011-05-12 08:04:06 UTC
Because voting just means that the most vocal and obnoxious users get their voice heard the most. The number of votes a bug gets has little correlation to its actual seriousness. At least for me personally, if I start seeing people whining "this bug has already 10 votes, fix it ASAP!", and the bug has doesn't cause data loss, and has a workaround, it will just make me less likely to work on that bug. I will prefer to work on some real crash-inducing bug even if it has zero votes. Still, ultimately it is my boss who tells me what to do and what not do do of course. And, obviously, bugs reported by our paying customers (which are not even necessarily reported in this bugzilla) will always have precedence. I am sure the same holds for other paid developers.
Comment 4 Rainer Bielefeld Retired 2011-05-12 09:38:47 UTC
Especially for enhancements I agree with the idea that something like voting can be useful. But in all the years I have been watching this I had to learn that impact of voting results is quite nearby 0, and there are good reasons not to follow simple number of votes. In Wikipedia we followed the ideal that the best arguments should determine the course, not the number of supporters. For that Idea we need a mass support solution. 

So I do not disagree with the idea to activate the voting, but I doubt that it will be very useful.

A very rudimental attempt of an interim solution of an argument collection is the Wiki poll page.

May be you want to vote for this enhancement request on the new nonofficial Voting Page?
<http://wiki.documentfoundation.org/Vote_for_Enhancement>
Comment 5 Andy Brown 2011-06-11 16:44:36 UTC
Why bother.  Voting on improvement or bug (bad ones even) at OOo never did any good.
Comment 6 Björn Michaelsen 2011-12-23 12:01:05 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 7 Pander 2011-12-30 05:26:32 UTC
My two cents:

Which bug or issue is interesting for a user or developer depends really on the person and how he or she uses the software. A very important behind-the-scene bug can be fixed but can be completely invisible for end users while on the other hand a trivial aesthetic change can put a smile on many faces.

Satisfying the users in general is important, also to continue to get support, sponsoring and good reviews, paving the way for future development.

Advantages of voting:
- users and developers can express their desire to have an issue solved with having to comment "+1"
- by doing this, users and developers feel they are being heard which increases user satisfaction regarding a project
- this in turn prevents users getting obnoxious

Disadvantages of voting:
- might not speed up solving an issue
- when a 10 year old bug has hundreds of voters, perhaps someone should do something about it (perhaps an advantage ;) ) 

Voting is enabled for Bugzilla at Mozilla and it is helping a bit. It also provides users an alternative overview to the different searches to see about which bugs they care.

I'm also in favor of funding bugs by pledging bounties. In order to be able to offer this in bugs.freedesktop.org, please *vote* here:
  https://bugzilla.mozilla.org/show_bug.cgi?id=124096

Also I wouuld like to propose this bug is moved to
  Product: freedekstop.org
  Component: Bugzilla
because voting is offered for all projects here.
Comment 8 Markus Grob 2012-11-12 11:40:53 UTC
+1

I was voting in the KDE Bugzilla also and was searching here for the same. I think, if you have thousands of new errors, but on a few bugs, you have a lot of votes, you try to fix it earlier then another bug, which nobody except the submitter has voted.

Greetings from Switzerland, Markus
Comment 9 retired 2013-04-03 11:46:24 UTC
Since I can't vote: +1 ;)

Both sides here have valid arguments. I understand the thinking behind what Tor says. But since voting doesn't hurt anybody I tend to think it might be a good way to make peoples voice heard and prevent duplicates and increase the motivation to avoid duplicates when reporting. The process then should be explicitly stated in the Bug Submission Assistant.

The Wiki is much too complicated for users to really participate. They'd have to sign up, learn how to edit a wiki and spend at least 10-15 minutes doing so. Hitting a vote button if you already have a bugzilla-account takes 3 seconds.
Comment 10 crxssi 2014-03-01 04:34:28 UTC
+1 from me too.

Voting is a useful tool.  For one, it can prevent "me too" postings that don't add much to the thread, because people feel like they can express how they feel. It also empowers people to participate, especially those less-technical that don't feel like they could add much even if they wanted to. It can also show developers which bugs have the most visibility.

Voting is far perfect, but it is SOMETHING.  I have seen it work fine on mozilla's bugzilla and others.  I don't really see any negatives with enabling it.  Voting doesn't prevent ALSO having pledges, lists of most annoying, or any other system.

It could even be integrated into another system- such as allow users to "buy" votes for a donation...
Comment 11 Adolfo Jayme 2015-03-22 19:15:35 UTC
We won’t do this. There are no real benefits for us, because we aren’t looking for people to whine about how much they desire anything to be done, and we are volunteers who work on what we want to or we are paid to work on what we are assigned to. That’s how it is since the beginning of this project ;-)

On a related note, I believe putting money where your mouth is is a much more effective way to get anything done faster. For that purpose, please use the FreedomSponsors platform :-)