Bug 37540 - Highlighted Text becomes colored Background when saved as word 97-2003 doc Format
Summary: Highlighted Text becomes colored Background when saved as word 97-2003 doc Fo...
Status: RESOLVED DUPLICATE of bug 64490
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: All All
: high major
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: NoRepro:4.2.0.3:OSX
Keywords:
: 51122 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-05-24 05:42 UTC by hirt
Modified: 2014-06-03 17:22 UTC (History)
14 users (show)

See Also:
Crash report or crash signature:


Attachments
Example text with bug (3.71 KB, application/zip)
2011-12-15 23:36 UTC, Robotic Boyer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description hirt 2011-05-24 05:42:56 UTC
FILESAVE as word 97-2003 doc Format saves highlighted text not correct. 

When opening the file with word2000, 2003 or 2010 the text is not highlighted but has a colored background. 

This behaviour is independent of the source of the highlightening (imported from Word or highlighted in Libreoffice or Openoffice).

However, when opened in Libreoffice/Openoffice the text is recognized correct as highlighted text and not as background.

This behaviour is included in LibO 3.4 RC1
Comment 1 hirt 2011-06-13 03:25:28 UTC
LibO 3.3RC1 does not fix this issue
Comment 2 hirt 2011-06-30 23:34:24 UTC
Version 3.3.3 and 3.4.1RC3 still show this bug. 
This Bug is on x86 and x86-64 on both Linux and Windows
Comment 3 Eliot the Cougar 2011-09-05 03:15:06 UTC
My colleague just noticed this issue like this:
"I never can remove color highlights in your *** documents made in your *** LibreOffice... Throw it in ***"... And so on...

The bug happens not only when you export as DOC, but also when you export as DOCX and then edit it in Office 2007 or 2010...

Additional info:
There are two buttons on the toolbar in Word 2010 – one changes highlight color and the other changes text background color (Word2003 has only one of those)

1. Make a document in LibreOffice that consists of 3+ paraghraph
2. Highlight ENTIRE central paragraph yellow
3. Save as DOC or DOCX
4. Open in Office 2007-2010
5. Enable display hidden characters (!)
6. Try to remove highlighting (background color)
a) Select the entire paragraph with the paragraph sign in the end. Change text background option using the control on the panel. Doesn't work.
b) Select the entire paragraph with the paragraph sign in the end. ... Does work.

Anyway, most people, when they see highlighted text in MS Word, assume it is "highlighted text", not "text background"... The second option is hidden deep in MS Word 2007-2010 and nonexistent in MS Word prior 2003...
Comment 4 Romano Giannetti 2011-09-17 07:49:22 UTC
I have dug a bit more into the problem, and the matter is that it seems that OO (or LO) do not have the duality background-highlighting that MS Word has , so I suppose the problem is not so easily solved. 

I did found a rtf + grep hack to solve the problem, but it's still a bad hack. 

More details are in:

https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/645269


So yes, please solve this. It is a major interoperability problem.
Comment 5 Romano Giannetti 2011-09-17 08:15:27 UTC
To simplify things, I copy here my findings too: 

I saved (from MS Word) the file in RTF format. The sequence, highlighted by MS, which works (you can remove the highlight) is like that:

{\rtlch\fcs1 \af37 \ltrch\fcs0 \lang1033\langfe1025\highlight7\langnp1033\insrsid5522236\charrsid3873419 \hich\af37\dbch\af37\loch\f37
This text has been highlighted with Microsoft Word 2007}

The sequence that you cannot modify is this one:

{\rtlch\fcs1 \af37 \ltrch\fcs0
\lang1033\langfe1025\chshdng0\chcfpat0\chcbpat7\langnp1033\insrsid5522236 \hich\af37\dbch\af37\loch\f37 This text has been modified and highlighted with O\hich\af37\dbch\af37\loch\f37 penoffice (version 1:3.2.0-7ubuntu4.1, Ubuntu Linux 10.04 up-to-date).
}

Note that if I change "\chshdng0\chcfpat0\chcbpat7" to "\highlight7" in the rtf file, then MS Word can edit it correctly.

The command: 

sed 's/\\chcbpat/\\highlight/g' < in.rtf > out.rtf 

makes a editable file. Saved my day.
Comment 6 Robotic Boyer 2011-12-15 23:36:25 UTC
Created attachment 54486 [details]
Example text with bug

In the zip file there are:
Sottolineatura_WO.doc => Original file made with MS Word
Sottolineatura_LO.doc => the same after saved with LO Writer

The bug is:
Ms_Word doesn't use "shading" text property for underline text, while LO_Writer uses it.
Comment 7 Christopher M. Penalver 2011-12-16 02:55:06 UTC
Robotic Boyer, please do not toggle the Version. For more on this please see http://wiki.documentfoundation.org/BugReport_Details#Version
Comment 8 Björn Michaelsen 2011-12-23 12:03:20 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 9 Romano Giannetti 2011-12-24 02:36:34 UTC
Given that this is a "design" problem, and it is not listed in the new features of release 3.5, I doubt it could be magically been fixed. But anyway, I'd love to test it --- can anyone point me to instruction on how to test "beta" version alongside with the "normal" one? I am on Ubuntu-current.
Comment 10 Christopher M. Penalver 2012-01-03 17:20:34 UTC
Reproducible in:
LOdev 3.5.0beta2 
Build ID: 8589e48-760cc4d-f39cf3d-1b2857e-60db978
Microsoft Windows Vista Business 6.0.6002 Service Pack 2 Build 6002
Comment 11 Francisco Pina Martins 2012-10-30 14:36:22 UTC
*** Bug 51122 has been marked as a duplicate of this bug. ***
Comment 12 Francisco Pina Martins 2012-10-30 14:38:57 UTC
Confirming that it is still present in LO 3.6.2.
I have also found a duplicate on bugzilla and changed the status accordingly.
Comment 13 Norbert X 2013-05-11 12:40:33 UTC
Bug exists in Ubuntu 12.04.2 LTS with LibreOffice 3.5.7.2 Build ID: 350m1(Build:2).
Comment 14 Romano Giannetti 2013-05-11 15:00:53 UTC
Still here in 4.0.2. Now is even more confusing; we have both "highlighting" and "background color" on the toolbar, but highlighting is still incompatible with Microsoft Office.
Still a big problem in interoperability.
Comment 15 Norbert X 2013-05-11 15:15:13 UTC
I tested many versions of LibreOffice and AOO on different OSes:
* Debian 6 with "OpenOffice.org 3.2.1 OOO320m19 (Build:9505) ooo-build 3.2.1.4, Debian package 1:3.2.1-11+squeeze8";
* Windows 7 Starter SP1 with "OpenOffice.org 3.4.1
AOO341m1 (Build:9593) - Rev. 1372282";
* Debian 7 with LibreOffice 3.5.4.2 Build ID: 350m1(Build:2);
* Ubuntu 12.04.2 LTS with LibreOffice 3.5.7.2 Build ID: 350m1(Build:2)
* Ubuntu 12.10 with Version 3.6.2.2 (Build ID: 360m1(Build:2));
* openSUSE 12.3 "Dartmouth" with Version 3.6:build-304 (Build ID: 360m1(Build:304));
* Fedora 18 with Version 3.6.6.2 (Build ID: 3.6.6.2-5.fc18);
* Fedora 19 with Version 4.0.3.1 (Build ID: 4.0.3.1-2.fc19) and Version 4.0.3.3 (Build ID: 4.0.3.3-1.fc19);
* Ubuntu 13.04 with Version 4.0.2.2 (Build ID: 400m0(Build:2));
* Windows 7 Starter SP1 with LibreOffice 4.0.2.2 (ID сборки 4c82...49c3) and Версия 4.0.3.3 (ID сборки: 0eaa50a932c8f2199a615e1eb30f7ac74279539).

My conclusion - both AOO and LO have not fixed this bug for 9 (nine !!) years.

Please fix it.
It's very annoying, and it may scare away users, which are going to switch from Microsoft Office to Apache OpenOffice. 
And as Romano Giannetti said it's "Still a big problem in interoperability".
Comment 16 Norbert X 2013-05-11 20:18:14 UTC
DOCX files are affected too.
I have reported bugs to Redhat (Fedora 18) and Novell (OpenSuse 12.3).
Comment 17 Christopher M. Penalver 2013-05-12 13:14:04 UTC
nrbrtx, please do not adjust the Summary, as this is causing bug scope creep. If you have a bug in LibreOffice, please feel free to open a new report following https://wiki.documentfoundation.org/BugReport .

Thank you for your understanding.
Comment 18 Norbert X 2013-07-24 10:43:25 UTC
Bug still exists in LOO 4.1.0.2 (Version: 4.1.0.1.0+ 
Build ID: Gentoo official package). 
Please fix it, it's a great interoperability problem, I think.

DOC and DOCX files with correct highlighting, created in MS Word are located in Novell bugzilla  (https://bugzilla.novell.com/show_bug.cgi?id=819512 - in Comments 3,4 and 5).
Comment 19 Norbert X 2013-10-07 10:07:57 UTC
Hello!

Bug is still exist in the latest Windows build of LibreOffice
(
LibreOffice 4.1.2.3
Версия: 4.1.2.3
ID сборки: 40b2d7fde7e8d2d7bc5a449dc65df4d08a7dd38
).

Please fix it as soon as possible.

Highlighting marker is used very often.
It breaks normal document exchange between Microsoft Office Word users and LO/OO users.
Comment 20 Norbert X 2013-10-07 10:10:39 UTC
I mean: "Highlighting marker is used very often.

But this bug breaks normal document exchange between Microsoft Office Word users and LO/OO users."
Comment 21 retired 2014-01-27 10:34:04 UTC
NoRepro:4.2.0.3:OSX

open Sottolineatura_LO.doc

save as doc
save as docx

Open doc with MS Word 2011 > text with color-background is recognized as marked text
Open docx with MS Word 2011 > text with color-background is recognized as marked text

WORKSFORME.

Please re-open if I'm missing something obvious :)
Comment 22 Romano Giannetti 2014-01-30 15:09:28 UTC
@Foss: 

Have you tried to remove the highlighting in MS word? I tried in 4.1.3 and the problem is still there. 

The problem is NOT that the highlight is not visible. The problem is that the highlight is not REMOVABLE from the document when opened in MSword. 

I have no 4.2 to test; can you attach the file you prepared with 4.2 so that I can try to open it with microsoft word an check if the problem is really gone?
Comment 23 Romano Giannetti 2014-01-30 15:11:08 UTC
Re-opening because I think that it is missing a fundamental test.

Will re-close if I can test a 4.2 document which works correctly in MS word. 

Thanks
Comment 24 Romano Giannetti 2014-01-30 15:19:15 UTC
See https://bugs.freedesktop.org/show_bug.cgi?id=64490#c17
Comment 25 Norbert X 2014-01-30 15:47:44 UTC
Marked as duplicate of https://bugs.freedesktop.org/show_bug.cgi?id=64490 because of better explanation of a problem (see attachments of bug 64490 - they are useful for performing tests against this bug).

*** This bug has been marked as a duplicate of bug 64490 ***
Comment 26 Romano Giannetti 2014-01-31 20:47:01 UTC
Still here in 4.2.0.4, tested on Windows.
Comment 27 Christopher M. Penalver 2014-02-02 23:30:40 UTC
Romano Giannetti, please do not adjust the Version. This is not the latest version the problem is reproducible in, but the earliest. For more on this, please see https://wiki.documentfoundation.org/QA/BugReport .