Download it now!
Bug 37556 - Filesave as RTF doubles all hyperlinks
Summary: Filesave as RTF doubles all hyperlinks
Status: CLOSED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: x86 (IA32) Linux (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTF Hyperlink
  Show dependency treegraph
 
Reported: 2011-05-24 14:56 UTC by Bryce
Modified: 2017-05-14 04:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Mangled file (2.79 KB, application/rtf)
2011-05-24 14:56 UTC, Bryce
Details
Same file, saved as DOCX (3.52 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2011-06-04 15:18 UTC, Bryce
Details
Same file, saved as ODT (9.23 KB, application/vnd.oasis.opendocument.text)
2011-06-04 15:18 UTC, Bryce
Details
Same file, saved as RTF. Note Hyperlink is doubleddoubled. (1.86 KB, application/rtf)
2011-06-04 15:18 UTC, Bryce
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bryce 2011-05-24 14:56:33 UTC
Created attachment 47112 [details]
Mangled file

Step 1: Create a document and add a hyperlink.
Step 2: Save as "RTF" format.
Step 3: Close the file, load it again.
Step 4: Save as "RTF" under a new name

The files created in step 2 and 4 will double and quadruple the hyperlinked text.  The actual defect is in the on disk file:

This is a }{{\field{\*\fldinst HYPERLINK "http://www.example.com/" }\cf2\ul\ulc0\langfe255{\fldrslt \cf2\ul\ulc0\langfe255\lang255\rtlch \ltrch\loch\lang255
TEST}
{{\field{\*\fldinst HYPERLINK "http://www.example.com/" }\cf2\ul\ulc0\langfe255{\fldrslt \cf2\ul\ulc0\langfe255\lang255\rtlch \ltrch\loch\lang255
}}TEST}


------------------------------------------------
LibreOffice 3.3.2 
OOO330m19 (Build:202)
tag libreoffice-3.3.2.2, Ubuntu package 1:3.3.2-1ubuntu5
Comment 1 Yifan Jiang 2011-05-25 22:06:03 UTC
I can confirm this is reproduced in 3.3.1, but cannot reproduced in 3.4 rc1. Both of my systems are SLED 11 sp1 i586.

Hi Cedric,

Did we merged some patches possibly have this already fixed? Thanks for reviewing!
Comment 2 tester8 2011-06-04 14:26:34 UTC
Not reproduced with
Ubuntu 10.04.2 x86
LO 3.4
Comment 3 Bryce 2011-06-04 15:18:01 UTC
Created attachment 47537 [details]
Same file, saved as DOCX
Comment 4 Bryce 2011-06-04 15:18:21 UTC
Created attachment 47538 [details]
Same file, saved as ODT
Comment 5 Bryce 2011-06-04 15:18:47 UTC
Created attachment 47539 [details]
Same file, saved as RTF.  Note Hyperlink is doubleddoubled.
Comment 6 Bryce 2011-06-04 15:21:48 UTC
Verified again today from scratch:
----------------------
LibreOffice 3.3.2 
OOO330m19 (Build:202)
tag libreoffice-3.3.2.2, Ubuntu package 1:3.3.2-1ubuntu5

Linux ubuntu 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.04
DISTRIB_CODENAME=natty
DISTRIB_DESCRIPTION="Ubuntu 11.04"
Comment 7 Christopher M. Penalver 2011-08-30 10:54:37 UTC
Unreproducible in LibreOffice Writer 3.4.2.

lsb_release -rd
Description:    Ubuntu oneiric (development branch)
Release:    11.10

apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.4.2-2ubuntu2
  Candidate: 1:3.4.2-2ubuntu2
  Version table:
 *** 1:3.4.2-2ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ oneiric/main i386 Packages
        100 /var/lib/dpkg/status
Comment 8 Björn Michaelsen 2011-12-24 04:45:26 UTC
closing