Bug 37584 - track changes: deleted text lost
Summary: track changes: deleted text lost
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: x86 (IA32) All
: high critical
Assignee: Cédric Bosdonnat
QA Contact:
URL:
Whiteboard:
Keywords: regression
: 38216 38222 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-05-25 07:15 UTC by Cor Nouws
Modified: 2011-10-29 07:38 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2011-05-25 07:15:53 UTC
- start writer document
- type some text
- turn trach changes on (Edit > Changes > Record)
- select some text and type somthg different
  > deleted text is invisible, only line is shown

Regression from 3.3.2
Comment 1 vitriol 2011-05-25 07:24:43 UTC
Confirmed. After that, if you reject changes all text will lost. Very bad regression...
Comment 2 Cor Nouws 2011-05-25 07:55:19 UTC
- The same bug is present in 340beta4 already (previous betas I cannot test).
through)  a very sort moment. Then it is replaced by spaces, it seems.
- After selecting and starting to type other text, the text is vissible (striked
Comment 3 Cor Nouws 2011-05-25 07:56:33 UTC
Sorry, previous comment should read: 

- After selecting and starting to type other text, the text is vissible
(striked through)  a very sort moment. Then it is replaced by spaces, it seems.

- The same bug is present in 340beta4 already (previous betas I cannot test).
Comment 4 Petr Mladek 2011-05-26 01:08:29 UTC
Cedric, could you please have a look? I think that we should fix it for 3.4.1.
Comment 5 karlsen-masur 2011-05-30 02:04:36 UTC
(In reply to comment #4)
> Cedric, could you please have a look? I think that we should fix it for 3.4.1.

I hope you meant 3.4.0?!?
Comment 6 Mihkel Tõnnov 2011-05-31 08:57:27 UTC
Still present on 3.4.0 RC2. A showstopper in my view :(
Comment 7 Petr Mladek 2011-06-02 10:30:07 UTC
Change tracking is not enabled by default. It loses only text that user wanted to remove => it is quite bad but we should not blocker the 3.4.0 release => lovering the severity a bit

We will mention it in the release notes, see
http://wiki.documentfoundation.org/ReleaseNotes/3.4#Most_annoying_bugs_in_3.4.0

Cedric, Lubos, please make sure that this is fixed in 3.4.1.
Comment 8 karlsen-masur 2011-06-03 00:37:19 UTC
(In reply to comment #7)
> Change tracking is not enabled by default. It loses only text that user wanted
> to remove => it is quite bad but we should not blocker the 3.4.0 release =>
> lovering the severity a bit
> 
> We will mention it in the release notes, see
> http://wiki.documentfoundation.org/ReleaseNotes/3.4#Most_annoying_bugs_in_3.4.0
> 
> Cedric, Lubos, please make sure that this is fixed in 3.4.1.

I strongly disagree with your impression, that a user wants to delete a piece of text if he/she is deleting text with "Track changes" enabled. He/She wants to highlight the difference between to versions of a document.

I use this feature for creating draft document revisions - for review cycles with peers - a lot in my daily work, it is very important to my work with LO.

Using tracked changes highlights the change (from->to) and makes it possible to revert it once in review cycle it was decided to undo the the change. This is used in revision management of documents.

I guess that this feature is really used a lot by other business users of LO.

And this bug is currently the reason I can't use LO 3.4.0 RC2 for any real work to test it further.

After all this a regression; shouldn't those be fixed for a new stable release?
Comment 9 Cédric Bosdonnat 2011-06-07 13:47:48 UTC
After long hours debugging and trying to find whom was inserting those blank spaces, I finally found the culprit. I'm keeping a stacktrace of it here just as a post-it.

#0  0x00007ffff7b8da59 in osl_decrementInterlockedCount ()
   from /home/cbosdo/libreoffice/3.4/bootstrap/install/program/../basis-link/ure-link/lib/libuno_sal.so.3
#1  0x00007ffff7ba45fb in rtl_uString_release ()
   from /home/cbosdo/libreoffice/3.4/bootstrap/install/program/../basis-link/ure-link/lib/libuno_sal.so.3
#2  0x00007ffff3f33710 in _ImplCopyData (pData=0x1fda9e0) at /home/cbosdo/libreoffice/3.4/bootstrap/tools/source/string/strimp.cxx:207
#3  0x00007ffff3f37fb7 in String::ImplCopyData (this=0x7fffd77201c0)
    at /home/cbosdo/libreoffice/3.4/bootstrap/tools/source/string/strimp.cxx:219
#4  0x00007ffff3f33f5e in String::SetChar (this=0x7fffd77201c0, nIndex=8, c=32)
    at /home/cbosdo/libreoffice/3.4/bootstrap/tools/source/string/strimp.cxx:654
#5  0x00007fffda8dfe12 in lcl_MaskRedlines (rNode=..., rText=..., nStt=0, nEnd=17, cChar=32)
    at /home/cbosdo/libreoffice/3.4/bootstrap/sw/source/core/txtnode/txtedt.cxx:144
#6  0x00007fffda8dff25 in lcl_MaskRedlinesAndHiddenText (rNode=..., rText=..., nStt=0, nEnd=17, cChar=32, bCheckShowHiddenChar=false)
    at /home/cbosdo/libreoffice/3.4/bootstrap/sw/source/core/txtnode/txtedt.cxx:174
#7  0x00007fffda8e8094 in SwTxtNode::CountWords (this=0x7fffd77200f8, rStat=..., nStt=0, nEnd=17)
    at /home/cbosdo/libreoffice/3.4/bootstrap/sw/source/core/txtnode/txtedt.cxx:1821

The changes in the word counts are the faulty ones! Will fix that tomorrow.
Comment 10 Caolán McNamara 2011-06-08 05:53:55 UTC
fix checked in to 3-4 now
Comment 11 Mihkel Tõnnov 2011-06-08 06:18:41 UTC
(In reply to comment #10)
> fix checked in to 3-4 now

Will it make it into 3.4.1?
Comment 12 Jan Holesovsky 2011-06-08 17:13:01 UTC
Mihkel: Yes.
Comment 13 LeMoyne Castle 2011-06-09 00:26:36 UTC
Rremoved and replaced regression keyword.  
Test with Edit->Changes->Record checked has shown both deleted text erased (notOK) and deleted text redlined (OK) both tests run from Applications->Office->Writer 3.3 on Ubuntu 10.04 where About dialog shows LibreOffice 3.3.2 / OOO330m19 (Build:202) / tag libreoffice-3.3.2.2
Difference may come from the notOK test being run with terminal/shell still open where dev-install of 3.4 had been run.  
Result unclear but believe was tested in 3.3 and 3.3 now shows OK result for me so replaced regression keyword.  
Puzzle: LibO 3.3 shows the visible word count changes made early 11/2010 but not the redlining error.
Comment 14 Rainer Bielefeld Retired 2011-06-10 02:58:20 UTC
RC2 is bit by bit identical with release version, so separate items in the version picker are useless. Changes have been discussed with Michael Meeks.
Comment 15 Sadi 2011-06-12 11:01:33 UTC
First, apologies from an inexperienced user of this Bug Reporting System here. As a long-time user of OpenOffice and lately LibreOffice, I'm surprised about such an important bug, and have just seen that it's already reported with Status RESOLVED and FIXED. But I wonder how? Is there a workaround or do users need to wait for 3.4.1 or downgrade to 3.2.2 to avoid this terrible bug.
I'll appreciate clarification on this, and thanks in advance...
Comment 16 vitriol 2011-06-12 15:26:20 UTC
*** Bug 38216 has been marked as a duplicate of this bug. ***
Comment 17 vitriol 2011-06-12 15:34:06 UTC
*** Bug 38222 has been marked as a duplicate of this bug. ***
Comment 18 Cor Nouws 2011-06-13 01:31:13 UTC
Hi Sadi
(In reply to comment #15)
> As a long-time user of OpenOffice and lately LibreOffice, I'm surprised about
> such an important bug, and have just seen that it's already reported with
> Status RESOLVED and FIXED. But I wonder how? 

This bug is fixed for 3.4.1
Explanation about the release model, 
http://blog.documentfoundation.org/2011/05/13/announcing-a-new-beta-release/
and here
http://wiki.documentfoundation.org/File:Adapt-o-meter.png
and about the release:
http://www.libreoffice.org/download/release-notes/#LO340
HTH - Cor