Download it now!
Bug 37666 - Mounting Volume in Extension-Managers Add...-Dialog hangs LO
Summary: Mounting Volume in Extension-Managers Add...-Dialog hangs LO
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: x86 (IA32) Mac OS X (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-27 08:43 UTC by Uwe Altmann
Modified: 2013-05-16 07:50 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Uwe Altmann 2011-05-27 08:43:09 UTC
Extension manager > Add....
Select unmounted Volume, doubleclick.
LO hangs with spinning beachball.

Same procedure done for normal File > Open...  works well. 
If the volume previously was mounted (i. e. by file > open... dialog) everything works as expected then also in extension manager.

Tested with AFP- and Samba-Volume.
Comment 1 Rainer Bielefeld Retired 2011-06-10 02:58:41 UTC
RC2 is bit by bit identical with release version, so separate items in the version picker are useless. Changes have been discussed with Michael Meeks.
Comment 2 Björn Michaelsen 2011-12-23 12:04:45 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 Uwe Altmann 2011-12-27 04:52:43 UTC
Still the same with LO 3.5 Beta 2
Comment 4 Uwe Altmann 2011-12-27 04:58:23 UTC
Still the same with LO 3.5 Beta 2
Comment 5 Roman Eisele 2012-09-20 10:43:47 UTC
Bug was never confirmed by an independent reviewer, therefore reset Status to
UNCONFIRMED.

(No offence -- this does not mean that I doubt the existence of this bug --
when status is UNCONFIRMED, the chance is even better that a bugwrangler will
try to reproduce this issue or search for duplicates, while with Status NEW the
bug will probably just be overlooked.)
Comment 6 Joel Madero 2013-05-15 02:22:50 UTC
So, as far as I can tell this works with 4.0 series.

@Uwe - have you tested this with version 4? I'm going to mark this as WFM but if you still see this with latest stable release feel free to mark the bug as UNCONFIRMED again (you may have to set as NEEDINFO first then as UNCONFIRMED, apologies for this). 

Hopefully it's resolved for you as well, so sorry it took so long to get to the bug.
Comment 7 Joel Madero 2013-05-15 02:23:26 UTC
Ah, I just saw that this was OSX (sorry I tried Linux), going to add Joren to confirm, for now leaving as WFM.

@Joren - can you test this one out?
Comment 8 Jorendc 2013-05-15 12:47:29 UTC
(In reply to comment #7)
> Ah, I just saw that this was OSX (sorry I tried Linux), going to add Joren
> to confirm, for now leaving as WFM.
> 
> @Joren - can you test this one out?

I don't have any Samba-setup/volume so I can't test this one out. It looks to me placing this bug back to UNCONFIRMED is the best option? Isn't it?

Kind regards,
Joren
Comment 9 Alex Thurgood 2013-05-15 14:10:21 UTC
Hi Uwe,

I do not see a way to reproduce this on my system (OSX 10.8.3).

My OSX client connects to an OSX server that has both SMB and AFS shares. However, if I disconnect the ethernet cable from my client, the OS unmounts the shares automatically, and when I reconnect the cable, the server appears and I can select the mount points in the Finder dialog that appears when you want to load an extension.

If I unmount a share that appears on my desktop, it is gone, and no longer appears in the Finder.

Which version of OSX are you using for your client ?
How are your AFS shares setup ? I seem to recall something like this on OSX 10.4, whereby an alias was created for the share instead of a direct disk mount - is this what your setup is like ?


Alex
Comment 10 Alex Thurgood 2013-05-15 14:21:43 UTC
I don't get a crash with a 10.8.3 client and LO 4.1alpha from my own master build.

What I do get is a beachball while OSX attempts to mount the share via the alias, and then gives up after a timeout, displaying a message saying that there was a network error. This process repeats endlessly, until the ethernet cable is reconnected, at which point the system mounts the share automatically.

Even if I unmount the share with the eject context menu, as soon as I navigate to the alias, the share is automatically mounted by the system.


So from my point of view, I can not reproduce.


Alex
Comment 11 Uwe Altmann 2013-05-15 14:31:50 UTC
Hi Alex

I'm using 10.6.8
The unmounted, but by bonjour announced volumes appear in Finders Sidebar under shares ("Freigaben"). Mounted shares have a vertical arrow to unmount them.
You may activate this in Finder > Setup ("Einstellungen > Seitenleiste").

The bug occurs also with mounted shares in 4.0.3. You can select one, the content is displayed but the beachball will not go away.
Comment 12 Alex Thurgood 2013-05-15 14:57:32 UTC
(In reply to comment #11)

Hi Uwe,

> 
> I'm using 10.6.8
> The unmounted, but by bonjour announced volumes appear in Finders Sidebar
> under shares ("Freigaben"). Mounted shares have a vertical arrow to unmount
> them.

Yes, I can see them in the left pane under shared devices, including the unmount arrow.



> The bug occurs also with mounted shares in 4.0.3. You can select one, the
> content is displayed but the beachball will not go away.

Can't reproduce either with LO 4.0.3. I have a feeling that this might be OS version specific behaviour of the Finder code :-/ On OSX 10.8.3 (well, on my system at least), any single click on an unmounted share in the Finder left pane automagically mounts the share, optionally requesting for user id/pwd combo).

Alex
Comment 13 Uwe Altmann 2013-05-16 07:50:11 UTC
(In reply to comment #12)
> (In reply to comment #11)

> Can't reproduce either with LO 4.0.3. I have a feeling that this might be OS
> version specific behaviour of the Finder code :-/ On OSX 10.8.3 (well, on my
> system at least), any single click on an unmounted share in the Finder left
> pane automagically mounts the share, optionally requesting for user id/pwd
> combo).

This is the expected behavior - so indeed this might be OSX version specific. So I changed it to WONTFIX - no need to handle this because easy workaround exists (just copy the extension to a local volume before installing) :-)