Bug 37806 - Support WordPro document tabs and window viewing
Summary: Support WordPro document tabs and window viewing
Status: RESOLVED DUPLICATE of bug 37134
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-31 23:52 UTC by roland
Modified: 2019-03-12 16:48 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description roland 2011-05-31 23:52:42 UTC
Under Lotus WordPro, each document had tabbed document sections with the tabs running down the right side of a document.  Tabs could be drug or otherwise re-arranged.  Individual tabs could be marked in such a way that they did not print when you printed the entire document.  This was, and still is, the most amazing way of laying out a book, manual, or business document.  You could have one or more "notes" tabs which were blocked from printing and a different tab for each chapter/topic.  If you decided to change topic order, you simply changed the tab order.  No icky-nasty cut&paste errors to deal with.  No breaking of styles, etc.

WordPro also had an MDI interface, which LibreOffice desperately needs to get back to.  On the main menu at the top was a "Window" item.  All documents were open within the single instance of WordPro.  You switch documents by pressing ALT-W then, after the window menu appeared, a digit 1-9.  If more than 9 documents were open at one time (not that likely given the memory of the day) the last entry was "m" for more documents.  Pressing "m" would cause a window with all document names to appear.  You scrolled through the list and hit enter on the one you wanted.  This worked in both Windows and OS/2.

Install a copy of Smartsuite 98 under Wine and see how things worked.  It was way ahead of its time.
Comment 1 Björn Michaelsen 2011-12-23 12:02:54 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 roland 2011-12-23 12:57:58 UTC
This bug still persists with all versions on all platforms
Comment 3 Jorendc 2013-02-18 09:08:42 UTC
Marking this as enhancement request.
Comment 4 Owen Genat (retired) 2014-07-26 10:37:07 UTC

*** This bug has been marked as a duplicate of bug 33173 ***
Comment 5 V Stuart Foote 2019-03-12 16:48:16 UTC
QA housekeeping adjusting the duplicate to bug 37134, from bug 33173

*** This bug has been marked as a duplicate of bug 37134 ***