Bug 37864 - EDITING Calc Input bar error looses last character of pasted content
Summary: EDITING Calc Input bar error looses last character of pasted content
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: All All
: lowest minor
Assignee: Not Assigned
URL: https://bugs.launchpad.net/ubuntu/+so...
Whiteboard: target:7.4.0
Keywords:
: 93653 (view as bug list)
Depends on:
Blocks: Paste Calc-Formula-Bar
  Show dependency treegraph
 
Reported: 2011-06-02 13:40 UTC by Christopher M. Penalver
Modified: 2022-04-28 10:57 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher M. Penalver 2011-06-02 13:40:47 UTC
Downstream bug may be found at:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/347453

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

3) What is expected to happen is if one copies a cell containing "test", and paste it into the 'input line' bar, just test is pasted.

4) What happens instead is that a space is appended to the end of test. If one backspaces or deletes the space, the last character is deleted.
Comment 1 Andras Timar 2011-06-06 04:31:01 UTC
It is the same on Windows. Reproduced also in 3.4.0.
Comment 2 Andras Timar 2011-06-06 04:39:04 UTC
Kohei, can you please check this?
Comment 3 wope 2011-06-18 14:39:24 UTC
in LibO 3.3.3 and 3.4.1 it seems to be ok. Please test it.
Comment 4 Christopher M. Penalver 2011-07-21 23:48:53 UTC
Reproduced in LO Calc 3.3.3.

lsb_release -rd
Description:	Ubuntu 11.04
Release:	11.04

apt-cache policy libreoffice-calc
libreoffice-calc:
  Installed: 1:3.3.3-1ubuntu1
  Candidate: 1:3.3.3-1ubuntu1
  Version table:
 *** 1:3.3.3-1ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-proposed/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
Comment 5 Robert Roth 2013-01-31 22:45:14 UTC
Do you
Comment 6 A (Andy) 2015-02-09 16:35:19 UTC
Reproducible with LO 4.4.0.3, Win 8.1.

Steps Done:
1. Open CALC
2. Write in cell A1 "test"
3. Select cell A1 and press CTRL + C
4. Select cell B1 and put the cursor in the Input Line below the toolbars at the top
5. Press CTRL + V

Interim Result: A space is appended at the end of "test"

6. Press the backspace key to delete this wrongly added space manually
>Take a look at the Input Line and the cell B1 itself<
   Press Enter

Result: In the Input Line only the wrongly added space is deleted, but in "real" the last character of "test" is deleted -> Result: "tes"
Comment 7 QA Administrators 2016-02-21 08:37:41 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2017-03-06 15:58:48 UTC Comment hidden (obsolete)
Comment 9 wope 2017-03-06 18:32:26 UTC
Since 4.1.6 8(linux) (the earliest version, i have) until 5.3.0.2 (linux and win) the defect was corrected
Comment 10 Christopher M. Penalver 2017-03-09 08:24:55 UTC
wope, thanks for testing to this. However, I was still able to reproduce as per below:
1) Windows 10 x64
Version: 5.3.0.3 (x64)
Build ID: 7074905676c47b82bbcfbea1aeefc84afe1c50e1
CPU Threads: 2; OS Version: Windows 6.19; UI Render: default; Layout Engine: new; 
Locale: en-US (en_US); Calc: group

2) apt policy libreoffice-calc
libreoffice-calc:
  Installed: 1:5.1.6~rc2-0ubuntu1~xenial1
  Candidate: 1:5.1.6~rc2-0ubuntu1~xenial1
  Version table:
 *** 1:5.1.6~rc2-0ubuntu1~xenial1 500
        500 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        500 http://us.archive.ubuntu.com/ubuntu xenial-security/main amd64 Packages
        100 /var/lib/dpkg/status
     1:5.1.2-0ubuntu1 500
        500 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
Comment 11 QA Administrators 2018-06-04 02:34:34 UTC Comment hidden (obsolete)
Comment 12 wope 2018-06-04 09:34:30 UTC
I tested it again with Win 10 and LibO 6.0.4.2
All was ok
Comment 13 Christopher M. Penalver 2018-06-04 22:12:05 UTC
This still happens in both Windows and Linux:
Version: 6.0.4.2 (x64)
Build ID: 9b0d9b32d5dcda91d2f1a96dc04c645c450872bf
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
Locale: en-US (en_US); Calc: group

Version: 6.0.3.2
Build ID: 1:6.0.3-0ubuntu1
CPU threads: 2; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 14 Xisco Faulí 2018-06-05 08:55:28 UTC
(In reply to A (Andy) from comment #6)
> Reproducible with LO 4.4.0.3, Win 8.1.
> 
> Steps Done:
> 1. Open CALC
> 2. Write in cell A1 "test"
> 3. Select cell A1 and press CTRL + C
> 4. Select cell B1 and put the cursor in the Input Line below the toolbars at
> the top
> 5. Press CTRL + V
> 
> Interim Result: A space is appended at the end of "test"
> 
> 6. Press the backspace key to delete this wrongly added space manually
> >Take a look at the Input Line and the cell B1 itself<
>    Press Enter
> 
> Result: In the Input Line only the wrongly added space is deleted, but in
> "real" the last character of "test" is deleted -> Result: "tes"

I can reproduce the problem with the adde space, but not the 'tes' result.
@Christopher M. Penalver, is this what you reproduce ?
Comment 15 Christopher M. Penalver 2018-06-05 22:20:26 UTC
Xisco Faulí, I'm only using the instructions noted in the Description (i.e. the scope of this report):
https://bugs.documentfoundation.org/show_bug.cgi?id=37864#c0
Comment 16 QA Administrators 2019-06-06 02:54:23 UTC Comment hidden (obsolete)
Comment 17 Thomas Lendo 2019-09-05 11:39:20 UTC
I can reproduce the issue from comment 0 (copying).

I cannot reproduce the issue from comment 6 (deleting) as Xisco also said in comment 14.

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 41cd3e8e817c8c33a13608e62eeb06ce2c6977e4
CPU threads: 12; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-09-01_22:04:10
Comment 18 QA Administrators 2021-09-05 04:36:08 UTC Comment hidden (obsolete)
Comment 19 Andreas Heinisch 2022-04-27 20:24:57 UTC
Repro in:
Version: 7.1.0.3 (x64) / LibreOffice Community
Build ID: f6099ecf3d29644b5008cc8f48f42f4a40986e4c
CPU threads: 6; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-US
Calc: CL

and in:
Version: 7.2.3.2 (x64) / LibreOffice Community
Build ID: d166454616c1632304285822f9c83ce2e660fd92
CPU threads: 6; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-US
Calc: CL

and in:
Version: 7.3.0.2 (x64) / LibreOffice Community
Build ID: f1c9017ac60ecca268da7b1cf147b10e244b9b21
CPU threads: 6; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-US
Calc: CL

No repro in:
Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: a58701650c2dd7ad8514752d571aa2569690fe37
CPU threads: 6; OS: Windows 10.0 Build 19044; UI render: Skia/Vulkan; VCL: win
Locale: de-DE (de_DE); UI: en-US
Calc: CL

So I close it as WFM. Feel free to open it again, if there is still any issue.
Comment 20 Andreas Heinisch 2022-04-27 20:33:32 UTC
*** Bug 93653 has been marked as a duplicate of this bug. ***
Comment 21 Xisco Faulí 2022-04-28 07:31:26 UTC
Issue fixed by

author	Eike Rathke <erack@redhat.com>	2022-02-17 18:28:17 +0100
committer	Eike Rathke <erack@redhat.com>	2022-02-17 19:10:03 +0100
commit be13ca182d7b0b59ad0c9509200cfdc45bd15cf2 (patch)
tree af84ab039423066fc923ef3be7f85dc98da419a6
parent 24231f2a336c50eac5e6a1621c57e60ebe1e1cf4 (diff)
Resolves: tdf#147496 No line feed for one single cell in clipboard Doc2Text()
Comment 22 Commit Notification 2022-04-28 10:57:28 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ae761fd359f4a553e4552125f77575204d62c958

tdf#37864, tdf#147496: sc: Add UItest

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.