Download it now!
Bug 37919 - Clicking "more" on the Language Section in Writer at the bottom bar opens up the wrong Dialog Window.
Summary: Clicking "more" on the Language Section in Writer at the bottom bar opens up ...
Status: CLOSED DUPLICATE of bug 32780
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.0 Beta2
Hardware: All All
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 37921 58579 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-06-04 05:54 UTC by aaron.hcc
Modified: 2014-08-20 11:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description aaron.hcc 2011-06-04 05:54:48 UTC
Overview:

Clicking "more" on the Text Language Section in Writer at the bottom bar opens up the "Character" Dialog Box at the "Font" Tab. Instead, the "Options - Language Settings - Languages" Dialog Box should be opened.

Steps to Reproduce:

1) Open Writer

2) Head for the bottom bar (Statusbar?) and click on the "More..." entry. You may as well point at "Set Language for this paragraph" and select "More..."

Actual Results: "Character" Dialog Box opens at the "Font" Tab. This is wrong, because it has nothing to do with language selection.

Expected Results:  the "Options - Language Settings - Languages" Dialog Box should be opened, because there, the user is able to select the Language he/she wants to.

Additional Builds and Platforms: This arror shows up on all plattforms the suite is installed on.
Comment 1 vitriol 2011-06-04 06:08:40 UTC
(In reply to comment #0)

> Actual Results: "Character" Dialog Box opens at the "Font" Tab. This is wrong,
> because it has nothing to do with language selection.

This is the correct behavior for me. The language for a paragraph is setted by the character attribute.
Options > Language Settings > Languages set the language of the whole document instead. You can open this option with Tools > Language > For all Text > More...
Not a bug for me.
Comment 2 vitriol 2011-06-04 06:13:14 UTC
*** Bug 37921 has been marked as a duplicate of this bug. ***
Comment 3 aaron.hcc 2011-06-05 02:54:14 UTC
(In reply to comment #1)
> 
> This is the correct behavior for me. The language for a paragraph is setted by
> the character attribute.

Actually there seems to be an Language dropdown-box in the font-character dialogue. I wonder why I did not take any notice of it. (O.o)

But I still see a bug here.

If, as you state, the language of the paragraph is setted by the character attribute, it makes sense to open up the font dialogue at the character tab when pointing at the "set language for paragraph" entry. 

But just clicking "More" without pointing to this entry predicts the intention of wanting to change the language for all text. Otherwise, this specific "set language for paragraph" entry would be useless. In my opinion, the appropriate behaviour in this case would be to provide the user with exactly that option.

For this reason, I flag this bug entry as reopened
Comment 4 vitriol 2011-06-05 05:40:30 UTC
(In reply to comment #3)

> Otherwise, this specific "set
> language for paragraph" entry would be useless. In my opinion, the appropriate
> behaviour in this case would be to provide the user with exactly that option.

I don't understand... if you select "Set language for paragraph > More..." and you change the language in "Font > Language" combo box, only the language of paragraph where you have the cursor on will change. What's wrong?
This is the behavior of OpenOffice too, from many versions.
Comment 5 aaron.hcc 2011-06-06 10:48:40 UTC
(In reply to comment #4)
> (In reply to comment #3)
> 
> > Otherwise, this specific "set
> > language for paragraph" entry would be useless. In my opinion, the appropriate
> > behaviour in this case would be to provide the user with exactly that option.
> 
> I don't understand... if you select "Set language for paragraph > More..." and
> you change the language in "Font > Language" combo box, only the language of
> paragraph where you have the cursor on will change. What's wrong?
> This is the behavior of OpenOffice too, from many versions.


Yes, if you select "Set language for paragraph  > More...", and you change the language,  only the paragraph with the cursor will be affected.

But what if you do not select "Set language for paragraph", but the "More..." entry right above the "Set language for paragraph"?

There are two "More..." entrys:

(1) Click on language at the bottom --> point at "Set language for paragraph" --> select "More..."

(2) Click on language at the bottom --> Select "More..."

Case (1) suggests selecting the language for the current paragraph, as you pointed out.

I see the "bug" in case (2): In my opinion, case (2) suggests changing the language for the whole document. 
Why else should there be two "More..." entrys then?

But currently case (2) opens the exact same dialogue as case (1). This behaviour is faulty in my opinion. Otherwise, having two entrys would not make sense to me.

Hopefully it is now clear, what I mean. Sorry, English is not my mother tounge. ;)
Comment 6 manj_k 2011-06-06 11:51:44 UTC
(In reply to comment #5)
> [...]
> 
> (2) Click on language at the bottom --> Select "More..."
> 
> Case (1) suggests selecting the language for the current paragraph, as you
> pointed out.
> 
> I see the "bug" in case (2): In my opinion, case (2) suggests changing the
> language for the whole document. 
> Why else should there be two "More..." entrys then?
> 
> But currently case (2) opens the exact same dialogue as case (1). This
> behaviour is faulty in my opinion. Otherwise, having two entrys would not make
> sense to me. [...]

No, that's the correct behaviour.

The control in the status bar always shows the language set at the current cursor position/selection. [1](p. 1, 4)

The 'More...' entry [your case (2)] from of the context menu calls the Format-Character dialog and the Font tab page is shown. [1] (p. 6)

What is the difference?

In that case the language at the current cursor postion (e.g. a word) or for the selection can be changed.

In the other case [your case (1)] the language for the whole paragraph at the current cursor positon can be changed.


[1] Software Specification Document
OpenOffice.org Writer
Set Language Attribute for Text
http://specs.openoffice.org/appwide/linguistic/Set_Language_Attribute_for_Text.odt

For sure: NOTABUG
Comment 7 aaron.hcc 2011-06-07 00:00:18 UTC
OK, maybe you are right, and it is not a bug.

But still, in my opinion, the developers could make this behaviour clearer, e.g. by adding submenus like "change language for word" and "change language for document". 

> The control in the status bar always shows the language set at the current
> cursor position/selection. [1]

Although this might be the case, adding this extra "document" option would certainly not do any harm imho... It would definitely clear thigs up...

Or at least make this difference between this two "Mores..." clearer, maybe be overlooking the text in this submenus to clarify:

> What is the difference?
> 
> In that case the language at the current cursor postion (e.g. a word) or for
> the selection can be changed.
> 
> In the other case [your case (1)] the language for the whole paragraph at the
> current cursor positon can be changed.

Thank you all for your kind support! ;)
Comment 8 brmj.page 2012-12-20 22:54:12 UTC
*** Bug 58579 has been marked as a duplicate of this bug. ***
Comment 9 walder 2014-04-02 23:35:16 UTC
This is actually not a bug but it makes working a bit anoying when a user works with several languages in the same document.

I suggest to show up de installed languages on the system. Users normaly work with languages they installed before.

It seems that writer tries to guess the language written in the paragraph but usually this is incorrect. It's possible to choose the language with the character dialog clicking on the "more" option but this is very anoying and time consuming. I hope the developpers could include this feature in future versions.
Comment 10 Johannes Buchner 2014-08-20 11:11:13 UTC
Marking as duplicate of earlier bug.

*** This bug has been marked as a duplicate of bug 32780 ***