Bug 37967 - VIEWING: Option like "MS WORD's normal view" needed
Summary: VIEWING: Option like "MS WORD's normal view" needed
Status: RESOLVED DUPLICATE of bug 39080
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: high enhancement
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
: 40231 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-06-05 23:51 UTC by Tero Niemi
Modified: 2017-05-29 14:25 UTC (History)
14 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tero Niemi 2011-06-05 23:51:32 UTC
Could it be possible to add this feature requested over 9 years ago for OpenOffice:

http://openoffice.org/bugzilla/show_bug.cgi?id=4914

"The Word Processor component of OpenOffice 1.0 has a default view, with margins 
and big spaces for page breaks; as well as an "online view" which simulates how 
the page will look if published on the web. It also needs the MS Word "Normal" 
view, which shows just the text, with no left hand margin space, and no extra 
space for page breaks (just a dotted line). I write a lot of simple text and 
don't need extra formatting, and all the extra space taken up for margins and 
page breaks is just useless to me. I much prefer a more "text editor" type 
approach, which MS Word supports."

This and the related "Outline view" are one of the oldest, most voted, and still open bugs/requests in OpenOffice:

http://openoffice.org/bugzilla/buglist.cgi?field0-0-0=votes&type0-0-0=greaterthan&value0-0-0=259

(listing all bugs with more than 259 votes)

Please, PLEASE fix this one!
Comment 1 DutchSherpa 2011-06-19 15:10:56 UTC
Closely related to this bug (actually a design flaw) is the lack of the "hide white space" function as it is called in MS Word. The feature request on the OpenOffice buglist dates back to 2002. See http://openoffice.org/bugzilla/show_bug.cgi?id=8006.

The inability to display formatted text in a continuous flow (i.e. without upper and lower margins and headers/footers) in OOo/LibO has been a major obstacle for the adoption of OOo by professional writers and companies.
Imho, the importance of this issue is grossly undervalued by the developers. It is a permanent nuisance for users and, worse still, a instant dealbreaker for many newbies.
Comment 2 Björn Michaelsen 2011-12-23 12:03:07 UTC Comment hidden (obsolete)
Comment 3 Tero Niemi 2011-12-27 02:46:53 UTC
The problem still persists.

Also, please see Open Office Writer views design proposal:
http://wiki.services.openoffice.org/wiki/Writer_Views#Draft_Layout
Comment 4 Aethralis 2012-02-04 04:55:43 UTC
*** Bug 40231 has been marked as a duplicate of this bug. ***
Comment 5 Michael Longval 2013-01-31 03:20:33 UTC
Not really a bug.

Rather a LONG overdue feature enhancement.

I have recently come back to LibreOffice (used OpenOffice and StarOffice before that), after having used MS-Word.

I concur that LibreOffice needs a Normal View where formatting and fonts are not displayed, just the text (bold and italic is acceptable).

This would go a long way to bridge what LibreOffice has to offer as a writing tool and what programs like WriteRoom, OmmWriter, PyRoom and multiple others have to offer : DISTRACTION FREE WRITING.  

1) Call it "Distraction Free View"  --- rather obvious

2) Allow for a DIFFERENT color theme than for Web or Print view.  For those of you who are old enough : Remember WordPerfect white on blue screen.  I am still drawn to that. Currently the chosen color theme applies to BOTH Web and Print view.  So if I chose to edit text in Web View (sorta of a stopgap) with a blue backgroud and yellow font. That color theme is carried over to Print view when I want to check formatting.  I have to go and change the color theme.  It's a pain.

3) If we really want to go wild...: allow for different keybindings in "Distraction Free View"

- a Vim mode
- or and Emacs mode
- or Wordstar mode (would probably get some old science fiction writers, who are still useing WordStar, to switch to LibreOffice.)

What can I do to help you with this?
Comment 6 VX 2013-01-31 14:54:02 UTC
Sounds reasonable. +1 for the ideas

(In reply to comment #5)
> Not really a bug.
> 
> Rather a LONG overdue feature enhancement.
> 
> I have recently come back to LibreOffice (used OpenOffice and StarOffice
> before that), after having used MS-Word.
> 
> I concur that LibreOffice needs a Normal View where formatting and fonts are
> not displayed, just the text (bold and italic is acceptable).
> 
> This would go a long way to bridge what LibreOffice has to offer as a
> writing tool and what programs like WriteRoom, OmmWriter, PyRoom and
> multiple others have to offer : DISTRACTION FREE WRITING.  
> 
> 1) Call it "Distraction Free View"  --- rather obvious
> 
> 2) Allow for a DIFFERENT color theme than for Web or Print view.  For those
> of you who are old enough : Remember WordPerfect white on blue screen.  I am
> still drawn to that. Currently the chosen color theme applies to BOTH Web
> and Print view.  So if I chose to edit text in Web View (sorta of a stopgap)
> with a blue backgroud and yellow font. That color theme is carried over to
> Print view when I want to check formatting.  I have to go and change the
> color theme.  It's a pain.
> 
> 3) If we really want to go wild...: allow for different keybindings in
> "Distraction Free View"
> 
> - a Vim mode
> - or and Emacs mode
> - or Wordstar mode (would probably get some old science fiction writers, who
> are still useing WordStar, to switch to LibreOffice.)
> 
> What can I do to help you with this?
Comment 7 bugquestcontri 2013-02-08 02:33:38 UTC
Although I got used to teh views available in Writer, I still miss the "Normal View" of Word. 

Michael Longval explanations and proposals are excellent!

I hope we can get them realized in Writer soon.
Comment 8 Emir Sarı (away) 2013-02-08 05:29:44 UTC
Well, this is what I would call a perfect feature for end users (and the outline view request as well).
Comment 9 Samuel Mehrbrodt (CIB) 2013-03-02 15:07:51 UTC
Some people already offered money for fixing this at Freedomsponsors: http://www.freedomsponsors.org/core/issue/203/viewing-option-like-ms-words-normal-view-needed

You might consider increasing that money if you want to get this implemented (You pay only when it has been implemented).
Comment 10 bugquestcontri 2013-03-04 01:04:26 UTC
Using the navigator now for almost a year I am still missing beside the normal view the outline view of word.
Also Emir can pointed this out.

I offer my time for testing the new SW as long as I can run the test version parallel to my production version currently 3.6.5
Comment 11 Greg 2013-04-22 12:47:57 UTC
I agree with Comment 1 and hope to see the "hide white space" feature implemented soon. This is the most important feature for me.
Comment 12 Tero Niemi 2013-04-23 08:08:50 UTC
Links in my original post have been outdated while the Open Office product has travelled from Sun to Oracle to Apache Foundation. Here are the current ones:

The original bug report / feature request: 
    https://issues.apache.org/ooo/show_bug.cgi?id=4914

Bug votes of importance:
    https://issues.apache.org/ooo/buglist.cgi?field0-0-0=votes&type0-0-0=greaterthan&value0-0-0=259

(The original report was made 2002-05-15, so in the next month it is celebrating its 11th anniversary. BDS Project had once a 25 year old one fixed, so there is still hope.)
Comment 13 Andrej 2014-07-11 10:02:49 UTC
Instead of the "hide white space" feature I use the "web layout", but that is not rally the same. Too bad, because it is a really nice future.
Comment 14 Jean-Baptiste Faure 2015-02-21 21:39:48 UTC
Set back to enhancement.
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Severity

Best regards. JBF
Comment 15 peterpan 2016-01-05 14:16:24 UTC
Let me second this request for enhancement.
Comment 16 Jean-Baptiste Faure 2016-01-05 14:31:08 UTC
This feature is currently implemented in the next 5.1 version. Please see bug 39080.

Best regards. JBF

*** This bug has been marked as a duplicate of bug 39080 ***
Comment 17 ErolB1 2017-05-29 14:25:56 UTC
I've just registered here to state my view that "Hide Whitespace" is NOT an adequate substitute for a Normal View. And that there is a meta-bug here in the form of developers not getting why a Normal View is such a "Critical! Need to have! Feature!" for many users (or rather non-users) of Open/LibreOffice. When I've gripped about this elsewhere, the usual programmer response was that it was a bug in my wetware - that my need for a Normal mode meant that I was trying to write prose in the wrong way. 

The reasons why "Hide Whitespace" is not an adequate substitute for Normal View include: 

- The proper behavior for Hide Whitespace is to show the blank page below the last line down to the bottom margin. The proper behavior for Normal View is to show the first line on the next page *immediately* below the last line of the page. 

- The proper behavior for Hide Whitespace is to stagger margins from page to page, when, e.g. the document has alternating left-and-right margins on odd-and-even pages. The proper behavior for Normal View is to align left margins from page to page, even if the left margin is (e.g.) 0.5 inches on one page and 1.5 inches on the next. 

- The proper behavior for Hide Whitespace is to display a thick, dark-gray line between pages that serves as a clear (and somewhat intrusive) end-of-page warning. The proper behavior for Normal View is to display a thin, light-gray start-of-next-page line that the user will notice only if he looks for it - that he can easily ignore.