Download it now!
Bug 38226 - Writer not saves DELETED new line character after table properly
Summary: Writer not saves DELETED new line character after table properly
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-13 01:31 UTC by sasha.libreoffice
Modified: 2015-03-07 08:15 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
document with table and completely empty second page (13.37 KB, application/vnd.oasis.opendocument.text)
2011-06-13 01:31 UTC, sasha.libreoffice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sasha.libreoffice 2011-06-13 01:31:15 UTC
Created attachment 47882 [details]
document with table and completely empty second page

Writer places new line character after table. In this document it is unnecessary and I delete it. It deletes ok. But when I load this document next time, this character appears anew.
To reproduce this problem:
0. Open attached document. There is text and table on first page and second page is completely empty (if not so then change something there to be so)
1. Place cursor in right bottom cell of table and press Ctrl-Shift-Delete. Second page disapears
2. Press File->Save
3. Press File->Reload. Second empty page appears

(if need add new line after table, place cursor in last cell and press Alt-Enter, if need add new line before table, place cursor in first cell and press Alt-Enter)

Reproduced on LibO 3.4 on Mandriva 64 bit and Windows XP 32 bit
Comment 1 Yifan Jiang 2011-06-13 02:29:25 UTC
I can reproduce the problem on LibO 3.4 SLED 11 sp1 i586.

Hi sasha, 

I am a bit confused with the title 'Writer not saves new line character after table properly', does it actually mean ' Writer not saves DELETED new line character after table properly'? Or there's something else implicitly need to report? Thanks!
Comment 2 André Schnabel 2011-06-18 13:58:21 UTC
confirmed using LibO 3.4RC1,

if you load a document which has a table as last element in <office:text> it will automatically add an empty paragraph while loading. This paragraph should not be added!
Comment 3 Björn Michaelsen 2011-12-23 12:26:41 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 4 sasha.libreoffice 2011-12-25 06:02:14 UTC
on LibO 3.5.0 beta 1 still exist
Comment 5 A (Andy) 2013-04-27 17:07:54 UTC
@Sasha: Am I doing something wrong?  I can not delete the line below the table by using the combination Ctrl + Shift + Delete with the cursor in the right bottom cell of table (with LO 4.0.2.2 [Win7 Home, 64bit]).  Does this work for you?
Comment 6 sasha.libreoffice 2013-04-29 05:18:24 UTC
Just another bug:
Bug 60967 - EDITING: Table shortcut Ctrl+Shift+Del ineffective cannot delete following paragraph of a table
Bug 33631 - Can't remove new line after table

Which in turn may be workaround of this:
Bug 42504 - [FILEOPEN] delete empty paragraph after table → table disappears after saving in .doc format
Comment 7 QA Administrators 2015-03-04 02:21:07 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1.2 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-03-03
Comment 8 Jean-Baptiste Faure 2015-03-07 08:15:35 UTC
Due to comment #33 from bug 60967 (https://bugs.documentfoundation.org/show_bug.cgi?id=60967#c33) I think we have to close this bug report as WontFix.
The idea is: ending a document with a table (without a paragraph after it) causes too many problems.

Please, feel free to reopen if you disagree.

Best regards. JBF