Bug 38246 - Change visibility of comments / notes via Notes Ruler Control [UI] [VIEWING] (OOoNotes2)
Summary: Change visibility of comments / notes via Notes Ruler Control [UI] [VIEWING] ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Rodolfo
QA Contact:
URL:
Whiteboard: Vote target:4.1.0
Keywords: difficultyInteresting, easyHack, skillCpp, topicUI
: 36896 39431 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-06-13 06:24 UTC by Christoph
Modified: 2015-12-16 00:38 UTC (History)
9 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph 2011-06-13 06:24:09 UTC
Issue: At the moment, the user is forced to use the application menu to toggle the visibility of the Notes (e.g. Notes Windows, Notes Anchors). This proposal provides a control located in a currently unused part of the Writer ruler bar. The topic relates to the OpenOffice.org Notes2 activity [1].

Current status:
* Enabling/disabling of the Notes Side Pane is implemented via the application menu (only)
* Complete specification for the Notes Ruler Control is available at [2]

Required changes:
* New control needs to be added in the ruler area of Writer

Contact: Christoph Noack (Design Team)


References:
[1] Notes2 - Improved Notes for OOo
http://wiki.services.openoffice.org/wiki/Notes2

[2] Specification for "Notes Ruler Control"
http://wiki.services.openoffice.org/wiki/Notes2_Design_NotesSidePane#Proposal_.22Notes_Ruler_Control.22
Comment 1 gleppert 2011-07-23 11:06:22 UTC
*** Bug 39431 has been marked as a duplicate of this bug. ***
Comment 2 gleppert 2011-07-23 11:18:39 UTC
*** Bug 36896 has been marked as a duplicate of this bug. ***
Comment 3 gleppert 2011-07-23 11:20:03 UTC
Having marked bug 39431 as duplicate. As this bug entry describes a better
solution to the same problem than bug 36896, I also mark that bug as duplicate.

Some additional information taken from these bug entries:

* Comments in Writer are a great feature but it is hard to turn them on and
off. This should be improved. 
* Another toolbar should be avoided and instead a Notes Ruler Control should be
used.
* Some hints on Notes Ruler Control implementation of how this could be done as
an extension to the existing ruler code: The existing ruler code is (shared) in
svx/source/dialog/svxruler.cxx and svx/inc/svx/ruler.hxx - and this builds on
top of the svtools ruler: svtools/inc/ruler.hxx and
svtools/source/control/ruler.cxx - see eg. Ruler::Paint there (and vcl's
outdev.hxx for drawing methods).
*Improvement to Comment handling in Impress/Draw/Calc: The existing comment
toolbar in Impress/Draw should be removed and a sufficient Notes handling
should be added in the Navigator of Impress/Draw/Calc.
Comment 4 Björn Michaelsen 2011-09-28 04:58:36 UTC
This has just been featured on http://wiki.documentfoundation.org/Development/Easy_Hacks
Comment 5 Max Odendahl 2011-10-26 01:59:03 UTC
If I am smart enough to use git and libreoffice is buildable with Lion I will try to implement this. Won't be fast due to many other committments, but still interested in implementing this....

Anyone can answer the lion issue?
Comment 6 Björn Michaelsen 2011-10-26 03:33:47 UTC
@Max: Great to see you at Libreoffice! For OSX questions thorsten and shm_get (Norbert Thiebault) are your first contact guys as the are having tinderboxes for OSX.
Comment 7 Don't use this account, use tml@iki.fi 2011-10-26 03:43:42 UTC
LO is buildable on Lion, sure, but the more interesting question is against what SDK. Building against the 10.6 SDK (comes with the latest Xcode in addition to the 10.7 one) should work, but you need to use the non-LLVM compiler(s), gcc-4.2 and g++-4.2.

At least, I think that was the conclusion I arrived at when trying last. You might want to use an autogen.lastrun something like this:

CC=ccache gcc-4.2 -arch i386 -mmacosx-version-min=10.4
CXX=ccache g++-4.2 -arch i386 -mmacosx-version-min=10.4
--disable-binfilter
--disable-build-mozilla
--disable-mozilla
--disable-online-update
--enable-epm
--with-java-target-version=1.5
--with-macosx-version-min-required=10.4
--with-macosx-sdk=10.6
Comment 8 Don't use this account, use tml@iki.fi 2011-10-26 04:04:23 UTC
Oh, and now I remember one thing: You need to:

sudo ln -s i686-apple-darwin10 /Developer/SDKs/MacOSX10.6.sdk/usr/lib/gcc/i686-apple-darwin11

if you are using the bleeding-edge Xcode 4.2. No guarantee that the resulting LO works, I don't remember if I got that far before the wife managed to put the MBP to sleep once again while I was logged in remotely;)
Comment 9 Thorsten Behrens (CIB) 2011-10-26 06:12:38 UTC
I think, from an efficiency point of view, using XCode 3.2.6 (or somesuch) is the quickest path to success. With that, a default configure should work.
Comment 10 Don't use this account, use tml@iki.fi 2011-10-26 06:22:05 UTC
But whether a "default" configure (no options at all to autogen.sh) works with Xcode 3.2.6 installed depends very much on where it is installed, and whether Xcode 4.x is also installed. I think our default configure works only if Xcode 3 is the only Xcode installed, in /Developer, or if it was in /Developer and installing Xcode 4.x moved that to /Developer-old.

(Personally I have Xcode 3.2.6 in /Xcode3, and Xcode 4.2 in /Developer.)
Comment 11 Cédric Bosdonnat 2012-02-04 06:21:36 UTC
Not that easy for a beginner... discussed with Bjoern
Comment 12 Christoph 2012-06-09 11:51:27 UTC
A rather complete SPECIFICATION is now available on a Design Team Whiteboard, see:
https://wiki.documentfoundation.org/Design/Whiteboards/Comments_Ruler_Control
Comment 13 Commit Notification 2013-03-11 09:14:24 UTC
Rodolfo Ribeiro Gomes committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e047a967b0db8c61dc977b52f3876fc4e385ad77

fdo#38246 Comment control on Writer ruler feature



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Cédric Bosdonnat 2013-03-11 09:19:49 UTC
Implemented by Rodolfo
Comment 15 Robinson Tryon (qubit) 2015-12-16 00:38:50 UTC
Migrating Whiteboard tags to Keywords: (EasyHack DifficultyInteresting SkillCpp TopicUI )
[NinjaEdit]