Bug Hunting Session
Bug 38671 - [UI] Main context menu has too many separators
Summary: [UI] Main context menu has too many separators
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: All All
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-25 09:14 UTC by Stefan Knorr (astron)
Modified: 2011-07-04 14:30 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Impress menu before and after change, mock-up (7.24 KB, image/png)
2011-06-25 09:14 UTC, Stefan Knorr (astron)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Knorr (astron) 2011-06-25 09:14:27 UTC
Created attachment 48402 [details]
Impress menu before and after change, mock-up

The Draw and Impress main context menus have too many separators. This makes mouse travels longer than necessary, looks cluttered and separates things that could go together.
To reproduce open a new document and right-click on an empty space in the Impress/Draw document.

The code for these context menus seems to be in /impress/sd/source/ui/app/popup2_tmpl.src , line 551 and following.

All that should be needed would be changing/reordering the current menu to this [1]:

#if SD_POPUP == RID_DRAW_TEXTOBJ_POPUP
    Menu RID_DRAW_NOSEL_POPUP
#elif SD_POPUP == RID_GRAPHIC_TEXTOBJ_POPUP
    Menu RID_GRAPHIC_NOSEL_POPUP
#endif
{
    ItemList =
    {
#if SD_POPUP == RID_DRAW_TEXTOBJ_POPUP
        MN_SLIDE_MENU
#elif SD_POPUP == RID_GRAPHIC_TEXTOBJ_POPUP
        MN_PAGE_MENU
#endif
        MN_NAVIGATOR
#if SD_POPUP == RID_DRAW_TEXTOBJ_POPUP
        MN_OUTLINEMODE
        MN_DIAMODE
        MN_PRESENTATION
#endif
        SEPARATOR
        MN_GRID
        MN_HELPLINES
        MN_CAPTUREPOINT
        SEPARATOR
        MN_LEAVE_GROUP
    };


[1] take this with a grain of salt – I am not an engineer and I haven't tested this. I don't know if there are side effects.
Comment 1 Rainer Bielefeld Retired 2011-07-02 07:23:09 UTC
@Cristoph:
Imho suggested solution would be an improvement.
Draw main context menu should be improved in the same way.
Any idea to whom we can assign this one?
Comment 2 Stefan Knorr (astron) 2011-07-02 14:37:02 UTC
Rainer, this single change already changes both context menus. I've asked on ux-avise, but so far no one answered (might have to do with the fact that I accidentally posted in the wrong thread), I will try again (but I don't want anyone to feel like I am spamming).
Comment 3 Thorsten Behrens (CIB) 2011-07-04 14:30:39 UTC
Thx for the fix, looks perfect - committed to master.