Bug 38838 - Removal/Replacement of the String/UniString with OUString once and for all.
Summary: Removal/Replacement of the String/UniString with OUString once and for all.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Caolán McNamara
QA Contact:
URL: https://wiki.documentfoundation.org/D...
Whiteboard: target:3.7.0 target:4.0.0 target:4.1....
Keywords: difficultyBeginner, easyHack, skillCpp, topicCleanup
: 59925 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-06-30 09:28 UTC by Björn Michaelsen
Modified: 2016-02-18 16:37 UTC (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Björn Michaelsen 2011-06-30 09:28:41 UTC
Removal/Replacement of the String/UniString/ByteString with OUString/OString once and for all.

Background: OO.o uses duplicate string classes, and should not. The 'old' !UniString class is limited to 64k, yet has many more helpful helper methods. We need to create similar helper methods for OUString and port the existing code to use the basic string class. Solid base classes are essential to removing old limits: see fd#30668. You can find a cross reference of the corresponding functions at: Development/String_Classes. We should write unit tests in parallel to ensure that nothing breaks in transition and in the future.

Skills: building, coding, writing unit tests, etc.
Comment 1 Caolán McNamara 2011-08-22 14:13:48 UTC
As an update here.

a) ByteString and UniString have been stripped down to the bits that are used and unused methods removed.
b) ByteString::CreateFromInt32 has been replaced
c) ByteString::ConvertFromUnicode has been replaced
d) ByteString::ConvertToUnicode has been replaced
e) ByteString::CreateFromInt32 has been replaced
f) ByteString::ToInt64 (which was wrong anyway) has been replaced
Comment 2 Caolán McNamara 2011-08-22 14:15:03 UTC
bah!
e) ByteString::CreateFromInt32 has been replaced
->
e) ByteString::CreateFromInt64 has been replaced
Comment 3 Caolán McNamara 2011-11-16 03:02:37 UTC
Progressing bit by bit. I reckon the easiest approach here is to tackle ByteString first, there isn't too many of them left in the code.

In some cases OString is a good fit, in other OStringBuffer is a better fit. And sometimes you can find/write a helper function in comphelper/inc/string.hxx to help bridge the awkward cases.
Comment 4 Caolán McNamara 2012-02-27 01:49:41 UTC
update: ByteString is now completely removed, only UniString remains
Comment 5 Pallav Shinghal 2012-03-31 18:51:22 UTC
I'd like to work on this. Can it be assigned to me please? Also, where can I see the versions that have already been fixed (ByteString), so that I have an example to guide me?
Comment 6 David Tardon 2012-04-01 22:09:21 UTC
(In reply to comment #5)
> I'd like to work on this. Can it be assigned to me please?

I do not think this is a one-man task... Just pick a module (or just a bunch of files) that still use String and try to replace it by rtl::OUString + rtl::OUStringBuffer. Beware of "rippling" effects, .e.g., if you replace String by rtl::OUString in a virtual function declaration, you will have to change all the derived classes as well, otherwise overriding will be broken.

> Also, where can I
> see the versions that have already been fixed (ByteString), so that I have an
> example to guide me?

See https://wiki.documentfoundation.org/Development/String_Classes for (rough) comparison of functions of both classes. The most important difference is that String is mutable while rtl::OUString is not. For constructing a string piece by piece, use rtl::OUStringBuffer and then call makeStringAndClear() to get rtl::OUString.

There are also additional string functions in comphelper/inc/comphelper/string.hxx .
Comment 7 Florian Reisinger 2012-05-18 08:59:23 UTC
Deteted "Easyhack" from summary
Comment 8 Caolán McNamara 2012-06-06 06:38:20 UTC
String::Reverse now removed as well
Comment 9 Caolán McNamara 2012-10-28 23:10:22 UTC
String::Expand now removed as well
Comment 10 Not Assigned 2012-11-02 13:55:00 UTC
Ricardo Montania committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=89519528563a0e740fe22acaf9ab90f83af99695

fdo#38838 UniString replacement



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Not Assigned 2012-11-03 17:22:54 UTC
Ricardo Montania committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b524b0bd98e4f841c88b91bff4bd23e68897a501

fdo#38838 UniString removal



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Not Assigned 2012-11-14 16:40:06 UTC
Ricardo Montania committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=752cb97a8fb189b6e11d3a55704222b9aba1b11a

fdo#38838 UniString removal



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Not Assigned 2012-11-30 19:40:02 UTC
Ricardo Montania committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2cb8883cfd1c6ffe293497f064f90f76d12eff32

fdo#38838 UniString -> OUString in cui



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Not Assigned 2012-11-30 19:55:55 UTC
Ricardo Montania committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ae2e02261de0c77394f28c19f07153dcb43bc330

fdo#38838 UniString -> OUString in cui



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 15 Caolán McNamara 2012-12-15 11:49:13 UTC
UniString( sal_Unicode c );
and
UniString& Assign( const sal_Unicode* pCharStr, xub_StrLen nLen );
have now become unused and have been removed
Comment 16 Caolán McNamara 2012-12-17 09:35:33 UTC
UniString::Fill now removed
Comment 17 Not Assigned 2013-01-13 07:43:18 UTC
Jean-Noël Rouvignac committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6f3c367f9c2bff7520f2a55f1795fd718abea938

fdo#38838 Some removal/replacement of the String/UniString with OUString



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 18 Not Assigned 2013-01-22 14:28:18 UTC
Jean-Noël Rouvignac committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e13a3d566ecc34a46e037aca1b2d70e58501e422

fdo#38838 Some removal/replacement of the String/UniString with OUString



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 19 Julien Nabet 2013-01-27 10:36:37 UTC
*** Bug 59925 has been marked as a duplicate of this bug. ***
Comment 20 Not Assigned 2013-01-28 16:41:39 UTC
Jean-Noël Rouvignac committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0dc532bffcda35d15a4719c05bb258e470355b98

fdo#38838 Some removal/replacement of the String/UniString with OUString



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 21 Not Assigned 2013-02-08 15:03:57 UTC
Jean-Noël Rouvignac committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9e310cc32923ceb4b18d97ce68d54a339b935f01

fdo#38838 Some removal/replacement of the String/UniString with OUString



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 22 Not Assigned 2013-02-19 12:05:35 UTC
GergÅ Mocsi committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3cfe6ad137aa358e26b0d7b1f591e91bd19957ce

fdo#38838, ::rtl::OUString to OUString, String to OUString



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 23 Not Assigned 2013-02-19 13:58:14 UTC
Jean-Noël Rouvignac committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=742515639168cd35a0c2036a5bf6c46b2a3a554e

fdo#38838 ScGlobal::GetRscString() now returns OUString instead of String.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 24 Not Assigned 2013-02-22 09:51:08 UTC
GergÅ Mocsi committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1da3af5f1eb6a32fd0ab10da7cf2f8ddb298a3a1

fdo#38838, ::rtl::OUString, String to OUString



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 25 Not Assigned 2013-02-22 17:27:59 UTC
Jean-Noël Rouvignac committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6119e15c8b2b19c6ea3c271fb1c9d7e047902e77

fdo#38838 search replace for String::CreateFromInt32().



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 26 Not Assigned 2013-02-22 17:34:15 UTC
Jean-Noël Rouvignac committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bb5fa449378d6535932d39f2357c06e181647346

fdo#38838 search replace for String::CreateFromInt32().



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 27 Not Assigned 2013-02-22 17:34:35 UTC
Jean-Noël Rouvignac committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=08603e66f9a994418d4e2a2badee3f5a6b3f7168

fdo#38838 search replace for String::CreateFromInt32().



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 28 Not Assigned 2013-02-24 13:05:24 UTC
Jean-Noël Rouvignac committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=63b0ce97ba0f71c28a7880c741100b0240332e74

fdo#38838 searched, replaced and removed String::CreateFromInt32().



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 29 Not Assigned 2013-02-25 13:03:06 UTC
elixir committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5269589ae4fbe65a7c4e3de3d429bc834348bf79

fdo#38838,::rtl::OUString_to_OUString



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 30 Not Assigned 2013-02-26 10:27:17 UTC
Author: GergÅ Mocsi committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3252c5d4980016246417d0253749f37f1ed87a80

fdo#38838, String to OUString in dbaccess/source/ext/macromigration



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 31 Not Assigned 2013-02-26 15:54:26 UTC
Jean-Noël Rouvignac committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=465dbaecf9890b7117a45d02ea982ef7aca32720

fdo#38838 Replaced some use of (Xub)String with OUString.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 32 Not Assigned 2013-02-28 01:31:15 UTC
elixir committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9133cc452c9e473164755a2177b7a2285c09cb22

fdo#38838,UniString,String_to_OUString



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 33 Not Assigned 2013-02-28 15:54:53 UTC
GergÅ Mocsi committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d5f12bfbf97e179ca45476bb7faf275bdf26f5ca

fdo#38838, String to OUString in module dbaccess/source/sdbtools/connection



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 34 Commit Notification 2013-03-04 17:36:25 UTC
Adam Csaba Kiraly committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=11109e8ab8cfa49750d0a2adc3afe3a8a0fc0b48

fdo#38838, replace String with OUString



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 35 Commit Notification 2013-03-04 18:23:17 UTC
Adam Csaba Kiraly committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=30e14d7d3a70f0b5f5a6163d122e501cc5edc334

fdo#38838, change String to OUString



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 36 Commit Notification 2013-03-05 12:50:47 UTC
Adam Csaba Kiraly committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=10bb5b8e24b90f881ac0ef758bb11a0bbd531a67

fdo#38838, replacement of String with OUString



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 37 Commit Notification 2013-03-07 19:53:19 UTC
Jean-Noël Rouvignac committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3bc29af446fd1d9bd267ade1b1a5fca725ca8166

fdo#38838 Replaced some use of (Uni)String with OUString.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 38 Commit Notification 2013-03-11 15:54:04 UTC
elixir committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7d1f4cdec307bb1e761bb5dd3d8231bba5833e10

fdo#38838: Converting String/UniString to OUString



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 39 Caolán McNamara 2013-03-12 20:18:36 UTC
UniString::CreateFromInt32 now complete gone
Comment 40 Commit Notification 2013-03-12 21:24:02 UTC
elixir committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a53f5933ea67cdc05695861fc15175c9451ceb3e

fdo#38838: Replaced some String with OUString



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 41 Commit Notification 2013-03-14 22:15:05 UTC
elixir committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b0cf3aba085373d84a55ef144b273a8a89d017af

fdo#38838: Replaced some (Uni)String to OUString in core/sc



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 42 Commit Notification 2013-03-15 01:12:40 UTC
GergÅ Mocsi committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=59bc10eb4609c5729f46308becc5a3de893ac77e

fdo#38838, String to OUString, in dbaccess/source/ui/browser



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 43 Commit Notification 2013-03-15 01:29:39 UTC
GergÅ Mocsi committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bdc374eadf3c5b2a752eb5ce3cb346939b0fb77a

fdo#38838, String to OUString in dbaccess



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 44 Julien Nabet 2013-03-26 13:09:20 UTC
@all: Just FYI, according to http://opengrok.libreoffice.org/search?q=unistring&project=core&defs=&refs=&path=&hist=, there are very few Unistring remaining elements now. But it seems they won't be the easiest to remove. Also, is it possible some extensions use it?
Comment 45 Stephan Bergmann 2013-03-26 14:45:51 UTC
(In reply to comment #44)
> @all: Just FYI, according to
> http://opengrok.libreoffice.org/
> search?q=unistring&project=core&defs=&refs=&path=&hist=, there are very few
> Unistring remaining elements now. But it seems they won't be the easiest to
> remove. Also, is it possible some extensions use it?

No, extensions must not include tools/string.hxx nor link against the tl library.
Comment 46 Commit Notification 2013-04-02 16:31:23 UTC
elixir committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ff85b2c3d19136ea4d66f6555158e2a52da6e413

fdo#38838 : Replacement of String with OUString in core/chart2



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 47 Commit Notification 2013-05-20 03:41:49 UTC
Marcos Paulo committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5ef0015704ca67a8f9ffd8f4ae207be355da7f3e

fdo#38838 Replacement of the String with OUString



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 48 Commit Notification 2013-05-20 14:48:02 UTC
Marcos Paulo committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bbfc9999db281c02c4a79b49c86499ba52571002

fdo#38838 Replacement of the String with OUString



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 49 Caolán McNamara 2013-07-14 13:05:45 UTC
String::SearchAndReplaceAllAscii is now gone
Comment 50 Caolán McNamara 2013-07-14 19:06:35 UTC
String::ReplaceAscii is now also gone
Comment 51 Commit Notification 2013-08-10 20:57:51 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9891cb881b68d643bcae6160e2284be4728a3612

Related: fdo#38838 remove String::Equals(const sal_Unicode* ...)



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 52 Commit Notification 2013-08-16 13:05:06 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d69d6f4dc8eef7cd85929a2655c523d2f17263e0

Related: fdo#38838 ToInt64 and a EqualsIgnoreCaseAscii variant are now unused



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 53 Commit Notification 2013-08-27 09:37:06 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a720ff09d8ee03248865599a691314199925dbf8

Related: fdo#38838 AllocBuffer is now unused



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 54 Commit Notification 2013-08-30 10:53:18 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=74929bba736cc6cceed3c088e13f5952abb1bd2b

Related: fdo#38838 remove UniString::ToUpperAscii



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 55 Commit Notification 2013-09-08 14:05:34 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ce9c390e1a100921fd4300d6acb602b4af2b7003

Related: fdo#38838 String::ReleaseBufferAccess is now no more



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 56 Commit Notification 2013-09-08 19:59:27 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7fd6d43c1dae1548aca5ae4ed6d63cbf7e10b7ea

Related: fdo#38838 String::GetBufferAccess is now no more



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 57 Commit Notification 2013-09-08 19:59:50 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=02740cbe0a21939e3720b72a074ce71798e78d1d

Related: fdo#38838 drop String::EmptyString now as well



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 58 Commit Notification 2013-09-11 11:40:14 UTC
Thomas Arnhold committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4f702470a2c5f5521209203f0d20f768ef274d67

Related: fdo#38838 Remove String::SearchChar()



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 59 Commit Notification 2013-09-12 12:19:05 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d908422f5763ed8ea79af81336ca564f46435baf

Related: fdo#38838 remove XubString alias



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 60 Commit Notification 2013-09-13 14:31:06 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8b3cbc71151cf91a97e4c4340430876c8d02d030

Related: fdo#38838 remove UniString::ToLowerAscii



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 61 Commit Notification 2013-09-14 13:20:42 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5167539b10478cdb14d6690147d440d99ea05e83

Related: fdo#38838 one UniString::Search variant now unused



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 62 Commit Notification 2013-09-22 11:30:14 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=28c9207da43551059e283008225abfdfb4a988be

Related: fdo#38838 remove UniString::InsertAscii



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 63 Commit Notification 2013-09-22 19:38:36 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=81202ae7487b139cb473ff85634003b36d67e8c4

Related: fdo#38838 remove UniString::CompareIgnoreCaseToAscii



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 64 Commit Notification 2013-09-25 17:34:13 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=98de5b40c8a3fd4e57477b6d994e3b1472207f71

Related: fdo#38838 remove UniString::EqualsIgnoreCaseAscii



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 65 Commit Notification 2013-09-27 09:24:07 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b3a8056a499ca2a5cb809fcec52aebddd4e17f23

Related: fdo#38838 remove UniString::SearchBackward



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 66 Commit Notification 2013-09-30 10:11:34 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=64b720dce8d3087ed62da815ecae1375b45149be

Related: fdo#38838 remove UniString::SearchAscii



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 67 Commit Notification 2013-10-01 13:25:41 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d05a9ae25e4a397834330d868b68d92ca919e33b

Related: fdo#38838 remove UniString::AssignAscii



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 68 Björn Michaelsen 2013-10-04 18:46:48 UTC
adding LibreOffice developer list as CC to unresolved EasyHacks for better visibility.

see e.g. http://nabble.documentfoundation.org/minutes-of-ESC-call-td4076214.html for details
Comment 69 Commit Notification 2013-10-07 10:55:21 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b8cf30e93f18ddc16fd648976a41a6bbb6c6d8b2

Related: fdo#38838 remove UniString::SearchAndReplaceAscii



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 70 Commit Notification 2013-10-08 13:13:44 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=832e5aadbff006ec24959162c29756fe2b1982be

Related: fdo#38838 remove UniString::SearchAndReplaceAll



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 71 Commit Notification 2013-10-09 12:30:47 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5089bdb234a93bcb62b597c18b8ab66048246b13

Related: fdo#38838 remove UniString::EqualsAscii



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 72 Commit Notification 2013-10-09 16:10:50 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ae95703819348938bf9e44bd635365e3e48cd05d

Related: fdo#38838 remove UniString::SetToken & UniString::SearchAscii



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 73 Commit Notification 2013-10-14 11:12:15 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7e7a487e904143cbc282a2b90c4cb3918bfa151f

Related: fdo#38838 remove UniString::AppendAscii



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 74 Commit Notification 2013-10-14 11:23:57 UTC
Chr. Rossmanith committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9e208f28255eab69ee2ef372df90b1b636d97e0a

fdo#38838 use OUString instead of String



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 75 Commit Notification 2013-10-14 12:01:33 UTC
Chr. Rossmanith committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=646ce81d1c1623feb5414cd248860b143fd2cd6b

fdo#38838 use OUString instead of String



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 76 Commit Notification 2013-10-16 11:13:25 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=255cfbbeaa090fd7a06130e2b621cb27ae9baca4

Related: fdo#38838 remove unused String::Append varients



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 77 Commit Notification 2013-10-17 08:28:34 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c975d6b751c48471d413b2e15ccb86e742e9e231

Related: fdo#38838 remove String::CompareToAscii



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 78 Commit Notification 2013-10-17 13:30:53 UTC
Thomas Arnhold committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c65eb7e56934b22f9bea68e62c0a51fd59869f1c

Related: fdo#38838 remove String::SearchAndReplace



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 79 Commit Notification 2013-10-17 16:10:16 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d1563b818d335495a5591f5fd491fee77b47c93d

Related: fdo#38838 make String::CompareTo private



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 80 Commit Notification 2013-10-18 10:22:05 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=13f383ac919acb36f54c5cf211954a8c032837b4

Related: fdo#38838 remove String::GetToken



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 81 Commit Notification 2013-10-18 15:39:44 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fdf85819c33abe5a81d19a94b3bac0800b6cda30

Related: fdo#38838 remove String::Match



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 82 Commit Notification 2013-10-18 19:41:56 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5712a06f2c6f0616df777053242803c3723bc743

Related: fdo#38838 make String::Erase private



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 83 Commit Notification 2013-10-19 13:32:29 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f2bdfdb2952b4ef6064be65130242fbabb71f885

Related: fdo#38838 remove String::Replace



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 84 Commit Notification 2013-10-19 18:27:03 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a6cdf1b2f638800318e0b8789bd991e04eef5cf5

Related: fdo#38838 remove String::Search



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 85 Commit Notification 2013-10-20 11:11:09 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=35373db02976efff7f640b477d07825e96c6b5a4

Related: fdo#38838 remove String::Assign(const sal_Unicode*)



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 86 Commit Notification 2013-10-20 14:04:36 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f8d5bd07053d27d4c6546141e61d8da25e44cc24

Related: fdo#38838 remove operator=(const sal_Unicode*)



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 87 Commit Notification 2013-10-20 18:07:30 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b0fd64b2fa7ae1fd8d435c64b7b69758e98e8926

Related: fdo#38838 remove the unused String::Insert



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 88 Commit Notification 2013-10-20 18:07:52 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8bb4b18127cdc6259ecd65ec0f28d27d0513cb26

Related: fdo#38838 remove String::Equals



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 89 Commit Notification 2013-10-21 08:27:18 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9be876cd067cf95338e719645c7f3025757d5563

Related: fdo#38838 remove non OUString ::Append



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 90 Commit Notification 2013-10-21 08:27:45 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3714051f1495791095cce885918d48dce7b339f7

Related: fdo#38838 remove String::[G|S]etChar



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 91 Commit Notification 2013-10-21 08:28:07 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9e6917c21e8a2fa5c40adeddafdaf704a67aef4a

Related: fdo#38838 remove String::ToInt32



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 92 Commit Notification 2013-10-21 08:28:29 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=48bb54aa7eafa85c5b0a2574fb3fa167614ddcbc

Related: fdo#38838 remove String::Insert



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 93 Commit Notification 2013-10-21 10:35:18 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d486b2b324364dd99bea686b6969f7a796f5e329

Related: fdo#38838 remove/privatize String::Append



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 94 Commit Notification 2013-10-21 13:36:08 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6e03e292e5e887053dfd7746d6f9df12abc0bab7

Related: fdo#38838 remove a pile of ctors



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 95 Commit Notification 2013-10-21 18:39:28 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cfda947d7c0476b9c402c84f9d8515c76ec87bac

Related: fdo#38838 remove UniString::Copy



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 96 Commit Notification 2013-10-22 08:27:54 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b2e954e300f51120387a55bf237cafdcd40ed7e6

Related: fdo#38838 remove UniString::UniString(const ResId&)



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 97 Commit Notification 2013-10-22 12:03:15 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b37e2dd071c83454b3b06c0959a76b6012f53abb

Resolves: fdo#38838 remove UniString



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 98 Robinson Tryon (qubit) 2015-12-15 22:50:17 UTC
Migrating Whiteboard tags to Keywords: (EasyHack DifficultyBeginner SkillCpp TopicCleanup )
[NinjaEdit]
Comment 99 Robinson Tryon (qubit) 2016-02-18 16:37:15 UTC
Remove LibreOffice Dev List from CC on EasyHacks
(curtailing excessive email to list)
[NinjaEdit]