Download it now!
Bug 38892 - Insert 32x64 table hangs Impress
Summary: Insert 32x64 table hangs Impress
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: x86-64 (AMD64) Windows (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 41671 (view as bug list)
Depends on:
Blocks: ImpressDraw-Tables
  Show dependency treegraph
 
Reported: 2011-07-01 09:44 UTC by allen
Modified: 2017-06-04 22:46 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
hang screenshot (258.70 KB, application/pdf)
2013-06-05 16:56 UTC, allen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description allen 2011-07-01 09:44:36 UTC
Working with 3 slide document, repeatedly try insert large table causes app to hang indefinitely.
Comment 1 Rainer Bielefeld Retired 2011-07-01 11:00:09 UTC
I don't believe that such tables will be used very often, but indeed, "LibreOffice 3.4.1RC1 - WIN7  Home Premium (64bit) German UI [OOO340m1 (Build:103)]" becomes unusable slow when I try to insert such a table, even on the first page as only element. And WIN7 will not close such a document (I waited 5 minutes).

In DRAW I see the same problem, but it seems to work a little better

@Radek:
Please feel free to reassign if it’s not your area!
Comment 2 Björn Michaelsen 2011-12-23 13:25:11 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.
Comment 3 Rainer Bielefeld Retired 2012-04-26 21:16:11 UTC
Same with DRAW, and it's even worse with "LibreOffice 3.5.3.2 (RC2) German UI/Locale [Build-ID: 235ab8a-3802056-4a8fed3-2d66ea8-e241b80] on German WIN7 Home Premium (64bit).

No progress with parallel  installation of  Master "LOdev 3.6.0alpha0+  – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 8a78020]" (tinderbox: Win-x86@6-fast pull time 2012-04-18 23:51:20)
Comment 4 Rainer Bielefeld Retired 2012-04-26 21:20:40 UTC
*** Bug 41671 has been marked as a duplicate of this bug. ***
Comment 5 ign_christian 2013-06-05 16:02:18 UTC
This bug has not been touched by for a long time. 
Just confirming, is this bug still ASSIGNED?
Comment 6 allen 2013-06-05 16:56:37 UTC
Created attachment 80360 [details]
hang screenshot

Version 4.0.3.3 (Build ID: 0eaa50a932c8f2199a615e1eb30f7ac74279539)
Comment 7 allen 2013-06-05 16:57:52 UTC
Verified problem still exists

Version 4.0.3.3 (Build ID: 0eaa50a932c8f2199a615e1eb30f7ac74279539)

Specifically, now I was able to insert the table, move it around, but could not resize it.

Was able to delete it.  Then created 64x32 table, couldn't resize it, and eventually impress hung after trying to move table (screen shot attached, not very helpful).
Comment 8 ign_christian 2013-06-06 02:25:43 UTC
I think you should attach presentation file & explain how to see the problem so anyone here could test.
Comment 9 Mikko Ahlroth 2013-09-25 08:31:03 UTC
(In reply to comment #8)
> I think you should attach presentation file & explain how to see the problem
> so anyone here could test.

This bug is related to bug 50762, I think. You can test it by creating an empty presentation in Impress, creating a 20x20 table and trying to do something with it (move it, change table style, resize it). Everything is *very* slow. Even slightly large tables are basically unusable in Impress currently.
Comment 10 Thomas Lendo 2017-06-04 22:46:49 UTC
Closing as WORKSFORME.

Tested with a new Impress file and 32x64 cell big tables in 2 slides. Can work with it, it's not very fast to edit the tables but it's not unusable or too laggy. Impress doesn't hang.

Version: 5.5.0.0.alpha0+

Feel free to reopen it if there are program hangs.