Bug 39080 - Hide white space between pages in 'print layout'
Summary: Hide white space between pages in 'print layout'
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: high enhancement
Assignee: Ashod Nakashian
QA Contact:
URL:
Whiteboard: target:5.1.0
Keywords:
: 37149 37967 63528 64851 (view as bug list)
Depends on: 108335
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-08 14:24 UTC by Nick
Modified: 2017-06-04 13:07 UTC (History)
15 users (show)

See Also:
Crash report or crash signature:


Attachments
MS-Word setting to make white-space removal the default view (56.04 KB, image/png)
2012-02-17 09:00 UTC, Cade
Details
screen shot old situation (6.81 KB, image/png)
2015-12-15 12:48 UTC, Cor Nouws
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nick 2011-07-08 14:24:31 UTC
When writing documents in Writer's "Print Layout," gaps appear between the bottom of one page and the top of the next page. In Microsoft Word, clicking on the end of one of these pages pulls them together, allowing the writer/reader to see a seamless page. This helps the flow of reading and writing and allows more information to fit on screens that don't have a lot of vertical space (e.g., netbooks). I'd sure like to see this capability added to LibreOffice. The feature's absence makes writing in LibreOffice Writer a chore compared to Microsoft Word. 

I posted an image to help illustrate what I'm describing at imgur here:  http://imgur.com/a/c0dgx
Comment 1 Christoph 2011-07-16 07:04:15 UTC
Changed according discussion on design list:
http://www.mail-archive.com/design@global.libreoffice.org/msg02687.html

The better approach (UX wise) is to provide a so called draft view in Writer. The draft view aims to hide all print layout "paper" specific elements that disturb when focusing on writing. This draft view is related (but not identical) to an outline view.

In a nutshell, the draft view is:
* very similar to the web view, but ..
* the width of the content is the same as in the "print layout"
* markups show page breaks / border breaks / ...

@ Björn: Are parts of this suitable to be solved as easy hacks? (Document model changes, ...)

UX contact: Christoph Noack
Comment 2 Rich Beaulaurier 2011-10-04 08:21:19 UTC
I posted a similar request (#37149) in April. My post was also a repeat (referenced there)... I would not have anything against Christoph's suggestion UNLESS doing something bigger interferes with getting the "hide white space" feature, ASAP.  (MS Word calls this feature "hide white space"). This has been a request, as far as I can tell since Open Office first appeared. REALLY needed feature, especially as laptops and net books keep squeezing the screen smaller on the vertical. REALLY hope this can be a priority.
Comment 3 Björn Michaelsen 2011-12-23 12:25:35 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 4 William 2012-01-14 05:40:53 UTC
I'd like to see this feature implemented as well. 

I agree with "Rich Beaulaurier" and hope LibreOffice developers make implementation of this a PRIORITY. It dramatically improves the user's experience of LibreOffice Writer.
Comment 5 William 2012-01-14 05:47:35 UTC
Here's a link to the Microsoft Office description of what we are asking for:  https://office.microsoft.com/en-us/word-help/show-or-hide-white-space-in-print-layout-view-HP003072013.aspx
Comment 6 Cade 2012-02-17 09:00:57 UTC
Created attachment 57217 [details]
MS-Word setting to make white-space removal the default view

@Christoph Noack

Christoph, you said: "Microsoft changed the behavior from 2003 to 2007 and
made this feature "more hidden". I assume they wanted to completely
remove it, but feared the feedback by the existing user base."

This is not true. There were never plans to remove it; the feature is a well regarded feature. I don't know about Word 2007, but Word 2010 has made this feature even more prominent & powerful by adding a setting under File > Options that allows users to make it the default Print Layout view. I attached a photo showing the setting.

LO Writer needs a setting to make its Print Layout view automatically hide white space between pages. Be nice to see this setting added to Writer in the next Libre Office release!
Comment 7 Christoph 2012-02-19 14:24:40 UTC
(In reply to comment #6)
> Created attachment 57217 [details]
> MS-Word setting to make white-space removal the default view
> 
> @Christoph Noack
> 
> Christoph, you said: "Microsoft changed the behavior from 2003 to 2007 and
> made this feature "more hidden". I assume they wanted to completely
> remove it, but feared the feedback by the existing user base."
> 
> This is not true. There were never plans to remove it; the feature is a well regarded feature. I don't know about Word 2007, but Word 2010 has made this
> feature even more prominent & powerful by adding a setting under File > Options that allows users to make it the default Print Layout view. I attached a photo
> showing the setting.

Thanks for the file! Some details: From 2003 to 2007, MS changed the "single click" to a "double click" to enable / disable the header/footer area. But, the mousover still suggest that "single click" works. So this is clearly a UI bug. The options page you are referring to is required to a) make the feature more accessible to non-mouse users, and b) help people who don't know about this feature how to get back the white space. Finally, it also enables users to enable / disable it - as you said. This option is also available in MSO 2007.

> LO Writer needs a setting to make its Print Layout view automatically hide white space between pages. Be nice to see this setting added to Writer in the next
> Libre Office release!

Again, I think users will benefit even more if we deliver a good draft view that provides clear separation between different view modes. MS even offers a "symptoms" description for "lost users":
http://office.microsoft.com/en-us/word-help/my-top-margin-is-missing-HP010024038.aspx

(If we need more discussion, we should switch from the issue tracker to the design list, I think...)
Comment 8 William 2012-02-20 14:11:17 UTC
Christoph,

How long until this new draft-view that hides white-space lands in LO-Writer? 

The only thing keeping me on Microsoft Office Word at this point is the fact that it can hide white-space between pages. It is an incredibly important usability feature for a word processor to have. 

Will you please advocate for this feature so that its development can be made a top priority in LO-Writer?
Comment 9 Mark B. 2012-05-07 11:56:30 UTC
When is this going to be fixed? This is ridiculous that this hasn't been fixed yet!

This "bug fix" has been requested by lots of people for a long time. Can addressing this PLEASE be made a top priority by LibreOffice Developers? Please fix this soon!

I did a 2 minutes search and found tons of people asking for this feature. Here's a few links that show how this is a highly requested feature-request:

http://nabble.documentfoundation.org/hide-white-space-td3044835.html

http://www.oooforum.org/forum/viewtopic.phtml?t=61615

https://bugs.freedesktop.org/show_bug.cgi?id=37149
Comment 10 Rich Beaulaurier 2012-05-08 12:48:19 UTC
This is essentially the same bug as in 37149. I find requests for this feature going back for years. Hope we can get it soon!
Comment 11 Timur 2012-07-25 12:13:45 UTC
*** Bug 37149 has been marked as a duplicate of this bug. ***
Comment 12 Greg 2012-12-24 01:40:44 UTC
I would also love to see this feature implemented.

I would say that this feature is most important to me. Please don't forget about this feature request.
Comment 13 Urmas 2012-12-24 11:33:18 UTC
There are no developers competent enough to make such changes left, and it is unlikely that they will appear now when Oracle kicked that product out.
Comment 14 Björn Michaelsen 2012-12-26 22:13:35 UTC
Multiple clarifications on this:
- This is not an easyhack -- or only a very hard one. It has likely the scale of a small GSOC project (writer layout/view modifications plus general UI changes make it nontrivial)
- Please note this is an enhancement, not a bug fix. For bug fixes we encourage and invite users to point out the most glaring ones to be fixed quickly as it is a priority for all contributors and users. For enhancement requests (which are existing in abundance for a wide range of ideas), once mark with a HIGH importance, endusers can for example help out in the following ways:
-- buy support from one of those packaging LibreOffice or supporting it otherwise and escalating the issue there
-- sponsor a developer directly
-- motivate, set up and support an existing developer to mentor the implementation in a GSOC
-- possible more ways I forgot

There is NO lack of competence(*) to solve this issue. That is absolute nonsense. It is just quite a bit of work that needs a volunteer or a sponsor.

Please refrain from 'I want this too'-comments, unless you found a way to sponsor the work. Apart from that the issue is currently marked HIGH/ENHANCEMENT, so there is really no need to further drive that point.

Note none of this means that this isnt an important enhancement that would not be valuable to add, just that there are others (and esp. bugfixes) that are even more important.

As the discussion of "how to sponsor an enhancement" is not specific to this issue, please do not continue to discuss it here, but on the mailing lists (where it is helpful to the general public).



(*) commenter used to work at Oracle btw (as the linked bugs opened in 2008 and 2002 show it didnt enjoy exactly priority there too)
Comment 15 Rich Beaulaurier 2013-03-22 17:45:31 UTC
OK, I understand that this is not easy or trivial. I also understand that it's not a bug fix and that this may not be the proper place for discussion. 

I am an enduser, not a particularly wealthy one, and not a programmer. So...

Could you say a little more about how endusers can help. I think it might also be useful to suggest a link or two to "where." 

Specifically:

Where do you buy support? How do you support or escalate the issue there?

Where can developers be found with an interest?

Who might be motivated to support/mentor at GSOC?

Not asking for anything lengthy...just a nudge in the right direction ;-)
Comment 16 bugquestcontri 2013-03-22 23:47:31 UTC
The "hide white space" is definitely a good one. However, it would be nice to combine the development of this feature with the request to have also "normal view" like in Word. (https://bugs.freedesktop.org/show_bug.cgi?id=37967)


@Rich Beaulaurier - I hope you get good answers.
Comment 17 Greg 2013-04-22 12:50:55 UTC
the "hide white space" feature is being asked for in Comment 1 of the 37967 bug you linked. And commenter states the original request dates back to OpenOffice in 2002. Wow!

I'm really looking forward to being able to make use "hide white space" in Writer. I hope developers can find a way to implement this soon.
Comment 18 Walter 2013-11-05 11:12:16 UTC
When is this bug going to be addressed? How many more years are we going to have to wait to have this resolved?

This thing has been asked for for over a decade now. This isn't some trivial bug. This literally makes the Writer software unusable for numerous people operating on smaller screens. This bug alone is keeping many people on Microsoft Word for crying out loud.

Any chance this bug can get assigned for resolution NOW?
Comment 19 Walter 2013-11-05 11:15:06 UTC
*** Bug 63528 has been marked as a duplicate of this bug. ***
Comment 20 Khaled Hosny 2013-11-05 11:23:18 UTC
(In reply to comment #18)
> When is this bug going to be addressed? How many more years are we going to
> have to wait to have this resolved?
> 
> This thing has been asked for for over a decade now. This isn't some trivial
> bug. This literally makes the Writer software unusable for numerous people
> operating on smaller screens. This bug alone is keeping many people on
> Microsoft Word for crying out loud.
> 
> Any chance this bug can get assigned for resolution NOW?

See comment 14 above.
Comment 21 nushoin 2014-01-21 13:09:31 UTC
'Normal view', 'No space between pages in Print View' and 'Draft mode' are 3 different issues. Please do not assume that adding one of them solves the others.
Comment 22 Yousuf Philips (jay) 2015-04-27 13:39:18 UTC
Returning this bug back to its original enhancement request. I believe achieving this enhancement is alot easier than implementing what MSO refers to as 'Draft View', which was the default view in MS Word 2003 and prior. There is a draft view enhancement bug report in bug 67698.

This is a feature that i currently use in Google Docs, which saves me from having to scroll as much, and find it quite useful. I like to call this 'Continuous View'.
Comment 23 Commit Notification 2015-08-17 12:24:10 UTC
Ashod Nakashian committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3e3c5369e87066a4bfdead5fc9dbfe128f84df52

tdf#39080 Added HideWhitespaceMode ViewOption flag

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 24 Commit Notification 2015-08-17 12:37:22 UTC
Ashod Nakashian committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=17ac8354c97e107712d3ad59ab3140a8d0d3b78c

tdf#39080 Hide vertical whitespace when HideWhitespace option is set.

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 25 Commit Notification 2015-08-17 12:39:42 UTC
Ashod Nakashian committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2c346d669648bdecbe4be0e6013af14abef2526a

tdf#39080 Hide Whitespace UI option added to the View menu.

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 26 Ashod Nakashian 2015-08-18 14:05:09 UTC
There is unittest regression pending fix due to this feature. The last patch isn't committed yet. Please wait for the before testing this feature.
Comment 27 Jean-Baptiste Faure 2015-08-20 04:48:02 UTC
(In reply to Ashod Nakashian from comment #26)
> There is unittest regression pending fix due to this feature. The last patch
> isn't committed yet. Please wait for the before testing this feature.

This option is available in my last build from last night:
Version: 5.1.0.0.alpha1+
Build ID: f15cbf2451d08ccddde9643c9f926a322f9f9917

but seems to do nothing. Do I miss something?

Best regards. JBF
Comment 28 Ashod Nakashian 2015-08-20 12:29:02 UTC
(In reply to Jean-Baptiste Faure from comment #27)
> (In reply to Ashod Nakashian from comment #26)
> > There is unittest regression pending fix due to this feature. The last patch
> > isn't committed yet. Please wait for the before testing this feature.
> 
> This option is available in my last build from last night:
> Version: 5.1.0.0.alpha1+
> Build ID: f15cbf2451d08ccddde9643c9f926a322f9f9917
> 
> but seems to do nothing. Do I miss something?
> 
> Best regards. JBF

The last patch[*] is still pending review. It hooks UI to functionality, so is critical for this feature. Hopefully it'll get committed soon.

Thanks.

[*] https://gerrit.libreoffice.org/#/c/17281/
Comment 29 Ashod Nakashian 2015-08-20 16:10:36 UTC
JBF, do you know who typically reviews similar features? It might be more efficient to add reviewers individually than to wait for someone to notice.
Comment 30 Jean-Baptiste Faure 2015-08-20 18:20:06 UTC
(In reply to Ashod Nakashian from comment #29)
> JBF, do you know who typically reviews similar features? It might be more
> efficient to add reviewers individually than to wait for someone to notice.

No, I came here by chance, I was intrigued by this enhancement request found in a comparison between LO and MSO.
That said you can ask for tests on the QA mailing list.
I will try to test your pending patch.

Best regards. JBF
Comment 31 Ashod Nakashian 2015-08-20 18:24:32 UTC
(In reply to Jean-Baptiste Faure from comment #30)
> (In reply to Ashod Nakashian from comment #29)
> > JBF, do you know who typically reviews similar features? It might be more
> > efficient to add reviewers individually than to wait for someone to notice.
> 
> No, I came here by chance, I was intrigued by this enhancement request found
> in a comparison between LO and MSO.
> That said you can ask for tests on the QA mailing list.
> I will try to test your pending patch.
> 
> Best regards. JBF

Thanks, would be great to have feedback to improve it. Please keep me updated.
Comment 32 Yousuf Philips (jay) 2015-08-20 23:58:44 UTC
(In reply to Ashod Nakashian from comment #29)
> JBF, do you know who typically reviews similar features? It might be more
> efficient to add reviewers individually than to wait for someone to notice.

I normally review enhancements that i'm CCed in the bug report to make sure they work and set them to VERIFIED once i've done so, so i'll review it once the final patch is in if my build doesnt finish before its added. :D
Comment 33 Ashod Nakashian 2015-08-21 00:57:44 UTC
(In reply to Yousuf (Jay) Philips from comment #32)
> (In reply to Ashod Nakashian from comment #29)
> > JBF, do you know who typically reviews similar features? It might be more
> > efficient to add reviewers individually than to wait for someone to notice.
> 
> I normally review enhancements that i'm CCed in the bug report to make sure
> they work and set them to VERIFIED once i've done so, so i'll review it once
> the final patch is in if my build doesnt finish before its added. :D

Thanks! Just added you to the patch.
Comment 34 Commit Notification 2015-09-03 08:46:02 UTC
Ashod Nakashian committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2b8e62f7b6e0a45a9ff1ec530b2e941f3fbcf1a0

tdf#39080 Hide white space between pages in 'print layout'

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 35 Laurent BP 2015-09-12 15:13:02 UTC
*** Bug 64851 has been marked as a duplicate of this bug. ***
Comment 36 Laurent BP 2015-09-12 15:47:34 UTC
Hello,

Thanks for this feature :)
I added two requests for enhancement:
- bug 94164: adapt page height to remove whitespace in case of manual page break
- bug 94165: adapt page width to keep the same page numbers
Comment 37 Yousuf Philips (jay) 2015-09-12 17:53:27 UTC
(In reply to Laurent BP from comment #36)
> I added two requests for enhancement:
> - bug 94164: adapt page height to remove whitespace in case of manual page
> break
> - bug 94165: adapt page width to keep the same page numbers

I reported both issues to Ashod in the gerrit entry. :D
Comment 38 Commit Notification 2015-10-01 09:34:42 UTC
Ashod Nakashian committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=54a2c8c006e2f216e9d8c6b0ed625180c843c48b

tdf#39080 Interactive hide-whitespace mode

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 39 GavinB 2015-10-29 20:16:28 UTC
Testing using
http://dev-builds.libreoffice.org/pre-releases/win/x86_64/LibreOfficeDev_5.1.0.0.alpha1_Win_x64.msi

Is this a bug:

1. I start a new document in Writer

2. I go into print layout mode

3. I add content + newline until two pages are visible

4. I hover the mouse over the gap between pages until I see a little white bar

5. I click on the bar - and the White space gets Hidden (yes!)

6. I save the file as ODT

7. I close LibreOffice - then I reopen  the ODT file in Writer and make sure I am in print layout mode again.

8. I hover the mouse over the gap between pages but this time I see NO little white bar. BUG ?
Comment 40 Ashod Nakashian 2015-10-30 02:36:40 UTC
(In reply to GavinB from comment #39)
> Testing using
> http://dev-builds.libreoffice.org/pre-releases/win/x86_64/LibreOfficeDev_5.1.
> 0.0.alpha1_Win_x64.msi
> 

Can you please try with x86 (32-bit) version and see if you can reproduce?

> Is this a bug:
> 
> 1. I start a new document in Writer
> 
> 2. I go into print layout mode

You mean View > Normal menu is checked and single-page view is selected? Anything else of relevance to reproduce?

> 
> 3. I add content + newline until two pages are visible
> 
> 4. I hover the mouse over the gap between pages until I see a little white
> bar

You mean the mouse pointer turning into a white bar with two arrows on top and bottom? If yes, it's part of this feature to signal that double-clicking will enable/disable Hide Whitespace mode.

> 
> 5. I click on the bar - and the White space gets Hidden (yes!)

Yes! This is the feature that this entry is addressing. It's an old one but I managed to have a go at it. Still raw and can do with all the testing/help we can afford to give it.

You can enable/disable the Hide Whitespace mode from View > Hide Whitespace menu or by double-clicking between pages in single-page view.

> 
> 6. I save the file as ODT
> 
> 7. I close LibreOffice - then I reopen  the ODT file in Writer and make sure
> I am in print layout mode again.

I'm assuming you exited LO altogether (File > Exit) and didn't just File > Close. In that case, your report is really interesting, as Writer doesn't store the Hide Whitespace state in the file or in configuration when you exit.

> 
> 8. I hover the mouse over the gap between pages but this time I see NO
> little white bar. BUG ?

Can you please share a screenshot of exactly what you see? 

Thanks.
Comment 41 GavinB 2015-10-30 06:25:15 UTC
Please ignore my previous bug report.

My error was I was unknowingly reopening the file with v5.02
and not with v5.1.

Everything works fine as advertised
Works also with win32 version.

Thanks guys - sorry for the bother.
Keep up the great work.
Comment 42 Commit Notification 2015-11-10 11:54:20 UTC
Ashod Nakashian committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=40f3a942448facb900b422d30f64b75d7cac7f0f

tdf#39080 Hide Whitespace improvements

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 43 Cor Nouws 2015-12-15 10:15:19 UTC
tested in Version: 5.2.0.0.alpha0+
Build ID: 87c9465262680dec09efb869800859aa65ab1d19
CPU Threads: 2; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86@71-TDF, Branch:master, Time: 2015-12-15_07:19:23
Locale: nl-NL (nl_NL.UTF-8)

Nice - thanks a lot Ashod!

Question: when I have a header/footer in the file, previously hovering the white space would show a dotted blue line and a control to edit or remove. Now it does not. Has this been changed or planned too?
(I see no difference in using Shft / Ctrl / Alt..)

Cheers - Cor
Comment 44 Ashod Nakashian 2015-12-15 12:34:41 UTC
(In reply to Cor Nouws from comment #43)
> 
> Nice - thanks a lot Ashod!

Glad it's useful.

> 
> Question: when I have a header/footer in the file, previously hovering the
> white space would show a dotted blue line and a control to edit or remove.
> Now it does not. Has this been changed or planned too?
> (I see no difference in using Shft / Ctrl / Alt..)

The controls come with the header/footer, as such in this mode they will be hidden along with the hidden header/footer. Also, it'd be overcrowded (and potentially confusing) to have them right on the edge of the page. To edit them one would need to go out of the 'hide whitespace mode'. There is a convenient 'double-click between pages' function to do this, so it shouldn't be much hassle to the users.

Of course suggestions to improve are welcome.
Comment 45 Cor Nouws 2015-12-15 12:48:52 UTC
Created attachment 121315 [details]
screen shot old situation

Hi Ashod,

In the old situation there is a widget, that is not visible now, also when the white space is not hidden. (anyway, I don't see it)
Comment 46 Ashod Nakashian 2015-12-15 22:30:26 UTC
(In reply to Cor Nouws from comment #45)
> In the old situation there is a widget, that is not visible now, also when
> the white space is not hidden. (anyway, I don't see it)

There could be a regression since my commit. Or are you saying you see this directly caused by my commit? I do remember testing for this and it was working when whitespace was no hidden (the control allowed for removing footer/header).
Comment 47 Jean-Baptiste Faure 2016-01-05 14:31:08 UTC
*** Bug 37967 has been marked as a duplicate of this bug. ***