Download it now!
Bug 39204 - File->Export does not remember previous settings
Summary: File->Export does not remember previous settings
Status: RESOLVED DUPLICATE of bug 56899
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: eRiC
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-13 12:59 UTC by Jonas Thedering
Modified: 2016-06-22 08:07 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
What I see after exporting Selection and EPS (340.89 KB, image/png)
2011-07-14 18:53 UTC, Jeffrey
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jonas Thedering 2011-07-13 12:59:42 UTC
To reproduce:
- Open drawing in Draw
- Select part of the drawing
- Select File->Export
- Use file format EPS, activate "Selection"
- Press Export, then OK

- Then open File->Export again
All previously done settings are lost (EPS, Selection, path).

This worked with OpenOffice 3.2.0 and was then broken in 3.2.1. It has remained that way until now (tested LibreOffice 3.4.1). It happens with native and LibreOffice file dialogs. It also happens in Writer and Calc.

Interestingly, the settings are in fact saved to the property SdExportLastFilter etc. in $HOME/.libreoffice/3/user/registrymodifications.xcu . But for some reason the information isn't used when the dialog is being opened again.
Comment 1 Jeffrey 2011-07-14 18:51:16 UTC
Failed to reproduce on LibreOffice 3.4  340m1(Build:103) for OpenSuse Linux.

I think I have managed to successfully export an EPS image. The selected picture comes out as black and white. Here is the attachment. I think the export was successful. Perhaps you could provide an attachment as well to better demonstrate the expected behavior? Thanks.
Comment 2 Jeffrey 2011-07-14 18:53:21 UTC
Created attachment 49110 [details]
What I see after exporting Selection and EPS

And if this is indeed a problem, it would be great to mark the bug as a regression.
Comment 3 Jonas Thedering 2011-07-15 06:51:29 UTC
Maybe I have not stated the problem clearly enough. The problem is not that the export does not work, but that the export settings are not remembered between subsequent invocations of File->Export.

After you exported the EPS, you enter the File->Export dialog again. In OpenOffice >= 3.2.1 and in LibreOffice, the file format will be reset to the default value (e.g. EMF in LibreOffice 3.4.1) and the checkbox "Selection" will be disabled again.

In OpenOffice 3.2.0 it is the case that the file format of the last export is remembered, so that EPS will already be selected and "Selection" will already be checked when the dialog is reentered.
Comment 4 Björn Michaelsen 2011-12-23 12:28:11 UTC Comment hidden (obsolete)
Comment 5 Jonas Thedering 2011-12-25 17:20:35 UTC
I can confirm that the bug still persists in 3.5.0 beta 2.
Comment 6 Anastasius 2012-11-06 11:02:57 UTC
Bug still exists in LibreOffice 3.5.6.2 (OS-X 10.6.8). It is a nuisance when using 'Export' a lot!
Comment 7 Anastasius 2012-11-06 11:03:19 UTC
Bug confirmed with LibreOffice 3.5.6.2 (OS-X 10.6.8). It is a nuisance when using 'Export' a lot!
Comment 8 Anastasius 2012-11-27 11:20:38 UTC
Bug still present in LibreOffice 3.6.3.2 (Mac OS X). (sorry for duplicate submission of comfirmation in 3.5.6.2!)
Comment 9 Valdas 2013-05-03 12:00:26 UTC
Tested LibO v4.0.2.2 (Build ID: 400m0(Build:2)) in KUbuntu 12.10 64bit: bug still there.
Comment 10 Anastasius 2014-03-26 19:10:16 UTC
Bug still present in LO 4.2.2.1 (Mac OS X 10.6.8)
Comment 11 eRiC 2014-06-01 10:39:05 UTC
I would like to squash this bug as my first contribution to LibreOffice. Any objections?
Comment 12 crxssi 2014-06-01 13:06:33 UTC
(In reply to comment #11)
> I would like to squash this bug as my first contribution to LibreOffice. Any
> objections?

I don't see why anyone would object.  Everyone has to start somewhere and with something.... this bug/enhancement is a good one to start with, since it should be easy.

I am not sure if it is absolutely necessary to remember the settings across sessions (saving in a preference/settings file), but it certainly would be extremely nice if it at least remembered settings within the same session.  Both would be even better.

I can't tell you how many times I have cursed at LO when working on a project that required me to export dozens of things...
Comment 13 QA Administrators 2015-06-08 14:42:00 UTC Comment hidden (obsolete)
Comment 14 Valdas 2015-06-08 17:31:37 UTC
Bug still exist in 4.4.3.2 (Kubuntu 14.04.2 LTS).
Comment 15 Heiko Tietze 2016-06-22 08:07:22 UTC

*** This bug has been marked as a duplicate of bug 56899 ***