Bug 39217 - EDITING: Undo ignores pictures after Copy / Paste from Browser
Summary: EDITING: Undo ignores pictures after Copy / Paste from Browser
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 44340 72247 (view as bug list)
Depends on:
Blocks: Calc-Images Undo-Redo
  Show dependency treegraph
 
Reported: 2011-07-13 23:37 UTC by Rainer Bielefeld Retired
Modified: 2018-07-31 17:06 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-07-13 23:37:50 UTC
I found this with Seamonkey browser and "LibreOffice 3.4.1  - WIN7  Home Premium (64bit) German UI [OOO340m1 (Build:103)]" during my investigations for "Bug 39208 - Crash while pasting into spreadsheet".

Steps to reproduce:
1. Open new spreadsheet
2. go to <http://www.bcferries.com/schedules/southern/vade-current.html> 
   with browser
3. In table with yellow heading "Tsawwassen to Mayne Island (Village Bay)"
   Mark table contents starting with word "Leave", ending with time stamp 
   "9:30 PM" (click in front of "Leave" and move mouse pointer with
    pushed left button behind "9:30 PM".
4. <cntrl+c>
5. switch to spreadsheet 
6. click 'A1'
7. <cntrl+v>
   Table contents with vessel images appears
8. Click 'Undo' icon
   Expected: all contents disappears
   Actual: vessel images remain.

I also see the problem with images from other tables in the Web.

Undo works fine in WRITER.

CONFIRMED because [Reproducible] with "LibO-dev 3.4.5  – WIN7  Home Premium  (64bit) English UI 
[(Build ID:d337f79-a24c961-2865670-9752b71-7f8fd43
	2fdd60d-fd28b6a-fd7bf20-aa369cb-28da3fb
	6a9633a-931d089-ecd263f-c9b55e9-b31b807
	82ff335-599f7e9-bc6a545-1926fdf)]"

@Kohei:
Please feel free to reassign if it’s not your area or if provided information is not sufficient.
Comment 1 noname 2011-07-14 13:12:17 UTC
Another side effect is that you can't remove the pics that easy.
For example do:

1) Select the cells that have the pictures.
2) Press 'del' to get the 'delete contents' window.
3) Select 'delete all' and press ok.

Nothing happens, the pics are still there. To get rid of them:

4) Select CTRL-A
5) Press 'del' to get the 'delete contents' window.
6) Select 'delete all' and press ok.
Comment 2 Rainer Bielefeld Retired 2011-09-06 12:07:17 UTC
Same problem with "LibreOffice 3.4.3 RC2 - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:302)]" and with "LibreOffice Portable 3.3.3  - WIN7  Home Premium (64bit) German UI [OOO330m19 (Build:301  Tag 3.3.3.1)]" 

So not a regression.

Modified Version due to results
Comment 3 tommy27 2014-01-05 09:04:36 UTC
*** Bug 44340 has been marked as a duplicate of this bug. ***
Comment 4 Joel Madero 2015-05-02 15:41:14 UTC Comment hidden (obsolete)
Comment 5 lvm 2015-05-05 12:03:03 UTC
repeatable in 4.4.2.2
Comment 6 Buovjaga 2016-05-13 06:05:33 UTC
*** Bug 72247 has been marked as a duplicate of this bug. ***
Comment 7 bsb_2 2018-06-25 08:31:48 UTC
Still present in Writer 5.4.7.2 (x64) - Windows 10.
Comment 8 Julien ROPE 2018-07-26 13:41:52 UTC
 I can reproduce this with :
 - Calc v5.4.7.2 on Windows 64bits
 - Calc v6.0.3.2 on Linux (Ubuntu 18.04 - 64bits)
 - Calc v6.2.0.0 (from nightly build 2018/07/26) on Linux
Comment 9 Julien ROPE 2018-07-26 13:46:27 UTC
(In reply to bsb_2 from comment #7)
> Still present in Writer 5.4.7.2 (x64) - Windows 10.

The bug is about Calc, and the initial reports says it works on Writer.
I actually tested it and couldn't reproduce it with Writer.

Can you confirm you're seeing it there too?
What are your steps?