Bug Hunting Session
Bug 39289 - landscape format prints as portrait and sometimes truncates long lines
Summary: landscape format prints as portrait and sometimes truncates long lines
Status: RESOLVED DUPLICATE of bug 44664
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.1 release
Hardware: x86-64 (AMD64) Linux (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-16 14:16 UTC by Gavin Flower
Modified: 2013-11-13 19:51 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
long line truncation (9.82 KB, application/vnd.oasis.opendocument.text)
2011-07-16 14:16 UTC, Gavin Flower
Details
EXEMPLE of document (8.89 KB, application/vnd.oasis.opendocument.text)
2011-11-11 07:29 UTC, pierre.5933
Details
Sample PDF scan of incorrect printer output (58.42 KB, application/pdf)
2011-12-20 14:38 UTC, Fred Olness
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gavin Flower 2011-07-16 14:16:08 UTC
Created attachment 49186 [details]
long line truncation

Affects LO 3.4.1 and LO3.4.2RC1.

I had a very long line, so I selected landscape mode.

However, when I went to print, it came out as portrait, and the end of the very long line was truncated.

I made an example document.

I found that a line of contiguous characters that was longer than the page width was printed correctly showing the extra characters wrapped.  However, a lines of various 'words' had the last 'word' truncated!
Comment 1 Gavin Flower 2011-07-22 07:58:03 UTC
Still a problem in LO3.4.2RC2
Comment 2 Gavin Flower 2011-07-31 15:01:22 UTC
Still a problem in LO3.4.2RC3

Correction to the symptoms:
Regardless off whether a line wraps in landscape mode: any text that would show on the same line in landscape mode, in the extra width, is truncated when it prints. Only the the first part of the overflow line is printed

I really feel this bug needs addressing before 3.4.2 is released, surely this is important to Enterprises?
Comment 3 Rainer Bielefeld Retired 2011-11-10 22:25:07 UTC
NOT Reproducible with reporter's sample and "LibreOffice 3.4.4RC2  - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:402)]" on Samsung CLX-3185FN:
- Menu 'Format -> Page' shows "Landscape 297mm width 210mm height
- Document shown as landscape in Page preview
- Document shown as landscape in Print preview
- Menu 'Print -> General -> Printer Properties shows "landscape", scaling 100%

@Gavin Flower:
Unfortunately information you provided is muc too rare. We need ALL available information. at least for example
- OS Printer setting
  -- Defualt paper size
  -- Default paper orientation
  -- Printer Language
- Printing from LibO
 -- Menu 'Format -> Page' shows?
  -- Page preview shows?
  -- Print preview shows?
  -- Menu 'Print ...' shows?
Comment 4 pierre.5933 2011-11-11 07:29:25 UTC
Created attachment 53403 [details]
EXEMPLE of document

This page has to bee in landscape appearance , when I print it I fet a portait form and just the letters A to O are printed , 

abd it begins at the second third of the page
Comment 5 pierre.5933 2011-11-11 07:47:21 UTC
I Have tried to explain my problem with a odt file but it seems that it is not possible

It is described here 

https://bugs.freedesktop.org/show_bug.cgi?id=42777

With libreoffice 3.4.2 
  000340 m1 (buid(206))

when I create a document in landscape appearence when I print it I get just the left part of it and it begins just at the second third of the page

If I save it in pdf form I can print it with acroread or evince (gnome)

I Use Suse distribution x86*64 11.4 and 12.1 version

Thanks
Comment 6 Rainer Bielefeld Retired 2011-11-11 10:33:11 UTC
NOT reproducible with new sample document and "LibreOffice 3.4.4RC2  - WIN7 Home Premium (64bit) Spanish UI [OOO340m1 (Build:402)]"
Comment 7 Fred Olness 2011-12-20 14:36:27 UTC
I have verified this problem on two separate systems: Scientific Linux 5, and Ubuntu 10.4 with LO 3.4.4. Print preview shows landscape, but is sent to printer
in portrait mode and right side of printout is truncated. I verified this is independent of any printer setting, and have tried this on a HP4200 and HP1022 printers--the problem is independent of the printers. 

IMPORTANT: I then used OpenOffice 3.1.1 with the above to verify the document did print properly--same compter, same OS, same printer; only the software changed. 
This convinces me it is not an external printer setting or OS system setting. 

I have attached a PDF scan of the incorrect output.
Comment 8 Fred Olness 2011-12-20 14:38:01 UTC
Created attachment 54612 [details]
Sample PDF scan of incorrect printer output

This is a scan of the incorrect output. The document prints incorrectly 
no matter what settings are used in LibreOffice -- portrait or landscape.
Comment 9 Caolán McNamara 2012-02-27 02:21:19 UTC

*** This bug has been marked as a duplicate of bug 44664 ***