Bug 39365 - Spell check does not work after copy / paste, modified language not recognized
Summary: Spell check does not work after copy / paste, modified language not recognized
Status: CLOSED DUPLICATE of bug 40449
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other All
: medium major
Assignee: Caolán McNamara
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2011-07-19 01:48 UTC by Rainer Bielefeld Retired
Modified: 2016-05-01 13:41 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample document, pls see original report! (11.23 KB, application/vnd.oasis.opendocument.text)
2011-07-19 01:48 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-07-19 01:48:18 UTC
Created attachment 49290 [details]
Sample document, pls see original report!

When I open an existing document with English Text  with Master "LibO-dev 3.4.5  – WIN7  Home Premium  (64bit) English UI 
[(Build ID:d337f79-a24c961-2865670-9752b71-7f8fd43
	2fdd60d-fd28b6a-fd7bf20-aa369cb-28da3fb
	6a9633a-931d089-ecd263f-c9b55e9-b31b807
	82ff335-599f7e9-bc6a545-1926fdf)]"
everything seems to work fine, Auto spell check underlines wrong words, and when I type a nonsense sentence like "This is some nonnsseennssee here" the wrong spelled word will be underlined.

But when I copy / paste text with wrong words those wrong words will no longer be recognized.
Additionally changes of character language will not be recognized correctly, when I modify language to something without existing dictionary and then modify back to English, Spell check will no longer work.

Please see attachment for more details!
Comment 1 Cor Nouws 2011-08-24 02:05:55 UTC
Does not work at all for me in build Build ID: 117281b-4eb4f62-260b7c1

Exmaple: work in French text, or Dutch text
with ditionary installed and correct language set for text.
  > all words are marked
  > I can add them to the list Default
Comment 2 Rainer Bielefeld Retired 2011-08-24 03:03:06 UTC
@Cor:
That's a confirmation?
Comment 3 wope 2011-09-06 08:33:35 UTC
This is an old error, already existing in OOo 3.0.
There was a Bug http://openoffice.org/bugzilla/show_bug.cgi?id=48509 from 2005-05-01 :(
Comment 4 Rainer Bielefeld Retired 2011-09-06 09:14:59 UTC
I take Cor's comment as a confirmation.

Worked with 3.4, so regression

Same roots, related to or DUP of "Bug 40449 - SPELLCHECK does not recognize text language"? That one seems to cover the problem of this one, my current results with Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI [(Build ID:  3b32204-7f92fce-2ba0a9f)]": Spell check does not work at all, after <f7> Text language pane empty in spell check dialog.

I discussed that on IRC with 'wope', this one is NOT the same as <https://issues.apache.org/ooo/show_bug.cgi?id=48509>. There the language information is lost in the character format dialog, here in the spell check dialog.

This is a major one, WRITER without any spell check - unimaginable!

@Caolan:
I saw you active in some Linguistic Component SPELL check bugs. Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 5 Caolán McNamara 2011-09-08 13:24:23 UTC
Fairly sure this is a manifestation of the same root problem

*** This bug has been marked as a duplicate of bug 40449 ***
Comment 6 Jean-Baptiste Faure 2016-05-01 13:41:53 UTC
Keyword regression added from comment #4.