Download it now!
Bug 39376 - Hang when try to open .odt on public ftp via hyperlink in ODF document
Summary: Hang when try to open .odt on public ftp via hyperlink in ODF document
Status: CLOSED DUPLICATE of bug 34880
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: Other All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-19 07:48 UTC by skeld_stu_1999
Modified: 2013-12-18 00:48 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Backtrace for libreoffice crash (921.70 KB, application/x-gzip)
2011-07-19 12:02 UTC, skeld_stu_1999
Details
Backtrace for libreoffice crash 2 / 5 (1.21 MB, application/x-gzip)
2011-07-19 12:04 UTC, skeld_stu_1999
Details
Backtrace for libreoffice crash 3 / 5 (1.71 MB, text/plain)
2011-07-19 12:05 UTC, skeld_stu_1999
Details
Backtrace for libreoffice crash 4 / 5 (1.75 MB, text/plain)
2011-07-19 12:05 UTC, skeld_stu_1999
Details
Backtrace for libreoffice crash 5 / 5 (2.92 MB, text/plain)
2011-07-19 12:06 UTC, skeld_stu_1999
Details

Note You need to log in before you can comment on or make changes to this bug.
Description skeld_stu_1999 2011-07-19 07:48:26 UTC
Creating,an hyperlink to a document in a FTP, the writer crashes and close
after press Ctrl + click, for a ODT document.

 For PDF or TXT for exemple it's OK.

 So the problem seems to be just for ODT extention.
 For ODS extention the screen just blink and nothing happens.

 Steps to reproduce this problem:
 1- create files in a ftp, like ftp://ftp-corp.myplace/global/test.odt
 2 - right button on the file and option ''copy link"
 3 - open the writer (new file) , in the blank page option ''insert'' >
 "hyperlink"
 4 - option "internet", then select "FTP"
 5 - paste the hyperlink copied
 6 - apply and close
 7 - on the hyperlink press Ctrl + click
 8 - at this point the writer crash and close (this for an ODT
  file)

 PS: for an ODS file at this point the screen just blink and do nothing
 PS2: for an PDF or TXT file it's OK

 Using: Ubuntu: Ubuntu 10.04 LTS - Lucid Lynx - LibreOffice/Openffice 3.3.2

 Correct result: open an ODT document linked to a FTP by an hyperlink on the
 writer.
Comment 1 Jeffrey 2011-07-19 08:14:48 UTC
Failed to reproduce on LibreOffice 3.4  340m1(Build:103) for OpenSuse Linux. Perhaps different platform or version of LO. Thanks for the clear steps though. See if you can get the backtrace of the crash by following this: http://wiki.documentfoundation.org/BugReport go to "How to get backtrace on Linux". Thanks!
Comment 2 noname 2011-07-19 11:45:09 UTC
Is that the link from your internal ftp site, coz it's just not accessible from this end ?!
Comment 3 skeld_stu_1999 2011-07-19 12:02:41 UTC
Created attachment 49308 [details]
Backtrace for libreoffice crash

LOG 1 / 5
In this file:

name of a station = estacao-1455821
name of ftp server is like = ftp-xxx-yyy
ip address are like = xx.yyy.yyy.x
Comment 4 skeld_stu_1999 2011-07-19 12:04:06 UTC
Created attachment 49309 [details]
Backtrace for libreoffice crash 2 / 5

LOG 2 / 5
In this file:

name of a station = estacao-1455821
name of ftp server is like = ftp-xxx-yyy
ip address are like = xx.yyy.yyy.x
Comment 5 skeld_stu_1999 2011-07-19 12:05:14 UTC
Created attachment 49310 [details]
Backtrace for libreoffice crash 3 / 5

LOG 3 / 5
In this file:

name of a station = estacao-1455821
name of ftp server is like = ftp-xxx-yyy
ip address are like = xx.yyy.yyy.x
Comment 6 skeld_stu_1999 2011-07-19 12:05:56 UTC
Created attachment 49311 [details]
Backtrace for libreoffice crash 4 / 5

LOG 4 / 5
In this file:

name of a station = estacao-1455821
name of ftp server is like = ftp-xxx-yyy
ip address are like = xx.yyy.yyy.x
Comment 7 skeld_stu_1999 2011-07-19 12:06:51 UTC
Created attachment 49312 [details]
Backtrace for libreoffice crash 5 / 5

LOG 5 / 5
In this file:

name of a station = estacao-1455821
name of ftp server is like = ftp-xxx-yyy
ip address are like = xx.yyy.yyy.x
Comment 8 skeld_stu_1999 2011-07-19 12:11:34 UTC
(In reply to comment #2)
> Is that the link from your internal ftp site, coz it's just not accessible from
> this end ?!

Hi there, 
Yes it's internal. The description is just an example that you can reproduce in your enviroment. 
In a internal ftp some people put some reports and qhen they use the hyperlink to an ODT file in libreoffice, the writer crash and close.
For an PDF file for exempla, the same procedure is OK.
Comment 9 skeld_stu_1999 2011-07-19 12:16:31 UTC
(In reply to comment #1)
> Failed to reproduce on LibreOffice 3.4  340m1(Build:103) for OpenSuse Linux.
> Perhaps different platform or version of LO. Thanks for the clear steps though.
> See if you can get the backtrace of the crash by following this:
> http://wiki.documentfoundation.org/BugReport go to "How to get backtrace on
> Linux". Thanks!

Hi there, 
I had to broke the backtrace in five files. In this backtrace we try access ODS and ODT files.

At the end of this test, the log is:
242  16:39:49.019319 lstat64("/usr/lib/ure/lib/libuno_cppu.so.3", {st_mode=S_IFREG|0644, st_size=186204, ...}) = 0
5242  16:39:49.019753 write(2, "terminate called after throwing an instance of '", 48) = 48
5242  16:39:49.019867 write(2, "com::sun::star::lang::WrappedTargetException", 44) = 44
5242  16:39:49.019955 write(2, "'\n", 2) = 2
5242  16:39:49.020057 rt_sigprocmask(SIG_UNBLOCK, [ABRT], NULL, 8) = 0
5242  16:39:49.020137 tgkill(5242, 5242, SIGABRT) = 0
5242  16:39:49.020197 --- SIGABRT (Aborted) @ 0 (0) ---
5251  16:39:49.020369 <... ???? resumed> ) = ? <unavailable>
5289  16:39:49.020511 +++ killed by SIGABRT +++
5252  16:39:49.020538 +++ killed by SIGABRT +++
Comment 10 Rainer Bielefeld Retired 2011-07-19 23:45:43 UTC
Not reproducible with "LibreOffice 3.4.1  - WIN7  Home Premium (64bit) German UI [OOO340m1 (Build:103)]".

@Reporter
Can you please try a more current version?
Also a problem in CALC /others or only in WRITER?
If you do not want to loose your reliable 3.3.2 please try
<http://wiki.documentfoundation.org/Installing_in_parallel>!

For further reports: 
Can you please try to find a more powerful zipper and follow hints on
<http://wiki.documentfoundation.org/BugReport#What_to_include_in_bug_reports> (experimental upload page) if the result still exceeds 3MB?

@Christopher:
Seems to be a known UBUNTU problem ( See Also: Add Bug URLs), can you please add hints in launchpad?
Comment 11 skeld_stu_1999 2011-07-20 09:11:41 UTC
(In reply to comment #10)
> Not reproducible with "LibreOffice 3.4.1  - WIN7  Home Premium (64bit) German
> UI [OOO340m1 (Build:103)]".
> 
> @Reporter
> Can you please try a more current version?
> Also a problem in CALC /others or only in WRITER?
> If you do not want to loose your reliable 3.3.2 please try
> <http://wiki.documentfoundation.org/Installing_in_parallel>!
> 
> For further reports: 
> Can you please try to find a more powerful zipper and follow hints on
> <http://wiki.documentfoundation.org/BugReport#What_to_include_in_bug_reports>
> (experimental upload page) if the result still exceeds 3MB?
> 
> @Christopher:
> Seems to be a known UBUNTU problem ( See Also: Add Bug URLs), can you please
> add hints in launchpad?

Today a tried with Libreoffice 3.4.1 in:
Windows Vista Business
Windows XP
both with all pathces included.


The same result for a ODT file in a FTP Libreoffice crash, may be you could try : Ctrl +click and a second Ctrl + click in the link.

This problem occurs for CALC too. In the test I had two file (writer and calc) opened, when the problem occurs in calc file both (means Libreoffice) ws closed.

But in version 3.4.1 there is a message tell us "...there is a problem...will bem close.." (in version 3.3.2 there is not a message, just crash and close)
Comment 12 skeld_stu_1999 2011-07-20 09:19:54 UTC
As a partial solution, we oriented the users to convert files to PDF and put a FTP hyperlinks to this files. For PDF files its ok in version 3.3.2 and 3.4.1.

For reproduce the problem you could try a CTRL + click and so a second Ctrl + click on the ftp  hyperlink (the first ctrl+click some time do nothing).
Comment 14 noname 2011-07-20 13:56:30 UTC
Unconfirmed with [Win2K LibreOffice 3.4.2 OOO340m1 (Build:201)].
Doesn't crash at all. LO seems to load the file, but after some time gives a small window saying "General Error. General input/output error.".

Also doesn't crash with [Win2K OpenOffice.org 3.2.1 OOO320m19 (Build:9505)ooo-build 2010-07-18]. But this one loads the file as it should.
Comment 15 Rainer Bielefeld Retired 2011-07-21 02:04:37 UTC
I believe I begin to understand the Problem. [Reproducible] with "LibreOffice 3.4.1  - WIN7  Home Premium (64bit) German UI [OOO340m1 (Build:103)]", also with Master "LibO-dev 3.4.5  – WIN7  Home Premium  (64bit) English UI 
[(Build ID:d337f79-a24c961-2865670-9752b71-7f8fd43
	2fdd60d-fd28b6a-fd7bf20-aa369cb-28da3fb
	6a9633a-931d089-ecd263f-c9b55e9-b31b807
	82ff335-599f7e9-bc6a545-1926fdf)]"

If you want to try to reproduce the problem you can simply use attached "mytest.ods" and click on the first link or follow my instruction:

1. open new WRITER document
2. Type "x"
3. Select "x"
4. Click 'Hyperlink' Icon in Standard Toolbar
   Hyperlink dialog opens
5. switch to this page in Browser
6. Right click on first link in Comment 13
7. Context menu: Copy Link
8. Switch back to ne WRITER  Document
9. Paste link into link Pane as FTP link  <ok>
10. Save document
11. Click "x" for hyperlink (ctrl+click, if you selected this option
    in security settings)
    Expected: "StringConcreteSyntax1.odt" from FTP should be opened in WRITER
    Actual: nothing, after a short while (1/2 minute) LibO stops responding

Opening "StringConcreteSyntax1.odt" directly clicking Link in Browser works without problems.
Opening "StringConcreteSyntax1.odt" from HDD, anything alse as step 1-11, works without problems.
Opening "StringConcreteSyntax1.odt" via Explorer from HD works without problems.

Still some questions remaining, problem might be related to document.

@reporter:
Please add on public FTP 5 additional documents:
a) Calc Document "A.ODS" only containing a simple "x" in A1
b) Draw Document "B.ODG" only containing a simple circle

@xdmx, @Jeffrey:
Can you confirm my results?
Comment 16 skeld_stu_1999 2011-07-21 05:39:28 UTC
The tests are corrects. The diference in my tests is that Libreoffice crash and close. 

Here others publics FTPs for test with ODS, ODG and ODP files (OK for PDF):

ftp://ftp.cefetes.br/Cursos/Matematica/Oscar/Dados_pessoais.ods
     (about 13kb)

ftp://ftp.cefetes.br/Cursos/Matematica/AlexJordane/Estatistica/Dados.ods
       (about 10 Kb )

ftp://ftp.griland.com/ooffice/oodraw-export-pdf-test.odg
       (about 48Kb)

ftp://ftp.griland.com/ooffice/test.odp
       (about 50Kb)
Comment 17 Jeffrey 2011-07-21 07:32:07 UTC
@Rainer,

Thanks for the steps. Yes LO seems to crash when I do this. Using the same version as previously reported.
Comment 18 Rainer Bielefeld Retired 2011-07-21 09:10:20 UTC
Crash also with new documents as expected.

I prefer the simple documents as requested because I want to exclude that the contents is part of the problem.

@skeld_stu_1999:
Can you please contribute such simple test documents as requested?
Comment 19 skeld_stu_1999 2011-07-21 10:12:17 UTC
(In reply to comment #18)
Sorry but I don't have access in a public FTP to put simple files as you ask.
Because of this I tried find out ftp in universities and other public entities for testing.
Our FTP is just internal.
Comment 20 noname 2011-07-21 11:10:17 UTC
@Rainer

Sorry, LO still doesn't wanna crash on my system. I've got the same results with the odt file as reported before. File still loads fine with Go-oo 3.2.1 and gives a 'general error' with LO 3.4.2 RC1.

With the ods file it's a little different. There is a small delay before you can do anything, you can see the hand (same as when using CRTL). But it disappears after 20 secs or so, after which LO (and go-oo, btw) tries to import the file (I can see my I/O). But the file doesn't get loaded in calc. No error window this time. But still no crash.
Comment 21 Caolán McNamara 2011-08-16 03:23:16 UTC
I can't reproduce a crash, but I can reproduce the failure to load a ftp document. I'm going to hazard that this is a duplicate of bug 34880 and fixed with http://cgit.freedesktop.org/libreoffice/core/commit/?id=3ae98a0ca5329a0205728a46b4e5dd0d4b46a9f3

*** This bug has been marked as a duplicate of bug 34880 ***
Comment 22 Björn Michaelsen 2011-12-22 05:51:50 UTC
RESOLVED, FIXED or CLOSED bugs cant be KEYWORD NEEDINFO.
Comment 23 Björn Michaelsen 2011-12-24 04:44:15 UTC
closing