Bug 39481 - FILESAVE: Word 2007 XML .docx discards formatting on blank lines.
Summary: FILESAVE: Word 2007 XML .docx discards formatting on blank lines.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 46937 (view as bug list)
Depends on:
Blocks: DOCX Character
  Show dependency treegraph
 
Reported: 2011-07-22 11:30 UTC by William Cattey
Modified: 2017-05-14 04:09 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Demonstrates test case for whitespace. (8.74 KB, application/vnd.oasis.opendocument.text)
2011-07-22 11:39 UTC, William Cattey
Details
Whitespace test case output via SaveAS Word 2007 XML docx (3.47 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2011-07-22 11:40 UTC, William Cattey
Details

Note You need to log in before you can comment on or make changes to this bug.
Description William Cattey 2011-07-22 11:30:45 UTC

    
Comment 1 William Cattey 2011-07-22 11:39:08 UTC
Created attachment 49436 [details]
Demonstrates test case for whitespace.
Comment 2 William Cattey 2011-07-22 11:39:51 UTC
Repeat by:

Create OOo document with a blank line between two lines of text.
Set the formatting of the blank line to a  non-default font, and a non default size.  For example, Times Roman 5 point (such as one would use for a little bit of whitespace between sections.)
Save in default odf format.
SaveAs Word 2007 XML format.

Expected behavior:
Blank line should retain font and size.

Actual behavior:
Blank line gets the default font and size.

Going back to the odf version, the blank line is properly recorded, but
is never properly saved/restored in .docx format.

Work-around:
Never use specially formatted blank lines for controlled white spacing.
Instead set the Paragraph formatting for additional white space above or below.

Reason why this is important:
Some resume submissions must be in docx format.  People's resumes are getting silently mutilated, and formatting is REALLY important here!

Example files are attached.
Comment 3 William Cattey 2011-07-22 11:40:45 UTC
Created attachment 49437 [details]
Whitespace test case output via SaveAS Word 2007 XML docx
Comment 4 Jeffrey 2011-07-24 20:16:35 UTC
Confirmed for LibreOffice 3.4  340m1(Build:103) on OpenSuse Linux. This seems to be another problem involving saving as .doc files or importing .doc files.
Comment 5 Björn Michaelsen 2011-12-23 12:20:44 UTC Comment hidden (obsolete)
Comment 6 Florian Reisinger 2012-08-14 13:57:18 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 7 Florian Reisinger 2012-08-14 13:58:40 UTC Comment hidden (obsolete)
Comment 8 Florian Reisinger 2012-08-14 14:03:13 UTC Comment hidden (obsolete)
Comment 9 Florian Reisinger 2012-08-14 14:05:28 UTC Comment hidden (obsolete)
Comment 10 sasha.libreoffice 2012-09-28 12:40:25 UTC
reproduced in 3.6.1 on Fedora 64 bit with first attachment.
msWord opens result without separate of empty line
Comment 11 Marc Kaulisch 2013-04-16 21:19:48 UTC
I can confirm this behaviour to be still included in LO 4.0.2.2 on Windows 8.
Comment 12 Jorendc 2014-04-21 22:50:51 UTC
Looks fixed, tested using Mac OSX 10.9 with LibreOffice Version: 4.3.0.0.alpha0+
Build ID: 619b4c40da9e85febbb08a3f7cf8aa8d10963fc1
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2014-04-18_00:07:53

I know this is fixed by one of the synerzip developers (as far I remember).

Looks the imported font with your text document is 5,5pt instead of 6. Other font sizes are saved correctly as far I can see (tested using Word for Mac 2011).

Marking as RESOLVED WORKSFOMRE.
Comment 13 Jorendc 2014-04-21 22:59:56 UTC
*** Bug 46937 has been marked as a duplicate of this bug. ***
Comment 14 Marc Kaulisch 2014-06-27 11:36:29 UTC
Sorry, but this bug is only partially solved (in LO 4.3.0.1 Windows 8.1). It seems like the font is saved and preserved correctly but not the font size. Saving a 7 point size is reopened in docx as 6 point size - the 6 point size is opened as 5.5.

It seems that bug https://bugs.freedesktop.org/show_bug.cgi?id=46937 is definitely still valid.
Comment 15 Marc Kaulisch 2014-08-11 11:30:42 UTC
font size problem with docx is still valid in 4.3.1.1
Comment 16 Marc Kaulisch 2014-11-24 09:07:15 UTC
looks to be fixed in 4.4.0.0.beta1
set to resolved/Worksforme - because do not know if it is deliberately fixed...